Display resolution

Please post logs.

Sure: https://paste.osmc.tv/faxuxeteso

Playback start of 4K file with empty whitelist and UI resolution at 1080p. The TV says the playback comes out as 1080p. I took the liberty of obscuring some personal paths and file names.

Have you tried pressing the “info” or “exit” button on your TV remote to see if that makes it go away. I have one TV that would sometimes get a signal from the help function of a harmony remote that would get the information overlay of the TV stuck on and require manually dismissing it.

Yes, I have tried this, but before the update everything was ok.
But with the solution gave by Grahamh (Adjust display refresh rate> On start/stop), solve my problem. When its a 4k file now the Kodi automatically adjust the resolution to 2160p.

1 Like

Your file has a very non-standard resolution:

[WHITELIST] Searching the whitelist for: width: 3838, height: 1604, fps: 23.976, 3D: false

Kodi doesn’t know what to make of it.

I’m a bit surprised that whitelisting 1080p modes would cause problems - that might be a bug. But it’s expected behaviour that your video is downscaled if the whitelist is empty. With nothing whitelisted, Kodi is able to switch resolution upward, but only if the video dimensions exactly match one of the available output modes. So, it can switch from 1080p to 2160p if the video is 3840x2160, but if the video is something like 3838x1604 then it can’t. You would definitely need to whitelist 2160p@23.98Hz to get it to play at 4K.

Whitelist guide: (click here)

If the whitelist doesn’t seem to be working the way it’s supposed to, that would be interesting to know about.

Argh. Looks like I chose just the right file for my tests. :roll_eyes:

But thanks a bunch for your prompt help.

Kodi looks for a (more or less) exact match to the width and height of a supported display mode. Both 3838 and 1604 are way off so there’s no match. It then searches for a desktop resolution with the correct framerate (but only if whitelisted) . We added a search for higher resolutions than the video frame but with the exact framerate (to help with TVs that had 4k50 but not 1080p50). With 4k24 whitelisted (only) that gets picked. So whitelist is working exactly as intended.

1 Like

So, are you saying that to get his video to play at 4K, he has to de-whitelist 1080p/23.98Hz, and that this is actually expected behaviour? If so, that’s rather surprising. It would make far more sense to upscale to 2160p/23.98 rather than downscale to 1080p, surely? It should search for a higher resolution with a matching frame-rate before it falls back to using the desktop resolution. And I’m fairly sure it did that under Leia.

If this is standard behaviour now, I’ll have to update my guide to reflect that…

1 Like

Odothan, if it is the case that it plays at 1080p if 1080p/23.98 is whitelisted then I suggest you whitelist that mode anyway and switch resolution to 4K manually during playback.

1 Like

Let me check. ATM it will choose 4k as long as either the width or the height matches a whitelisted resolution and the refreshrate is not supported at the GUI resolution and width is greater than GUI width. Your suggestion of picking 4k while playing the video is a good one.

I’m sure I remember, a few months back, a thread by a guy who had a video that was 2560x1440. With standard settings it was being downscaled to 1080p, but after enabling the whitelist it played at 4K. I guess it’s possible that (contrary to instructions) he only whitelisted 4K resolutions, but I think it’s more likely that the behaviour is different now. (And the old behaviour made more sense, IMO).

If I recall correctly, the behaviour under Leia was tweaked a bit in OSMC relative to standard Kodi behaviour. Could it be changed here too?

If I’m understanding that correctly, I can’t see the point of the second condition at all. That means you’ll have to de-whitelist all 1080p modes to get anything to play at 4K! And the first condition doesn’t seem right either - as I said, if you have something like a 2560x1440 video, you want that upscaled to 4K, not downscaled to 1080p, even though neither dimension matches an output mode precisely.

1 Like

My bad, should have said … and whitelisted width or height are greater than frame width or height (respectively).

Aha! You are right - in Leia the checks are in a different order. I’ll get that corrected and that should solve the OP’s problem. Thanks and thanks to @Odothan.


Oh, that makes more sense! :rofl:

So, what exactly is the logic going to be now? (Just want to check it’s reported correctly in my whitelist guide).

Erm, call me daft but I don’t know how to manually switch the playback resolution. :flushed: I can’t see it in the player video settings and the Wiki and Google won’t help me either.

Same as it was before, with the Matrix changes you have already covered there. The logic is look in the whitelist to:

  • find exact resolution at exact refreshrate [or 2x or 2.5x], if fails
  • find exact refreshrate at any resolution higher than the stream (specific OSMC tweak), if fails
  • find GUI resolution at exact refreshrate [1x, 2x, 2.5x], if fails
  • use GUI resolution and refreshrate and scale refreshrate as well as width and height
1 Like

Press OK and navigate to the icon far right in the OSD ribbon (in OSMC skin - I think Estuary has it under video options)

Assuming you mean the leftmost button in the right half of the OSD ribbon, I get this menu, which is indeed what Estuary has under video options, and this has me stumped. I can see the file’s weird resolution, but don’t know how to switch to 4K; I’ve tried all the view modes.

In the OSMC skin it’s the rightmost button at the bottom right, not leftmost. The button is only visible if the whitelist is active.

In Estuary, when you click the cogwheel button on the OSD during playback to get into Settings, there’s a menu option called “Select Resolution”.