Ditching OpenVPN for Wireguard


Thanks but unfortunately not what I’m looking for. I think you should be able to provide the service file with:

cat /lib/systemd/system/wg-quick.service | paste-log

Conf file as follows:

cat /etc/wireguard/Toronto.conf | paste-log

Or if contains any login credentials you may wish to copy and modify before uploading:

cp /etc/wireguard/Toronto.conf ~

modify with nano or vi to remove any credentials: nano ~/Toronto.conf

Then upload:

cat ~/Toronto.conf | paste-log

Regards Tom.


Please provide the out of: systemctl status wg-quick

Thanks Tom.

Tom try this, a start and stop of wg-quick.

Also here is my current wg0.conf


My current setup works correctly with these commands

systemctl enable wg-quick@wgo - boots with IP and DNS provided by Surfshark
or if not enabled
systemctl start wg-quick@wgo

What still is not working
systemctl stop wg-quick@wgo - the original DNS I provided in network setup is lost
/etc/resolv.conf is empty.


Is this with openresolv or resolvconf

Also please provide the link from:

cat /lib/systemd/system/wg-quick@.service | paste-log

Thanks Tom.

Thanks Tom got it. Did a fresh os install turned instructions into a script bingo, everything worked.
Went back to the other sdcard and purged resolvconf, worked. Connman wasn’t the problem.
Weird how manual worked but systemctl didn’t.
Once again thanks

1 Like

just in case sb stumbles over this topic (as I did) and finds the pastes are gone (as expected), I shared a small pseudo-tutorial on the other thread: