Drops in audio when playing h265 and 5.1 sound

Hi Sam,

no need for an excuse here. I just wanted to be sure, the topic ist still alive.
Here are the screenshots from the audio settings:

And the requested audio_cap file:
cat /sys/class/amhdmitx/amhdmitx0/aud_cap
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48 kHz, 16 bit

What I tested so far:
Change number of channels to 2, change resampling quality, change threshold for pitch correction - all with no success

Thanks again,


The device you are connected to is reporting only support for 2 channels, so yes, audio will be downmixed.

I recommend these audio settings:

Channels: 2.0
Output configuration: Fixed
Rest looks OK. Keep audio DSP off, because it’s broken in Kodi v17 (will be fixed in Kodi v18)

After I eat, I will try your clip on my system and see what happens.


Hi Sam,

did you had time to try the clip?

Thanks, Holger

The last update did not change anything. Any news from your side, Sam?

Hi Holger,

I did indeed try the clip. I tried the transport stream (0001.ts) which seems to be part of Eurovision.

I can replicate the audio dropouts.

I checked, and there are discontinuities in that clip.The audio is encoding as aac. This seems to be the standard for broadcasted surround these days.

Do you only experience this problem with Live TV?

Can you try disable HW Acceleration for the clip? I think it’s something we can work around, but it’s going to need a bit of work.


Dear Sam,

the dropouts only seems to be on Live TV (or recordings from Live TV) - But I don’t have any other file with h265 codec and 5.1 sound to test it.
Can you tell ne how I can disable hardware acceleration? I did try disable “settings / playersettings / videos: Allow hardware acceleration - amcodec” or to enable this and disable every other step by step.
When playing the clip from the local memory, nothing changed, when playing over the vdr plugin, not only the audio had dropouts, but the video was stuttering too.

Next I installed Kodi on my linux workstation and tried there. I had the same problem with the vdr vnsi plugin and the same problem, when playing the file locally over KODI.

Transcodiing to an mpeg4 file does not change anything, mixdown to stereo while transcoding had the same problem.

Playing the initial (.ts) file with mplayer2 works without any dropouts on the same machine, playing the transcoded files has the same kind of dropouts.

One more: When extracting audio from the ts file ffmpeg -i 00001.ts -acodec libmp3lame -metadata TITLE="OnlyWav" OUTPUTFILE.wav, the audiofile has no dropouts neither looks it (in audacity) like it’s stretched somewhere.
It seems. like it’s some kind of synnchronisation problem between audio and video.



That’s correct, you just want to disable this for testing, but if it’s not changing anything it’s not going to be a Vero 4K issue.

I thought this might be the case. If it’s affecting Kodi on other problems then it’s likely some issue with the recording itself and not something exclusive to OSMC or Vero 4K.

If you can possibly do so, can you record with a different PVR add-on and see if you still get problems?

If you also experience the problem after transcoding then this suggests some kind of issue with the source material itself. Can you try with a recording on a different channel?