DTS-HD MA doesn't work

Hello support team,

I recently realized that I have an issue with all DTS-HD MA audio sountrack, I have a nice helicopter noise instead.
All my devices are DTS-HD MA compliant and the configuration is correctly done (from my point of view). Also, I have no issues with any other audio format.
If you could help me to identify what’s going wrong, that will be great !

Please find below the requested information:

TV: TX-55HZ1000E
Receiver: Onkyo TX-NR686

Verok4k+ connected to the TV on HDMI 1
Receiver connected to the TV on HDMI 2 (ARC)
On the TV, the audio configuration is correctly setup to “Home Cinema” with Bitstream

MediaInfo: https://paste.osmc.tv/xuzatepeme.mel
Vero logs: https://paste.osmc.tv/mikuqokiyu

Although your TV supports eARC your AVR only supports ARC. In order to pass through DTS-HD MA from your TV you would need both devices to support eARC. It should work if you plug the Vero into the AVR directly.

Thanks Darwin for your reply,

Damned, I was thinking about this arc/earc but without being sure about what I was reading on Internet.

That explain why…
I will try to connect it back in direct (but if I’m right I was then facing a different issue: Vero4k was only able to send 2K resolution instead of 4K
But that’s another story (and maybe another thread ;p )

Thanks again for this prompt feedback

Well for that topic already one more hint.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Thank you so much fzinken !

I will try those settings today and will let you know (and update the thread accordingly)