DVD.ISO Menu Regression

DVD.ISO Menu Regression

Upon every update I have a handful of Movies that I test to ensure all is working as intended on both my RPI3 and Vero2.

The RPI series has had great DVD.ISO menu support for the lifespan of OSMC, playing every title we own, however note that earlier this year the VERO range received DVD.ISO MENU support for many, but not all, discs.

On Aug 15th I reported via a private post to @Popcornmix and @sam_nazarko that Menu playback from 2016.06-02 to 2016.07-01 was longer functioning normally and was instructed to post the issue on the public forum. This still appears to be the case on 2016.08-01. This is my first public post on the topic.

Desperate Housewives Season 1 Disc 1 now shows only the OSMC GUI while playing the menu sound – the same issue as it is doing on the VERO as previously reported -> this has the main menu but no adverts. http://paste.osmc.io/fubedusuku

Game of Thrones Season 1 Disc 1 now shows only Black but has sound. -> this has the main menu but no adverts. I can press OK after a bit on the black screen and it will begin playing the movie. http://paste.osmc.io/usufafekuy

Bolt now shows only Black and Grey but has sound, eventually pressing OK (once all the Advert sounds are done) allows the movie to begin. -> this has the main menu AND adverts. The Adverts will flash on and then static out, going back to black and grey from time to time. http://paste.osmc.io/qegetuboja

I retested 2016.06 on a clean RPI3 Install and the Menu playback works fine. Back to current and it does not.

Thanks Crew!

Happy Monthly Check in @sam_nazarko

I hope the traveling was refreshing and that the Krypton rebase is not proving too troubling.

1 - Have you had an opportunity to view the Desperate Housewifes DVD Menu issue?

2 - Have you had an opportunity to view the recent DVD Menu regression behaviour that cropped up in 2016.07-01?

Thanks!

It is not done just yet.

I was travelling for two weeks, and am now preparing Krypton.

Yes – I can replicate the issue with the disc you sent me. I am reluctant to work on resolving it for Jarvis, as Krypton is knocking on the door.

For Pi? I didn’t manage to replicate this issue, but Krypton test builds will come shortly. It would be interesting to know if it persists with these builds.

Sam

Understood wanting to wait for Krypton, no worries.

Yup, for Pi. The Desperate Housewives menu DID work on the Pi prior to 07-01. It has never worked on V1 or V2. I would be happy to pick up another SD card for checking DVD Menu functionality on a Krypton Test build if you like. Let me know when to poke :wink:

@sam_nazarko

Dusted off my RPI2, v 2016.05-01 which has been untouched since May/June.

  • Played Desperate Housewifes season 1 Disk 1, Main Menu, Play all → works fine
  • Played GoT Season 1 Disk 1, Adverts, Main Menu, Play all→ works fine
  • Played Bolt, Adverts, Menu, Main movie→ works fine
  • http://paste.osmc.io/relacijeje

Updated via OSMC GUI to v2016.09-01

  • Played Desperate Housewifes season 1 Disk 1, Main Menu, Play all → works fine
  • Played GoT Season 1 Disk 1, Adverts, Main Menu, Play all→ works fine
  • Played Bolt, Adverts, Menu, Main movie→ works fine
  • http://paste.osmc.io/jucudaguxi

Updated via SSH to 17 Krypton Beta as per [TESTING] Kodi 17 (Krypton) Beta Builds for all platforms
… and lost the custom home screen folders/mappings…

  • Played Desperate Housewifes season 1 Disk 1, Main Menu, Play all → works fine
  • Played GoT Season 1 Disk 1, Adverts, Main Menu, Play all→ works fine
  • Played Bolt, Adverts, Menu, Main movie→ adverts black, menu fuzzy but functional, movie works fine

Now time for the RPI3, v 2016.09-01 which has received every update within a day or so of release

  • Played Desperate Housewifes season 1 Disk 1, Main Menu, Play all → v2 behavior, plays sound but stays on OSMC GUI
  • Played GoT Season 1 Disk 1, Adverts, Main Menu, Play all→ displays all black screens, eventually pressing OK twice starts the movie
  • Played Bolt, Adverts, Menu, Main movie→ blue sad face
  • http://paste.osmc.io/laniqolizi

So STRANGE that rpi2 that has not been updated since May, when updated to the latest and greatest plays all the Menus fine, but the rpi3 which has been updated religiously has the DVD MENU issues!

Now time for the Vero2 17 Krytpon Beta

  • Played Desperate Housewifes season 1 Disk 1, Main Menu, Play all → v2 behavior, plays sound but stays on OSMC GUI
  • Played GoT Season 1 Disk 1, Adverts, Main Menu, Play all→ All plays fine
  • Played Bolt, Adverts, Menu, Main movie→ All plays fine

@sam_nazarko

I just updated the RPI2 (beta) after seeing the update available flash via the GUI.

Looks like someone has been giving DVD.ISO with menus a little love :slight_smile:

  • Desperate Housewifes season 1 Disk 1, Main Menu, Play all → works fine
  • GoT Season 1 Disk 1, Adverts, Main Menu, Play all→ works fine
  • Bolt, Adverts, Fastplay Menu, Main Menu, Main movie→ works fine

GREAT WORK & Thank you.

Should I spend a little time pounding on the Vero2 DVD.ISO menus again?