Fatal error after the first update- SOLVED

Hello, I received my Vero 2 yesterday. This morning I started installing it and after configuration I run the update from MY OSMC. After he installation the system rebooted and now I have the following :
FATAL ERROR: Could not find root file system device /dev/Vero-nand/root - if this is a USB install please check the USB drive is connected.
OSMC initranfs Rescue Console.

What can I do now?

Solved reinstalling from SD. The first trial failed then I changed the SD and I reached the goal. Which type of SD are usable for Vero2? Because apparently both the SD I tested have the same caracteristics but only different capacity.

A new update was available (why if I used the 2016.09-1 release?) and again I had the Fatal Error. Now I’m not able to restart from SD. How is it possible? What can I do? How can I force the boot from SD card?

But to be honest I suggest you wait till either @sam_nazarko or @DBMandrake show up on this thread and give advice as something seems to be wrong

That shouldn’t happen, but it’s very possible that a package only got pushed to Release slightly later than the image build time (although this is rare). Here are my suggestions:

  • First, make a note of any extra peripherals in the Vero. If you have several hard drives, or you’re using an extension chord the device may not be getting enough power
  • Download, and install the 2016.09-1 release from osmc.tv/download.
  • Run sudo apt-get update, and then sudo apt-get dist-upgrade. Make a note of which packages it offers to upgrade and put them here.
  • After this, run sync && sudo reboot

You will need to install OSMC to your SD card again. We delete the partition table of the installer off the SD after successful installation so that you don’t get in a boot loop of constantly installing OSMC, and so that users cannot accidentally plug the SD card in their device later and erase their internal storage. I would prepare the card again before trying the toothpick method.



Thank you Sam I’ll do it this afternoon.

Great – let me know how you get on

Done and solved. I didn’t have any peripheral connected but the remote dongle.
The packages upgraded are the following:
armv7-splash-osmc base-files base-files-osmc bind9-host e2fslibs e2fsprogs
gnupg gpgv libbind9-90 libc-bin libc6 libcomerr2 libdns100 libgcrypt20
libgudev-1.0-0 libidn11 libisc95 libisccc90 libisccfg90 liblwres90
libmysqlclient18 libpam-systemd libpolkit-agent-1-0 libpolkit-backend-1-0
libpolkit-gobject-1-0 libpython2.7 libpython2.7-minimal libpython2.7-stdlib
libsqlite3-0 libss2 libssl1.0.0 libsystemd0 libudev1 libxml2 locales
multiarch-support mysql-common openssl perl-base policykit-1 python2.7
python2.7-minimal systemd systemd-sysv tzdata udev vero2-kernel-osmc wget

I hope this can be useful for your job.
Thanks again.

Thanks – I’m not sure why you had an issue after updating but I’m glad it’s resolved now.

Looking in to the reason you had to update, even with the latest image, it looks like there was a problem preparing the 2016.09-1 filesystem for the Vero 2 (APT mirror temporarily went down); so the installer picked an older one. I’ll rebuild the filesystem and installer now, thanks for reporting, and I’ll add a check so this can’t happen again.

P.S. in future, you can mark a topic as solved by clicking the Checkmark on the post that helped you


Sam, for your information I tried again to update the system using Myosmc and I had the same result.

It is expected that you would also see an update in My OSMC if apt-get dist-upgrade shows packages are to be updated too. Provided the update has gone through without issue, you’ve nothing to worry about :). A new updated 2016.09-1 image will be published shortly.

I received my Vero 2 today and have had exactly the same issue, so it does seem to be a repeatable issue today.

I’ve used the OSMC installer to generate an reinstallation SD card but the Vero 2 doesn’t recognise the card, which is a Kingston 32 GB device. I’ll try a different SD card tomorrow but I’m wondering whether the Vero 2 requires a particular type or capacity of SD card.

Also, for info, the on-screen error message when the device fails to boot refers to http://osmc.tv/help but that specific URL doesn’t exist - it redirects to the home page. It may be helpful to put some recovery instructions on that page.

Don’t use Kingston SD cards – they’re not very reliable or highly recommended, mainly due to low 4K IO performance and problems with some SD controllers.

The URL was updated on 27th September

I’m not aware of any significant issue affecting OSMC or re installation on Vero 2, but I’ll obviously keep an eye out. Let us know how you get on. When you say ‘exactly the same issue’, elaborating would be helpful, just so we can confirm if you have a similar problem



Although the symptoms look identical, I’ve started a new thread to avoid hijacking this one.

Thanks, that’s appreciated, as OP didn’t seem to have an issue reinstalling. I will follow up on it shortly.