Frameskipping in the most 1080p files

I don’t know if this will solve your issue.
But the new video scheme will land in this month’s update.

I am trying to see if there are any commonalities between you and the other user.


@sam_nazarko I will upload a sample to you in a couple of hours :wink:

This both come with the next update and you have a suspicion that our problem will resolved too? So i have to wait for the next update and hope the best… anything what we or i can test or do to help? When the next update doesn´t solve the problem nor we find another solution for it i must send both Vero back…


Well, could be. But still we have done tests and it seems clear that it is only happening with 23.976fps content. And how to explain the problems not appearing with 50/60fps fixed settings? Is the buffer maybe bigger then and can keep up?

I’d like to install the March version, but I don’t have a micro SD card… :expressionless: Can the image only be installed via SD card?

I’m sorry to say that I’m getting a bit unpatient with this problem… Have done a lot of testing and invested days into this already and a solution is just a maybe until now. And now I would have to invest more money than I already did on the Vero itself to buy an SD card that I wouldn’t need otherwise. It’s very frustrating and at the same time I really hope, that I don’t have to send the Vero back aswell. :confounded: Can @MikeDelta and me at least maybe test your improvements for the next update soon and maybe already see, if the problem might be resolved?

As I said, I can’t say that an update will fix your problem, because I don’t know what your issue is. There are a lot of these devices in the wild now, and if this was widespread we would be getting a lot of posts about this.

  • Can you record the screen when this happens, so we can get on the same page re. what you’re seeing?
  • Can you try a fresh install from, with no add-ons and try playing back an affected movie from the eMMC (if it fits), or a fast USB drive.

Yes – they will be made available for testing before the next update, so we can get some feedback from a large number of users.

There are plans to allow reinstallation via USB in the future or the embedded recovery; but for now a micro SD card is needed. It would be really useful to know if the March update exhibits these issues for you @Chillbo.

I am reading through this all again in detail. There have been a lot of posts in a short time so it’s making it a little tricky to decipher what’s going on, but I am sure we will work it out.

I appreciate your frustration but can only fix things when I understand what the problem is. In particular I need to understand why this is affecting you and not others.

Having looked at the framerate skips for 4K post, it looks like that user’s TV doesn’t advertise a preferred mode, which means that Adjust Refresh Rate may not be working as expected.

The reason I’m not quite sure this is the issue is because you say that the issue only occurs after a significant period of watching TV. If it was really a 23.976Hz issue entirely, I’d expect you to see stutters immediately


Just with any camera I have at my disposal? First, describing it to my best of my abbilities: I can see stutter in movement of characters on screen or when the camera is panning - movements get choppy every now and then. Mostly, the stutter is not regularely. So, there’s not a stutter every so and so seconds, but there’s one, maybe another one, a couple shortly after another, then a break. Sometimes, with the same file, the skipping count jumps up to well over 120 until the clip is finished, sometimes it’s less. And the skips always occur at the beginning and at the end of file when framerate adjustment is enabled. But, I guess, that’s normal, isn’t it?

I will, but first I have to get hold of a micro SD card…

Awesome! Please let us know then and we can test!

It wasn’t meant as moaning to you, just, obvisouly, would love to just enjoy my Vero 4k as it provides everything I want from a Kodi box on paper.

Does this apply to us, too? I guess not, right? But one of the symptoms that user described sounds a lot like ours here:

But it looks like the stutter is kind of “building” up… No stutter first, but after about 20-30mins it starts. In my understanding that looks very much like a buffer runs out e.g. or something gets so out of sync that the device has to skip frames. And that obviously does only happen with 23.976fps. I don’t have a deeper understanding of things, just trying to make sense of all this.

Has Kodi a record function build in? Otherwise @Chillbo have made a good description what we see…

I do some tests with the second vero without any Addins installed, so this is a fresh installation with the march version of your software - the same error occures here!

So for helping that you understand what i see when frame skipps occured i try to make a shot with my HD Camcorder from a affected file later when i´m back at home…will share them on dropbox when it´s not too big…


I can produce an installer which will run off USB for you, to save you the trouble of getting a micro SD card. You can test it and let me know if it works :slight_smile:

Yes – any camera. Doesn’t need to be a work of art or anything. Just need to be able to see the problem.


That would be sweet! Thanks a lot, I’ll test it…

Will do that today or tomorrow.

Hi @sam_nazarko… i´ve made two shots with my Sony HD HandyCam…

first a scene played with the vero (my second with the installed march version and without any addons, fresh installation after unpacking the box) and when the frame skipping occurs first time while playing at 23 minutes… hope the shot is good enough to see the frame skips…

second a short sample from the same scene played with my himedia q10 without any frame skips…

Played with the same equipment (hdmi cable, network cable, a/v receiver), only change the boxes!
Hope this help to “see” the problem!


@Wuschel_Wuschel… can you see the Slkippings and is this the same what you have?

I see the skipping, of course… As I see it, it’s not only skipping, but it also results in huge stutter and very strange slow motion playback.
For me, it’s just skipping. So, some small stutter when a frame is missing. There is no slow motion or lag visible. I’ll provide a video later.

Having viewed your videos, i seem to be suffering the same issue and have frustratingly tried everything suggested including a fresh install and playing back the video from the eMMC and haven’t got to a solution yet.

I have exactly the same problem on my Vero 4K :(.
Only difference is that I have buffermode enabled in advancedsettings.xml so I can see on Codecinfo screen forward option that is cca. 56 MB 100% at beggining of movie playing,

Maybe strange thing is that after some time forward has same value (cca. 56 MB) but 100% is droped to 10% or less. I dont know what that “% value” means …

Like you, neither I cant find pattern when frames starts or stops to skip… but disturbs enjoying of movie watching.

Also I tried to play movie from USB memoy stick and result was also skipped frames during playing.

I never seen this problem with my RPi2 with OSMC.

@sam_nazarko… seems that this problem is much bigger than expected…

Just sent @sam_nazarko my recording made on the March version without any addons/plugins and only framerate adjustment and HDMI/passthrough settings altered. Skips again…

In some way, I’m “glad” that it’s not only a problem for @MikeDelta and me. Thanks for sharing, @soupladel and @Zendra! It looks a bit to me like more are experiencing it, but as there is already a thread about it, they seem to wait for a solution here. But, if more have that problem, please let the developers know! It’s not such a minor issue obviously :expressionless:

I had previously weighed in on the thread here:

stuttering video

so i do suspect there perhaps more people are suffering from the issue and are perhaps just not saying anything because they have seen threads where there problems are described and are patiently waiting for a solution rather than nagging for it.

If it is of any help, I have the same issue the last days on my Rpi0w with 720p files. Without having updated to April/May version.

osmc@myosmc0:~$ uname -a
Linux mysmc0 4.4.27-12-osmc #1 PREEMPT Fri Mar 17 19:54:16 UTC 2017 armv6l GNU/Linux

Using nfs mount through fstab

Rpi3 does not have the same problem, running the same version

osmc@myosmc:~$ uname -a
Linux myosmc 4.4.27-9-osmc #1 SMP PREEMPT Tue Mar 14 20:54:19 UTC 2017 armv7l GNU/Linux

Maybe an update on then main pi3 running the nfs server?
nfs-kernel-server version 1.2.8-9
And I see an new nfs version has been released on 2017-03-25 for strech 1.3.4-2

Totally different topic as this issue is related to Vero4k and the people have already excluded the network as the source for their issue. Please open a new thread

If vq: drops to 10% you are going to have a buffering issue.