Frameskipping in the most 1080p files


#22

So, my last test is done. The log playing the very same mkv file as before from my NAS share mounted via fstab: https://paste.osmc.tv/dudadojoti
It generated 112 skips and 1 drop. So, no change at all. From my side, I think, I have done all I can to demonstrate the issue… It definitely is a network playback issue. This issue wasn’t there before and is quite a downer for the overall usability of my Vero 4k.

As the issue hasn’t been there in the past, my network hasn’t changed at all, other users like @MikeDelta seem to have the same issue and the behaviour of when skips occur are not correlating with usage of the NAS at all and the read and write speeds (~90-100MB/s and ~30-35MB/s) of the NAS are constantly high, I can’t see any reason why this issue wouldn’t be related to the Vero 4k itself.

Hope, it can be fixed! If I can be of any more help, plz tell me and I will help…


@MikeDelta The way I mounted via fstab is this:

  • add this line to /etc/fstab (change permissions first or write via sudo command/admin ssh login; replace “…” with the according info, delete “” afterwards)

//“IP of share”/media /mnt/media cifs x-systemd.automount,noauto,iocharset=utf8,user,username=“username of share”,password=“password of share”,uid=osmc,gid=osmc,iocharset=utf8,file_mode=0770,dir_mode=0770 0 0

  • create folders in /mnt according to what you entered in the fstab file before (the /mnt/media part)
  • reboot system and access videos via the /mnt/media path (e.g. by adding that path to the video library)

#23

Hi,

You could try adding kodi video cache to advanced settings, as advised above (2nd post)

Thanks Tom.


#24

My post (#16) and the debug log attached with it shows that I already tried that… Didn’t help.

Maybe I did something wrong, then plz tell me.


#25

apologies I missed that.


#26

No problem! I wrote a lot, so… :wink:

@sam_nazarko Any idea maybe what the problem could be and if it might be possible to solve the problem? Or maybe something else I should try?


#27

Ok, bad luck! I cannot mount the shares directly via fstab, the Emby for Kodi Plugin doesn´t support that - i use the Emby Server as Backend Database and mount the shares via smb in the Emby for Kodi Plugin… so i hope a solution for this problem will be find, meanwhile i have to watch movies with my Q10 Pro… :frowning:

If anything i can do to help please let me know!


#28

You could still try and mount a directory of your SMB share just to test with one file…

Doesn’t need the whole database for that, does it? Just to see, if it’s the same behaviour as I had it.


#29

@sam_nazarko… I´ve mounted smb via fstab and play a 70 minute mkv - frame skips occurs again!

Full set of logs here: https://paste.osmc.tv/ugibocanof


#30

I think that Kodi 17 have some problems with frame skipping that occurs only in some situations.

I opened a thread, that was closed and hidden by mods, about problems with frame skipping using the library throught and addon.

But then I see people that have problems of frame skipping with the same behavior that I described: when you open the OSD the playback goes well, until you hide it and it start having frame skip again. This is other situation (not the library + addon that I described) https://forum.kodi.tv/showthread.php?tid=289498&pid=2521901

@MikeDelta, can you test if you display the information OSD (the typical screen that appears when you click I in a keyboard that shows the media name, the current played time and the total time) you stop getting frame skip? And if you hide the information / go again to full screen playback the frame skip comes again? Is to see if this have the same behavior (you can see real time frame skip information on screen with some keyboard shotcut, this web http://kodi.wiki/view/codecinfo say that is letter “o”)


#31

The problem occurs with or without the OSD - after first time i noticed frame skips at the last weekend i try to stop/pause/restart the affected movies without luck and i don´t think this is a general Kodi problem, because i have a Himedia Q10 Pro and a Q5 Pro and both Player with Kodi 17.3 installed plays the same movies from my NAS without frame skippings - this problem affected only on the Vero 4K!


#32

I can confirm that it has nothing to do with menus or layers over the video played back. Skipping is always occurring or it is sometimes not, no matter what. And I guess, we have made quite clear that it’s only a problem when playing back a network video file…
And that the problem has shown up some time ago, not related to Kodi 17 and clearly only related to Vero 4k.


#33

Hi MikeDelta and @Chillbo,

Have you considered sharing the videos via nfs, as this tends to have better throughput; which should help this issue?

Thanks Tom.


#34

I haven´t setting up nfs shares yet, my complete Emby Mediathek is shared via smb! I have to set it up for testing, but Wuschel_Wuschel wrote that the problem occurs after the April Update… I can´t believe that the Vero 4k can´t play those files without problems via smb!?..


#35

Edit the title of this post, because i have frame skipping in all of the last watched files…


#36

Hi,

I’m not sure if its related, but another user is having an issue with frame skipping with 4k files. They have reported if they set “Adjust display refresh rate” to off, there is improvement.

Could you please advise on current setting for “Adjust display refresh rate”, @Chillbo could you please advise as well?

Thanks Tom.


#37

@Tom_Doyle… Setting is enabled on start/stop!

Hope this will be fixed, cannot use the vero with this problem in my environment!


#38

Well, for the sake of testing, I’ll try nfs later and disable frame rate adjustment in another test. I have set it to enabled on start/stop normally, too.

But @MikeDelta is right, without SMB and framerate adjustment, two main features of Kodi are missing…


#39

Hi,

Appreciate you testing these options, will help the developers get closer to working out what the issue is.

Thanks Tom.


#40

Will configure NFS when i´m back at home later! This is much work for me, have to configure access rights, proof to compatibility with the Emby Server, etc. but i´m wiilling to help as much as i can. But disable “Adjust display refresh rate” isn´t an option for me, because playing all 24fps content with 60fps isn´t smooth and a bad experience! Hope that this issue will be solved, like the box and the user experience and have ordered a second one for my bedroom but with this problem i cannot use them with my environment and have to send both back…


#41

Hi,

Have you tried adjust frame to always, as we are not sure what is causing the issue; setting it to this option may reveal more.

Also could you please on the rest of your settings #player, videos?

Thanks Tom.