Frequent random muting, then freezing

You seem to have turned off the free memory summary at the top of the display - which makes evaluating your screenshots a bit difficult. Also you are not sorting based on memory usage, but by the looks of it based on CPU usage, which also makes it impossible to gauge overall memory usage. (of other processes)

Although 188MB res is higher than I’d like to see I doubt this is the cause of your problem on a Pi 2 which will still have plenty of free memory.

ok, yes I did but I see what I did wrong now when I ran TOP and didn’t configure it right. I will try again and watch the other processes for anything unusual.

Ive just run the same tests again… just the same as before but this time it happened much quicker before the sound stopped and the freezing video occurred…
Started with a reboot, then a screen shot from TOP before any videos where played…


Then played some videos, not from start to finish but a few minutes of each and also fast forward, reverse, pause, randomly and leaving the video running while going back to menu screens and returning to the video playing. I noticed the REZ getting higher but no other processes changing in the next screenshot…
Then the sound stopped when I played another video but nothing changed in TOP in this next screenshot…

after that the video started freezing and took a few seconds to exit back to the movies menu screen when I pressed stop. I tried to play another video I had previously played but it kept freezing. I took another screenshot at this point.

Then I uploaded the logs…

http://paste.osmc.io/gogegoyata

Hope this is of use to someone

Nick

I think you can rule out excessive memory use as a cause of your problem.

It’s very hard to make anything out of that log file as its extremely long, so without knowing exactly what time the problem occurs (relative to the timestamps in the file) it’s like searching for a needle in a haystack.

Could you reproduce the stall problem just once and take a note of the exact time that the stall occurred and the exact time that it recovered and include those times when you post the log ?

Also I may have missed it as I have only skimmed the thread, but where are the files playing from, or is it a stream ?

ok, will do on Sunday. I’m playing the files from a USB hard disk.

Also, I looked through the log myself and I think I have possibly found the point when the audio drops out completely as the highlighted comments don’t appear before this point…

@ntate6630 I have seen your issue. With enough starting and stopping creating the audio stream can hang, and that needs kodi to be restarted to fix. It is not a memory issue.

I don’t think it is the issue others have reported. This issue only occurs on start of stream - I don’t believe it will occur in the middle of video playback.

The alsa sink doesn’t have this issue. While not generally recommended, I’d be interested if you can try that and confirm you get the same behaviour. You’ll want “dtparam=audio=on” in config.txt (I believe that is a default), and make sure snd-bcm2835 is not blacklisted in /etc/modprobe.d. You should then be able to launch kodi and choose the alsa device in system/audio settings.

I do have a potential fix for this. It works but it’s not the right fix - I really need a colleague to look into the underlying cause and it’s next on his list.

@popcornmix, I did as you suggested…

Set “dtparam=audio=on” in config.txt. Previously I had it set to “off” because of an issue that came up with the January update… (January update now iqaudio dac not working?)
…and was expecting the sound to go back to the HDMI instead of “IQaudIO PiDAC +” but it didn’t change.

There is no blacklist.conf file in /etc/modprobe.d so nothing to edit in nano so im assuming that means “snd-bcm2835” wont be blacklisted.

Next I rebooted with logging turned on, opened terminal, started TOP, took a screen shot at time “21:45” before any videos were played… This was the same as before so didn’t feel the need to post it here again unless anyone wants it.

Next I play various videos on my USB hardisk, also fast forward, play, stop, change video, play, fast forward, stop etc. until the occurrence of the sound dropping out again which I can confirm the sound does drop out and the videos freeze again. The video starts playing with no sound after several seconds and if I stop a video it takes several seconds again before returning to the movie selection screen instead of instantly.

I took another screen shot of TOP at time “22:12” similar result as before so no need to upload here unless anyone wants it… “RES” was “96032” at this point.

After this I uploaded the logs. http://paste.osmc.io/idixoworik

Can you also change resample method from GPU to medium in system/audio settings.

Ok will do, and then repeat as before.

It seems to be working OK for now as I haven’t had the sound drop out yet or any video freezes but will need more testing for longer duration of time to confirm its better. I will try again on Sunday.

Thanks

Nick

Hi,

does the latest (February) update saves this problem?

Hi

I haven’t given up on finding the issue, but unfortunately there has been a lot of ‘noise’ / +1s in this thread and it’s made it tricky to work out what the issue may be.

The kernel remains unbumped from 4.4.1, but it may be worth trying the updated Kodi build to see if anything has improved. However for those experiencing issues with USB drives, I suspect it won’t make a difference

Sam

As far as I’m concerned, I’ve been using the updated kernel since its release a week ago, and the “random muting then freezing” has vanished for me (so far).

Thanks!

It only happens now if I set the GPU resample method to GPU instead of medium in system/audio settings. I will still use the GPU setting for audio only playback which has no problems at all. It would be great to have the GPU setting work properly for video because the audio quality is greatly improved in all cases, but maybe that’s a lesser priority at the moment.

Same for me, setting GPU resample to medium solved the random freezing.

Hi Sam
I can confirm (after a few days of testing), that new version with final Kodi 16 is much better for my case with USB drives. The increasing of RES is very very slowly.
Thank you very much for this version.
Regarding support of HEVC codec I tested a few files (also 720p), but without succes - no picture, only sound.
Do you have some sample file with HEVC codec which working on RPi2?
Thanks
Jan

Needs to be 8-bit hevc. Post mediainfo of the file.

Hlavní
Unique ID                                : 240836847870637196474175391342571019882 (0xB52F7D5D261E03D7BE43C1995D47DE6A)
Complete name                            : Z:\Downloads\TearsOfSteel_720p_h265.mkv
Format                                   : Matroska
Format version                           : Version 4 / Version 2
File size                                : 101 MiB
Duration                                 : 12mn 14s
Overall bit rate                         : 1 153 Kbps
Encoded date                             : UTC 2013-09-04 21:15:18
Writing application                      : mkvmerge v6.2.0 ('Promised Land Rovi v1.0.4') built on Aug 29 2013 13:59:38
Writing library                          : libebml v1.3.0 + libmatroska v1.4.0

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main@L6.2@Main
Codec ID                                 : V_MPEGH/ISO/HEVC
Duration                                 : 12mn 14s
Width                                    : 1 280pixely
Height                                   : 720pixely
Display aspect ratio                     : 16:9
Frame rate                               : 24,000 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Default                                  : Ano
Forced                                   : Ne

Audio
ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : A_AAC
Duration                                 : 12mn 14s
Channel(s)                               : 6 kanály
Channel positions                        : Front: L C R, Side: L R, LFE
Sampling rate                            : 48,0 KHz
Default                                  : Ano
Forced                                   : Ne

It is correct?

L6.2 seems surprising. That is that absolute highest level which supports up to 8k x 4k @ 300 fps.
Do you have a link for that file?

Hi
I´m not sure what you mean (L6.2).
:slightly_smiling:
But link is hear:
http://h265files.com/

Jan

Format profile                           : Main@L6.2@Main