Harmony 650 not able to get working

Hey Guys,

I got my Vero 4k a couple of days ago and everything works fine, only the last step of adding my Harmony 650 IR remote.

I think I read all the post that had something to to with this issue but I could not find a easy to follow step by step how to.

The IR receiver is connected to the port that is closest to the side of the box and NOT next to the hdmi.
I added the Vero 4k in the myharmony tool on my mac but now I don’t know how to get further.

When I choose for example the xbox 360 config in the remote settings, nothing happens and I don’t know what the next step could be.

Thanks for your help

ps: I have the vero remote connected all the time to get through the settings while testing this or can you not have 2 remotes working at the same time ?

I also have a Harmony 650. I have chosen xbox 360 in the Logitech MyHarmony tool and xbox 360 in the MyOSMC -> Remotes menu of the OSMC GUI. (The OSMC Vero information in the Logitech database worked but I was not satisfied by reaction when buttons are pressed.)

It should work with the April and June update … but NOT if you would have a development release before June; I’m sure the box wasn’t shipped like that and you automatically got the June update while first use.

The Vero 4K remote is RF and doesn’t use the My OSMC -> Remotes configuration, so it will work fine with the Harmony.

Try removing the iR receiver temporarily.

Sam

I got it half working.

In the myharmony software I added xbox 360 as device in the activity instead of the Vero 4k
In the OSMC remote setting I choose the xbox 360 remote and indeed it kinda works.

First thing, it’s much less responsive then the official included remote.
There is a bit of delay when going through movies and such, just annoying enough to bother me.
And of course the buttons are not all correctly mapped, like the back button does nothing.

Any way to remap easily and make it more responsive or is the solutions just to use the original remote, which is an ok solution but I’m trying to get rid of all my remotes and replace them with the harmony 650.

Thanks for the support so far, hopefully we get it working all the way.

@Smurphy is a Harmony expert.

Can you help this chap out?

Sam

@kim.clerckx

Regarding IR remotes: Infrared is invisible light and you have to aim with the Harmony remote control to the Vero … and yes, this technology isn’t that responsive like the original remote control which use a radio frequency and you do not have to care in what direction you hold the remote control.

The “back” button is wrong assigned with the Logitech information in their database; they assigned the “ChannelPrev” button to it although you and me understand it intuitively as the “Back” button, see picture below.
You can simply reassign the right “Back” button function to the key you want in the MyHarmony software. Logitech is responsible for the content of their remote control database.

1 Like

@JimKnopf already said what there was to say :slight_smile:
Logitech Harmony should actually fix their settings DB.

I will soon test the Bluetooth connection though as it really is more responsive.

A post was split to a new topic: Logitech Harmony Ultimate One, Home Button

Hey guys, thanks for all the help with the logitech remote.

Eventually I got it all setup and working fine, but of course the difference in precision and reaction time made me start using the included remote again.

So far it has been a very nice experience to use the Vero 4k, I had a couple of Red crash lights yesterday but it seems to have stopped. Maybe using the Mimic theme and addons like Janitor might cause this but it seems fine for now.
If it starts crashing I’ll find my way back here again.

The speed and quality of support for the Vero 4k is unparalleled, thanks again.

1 Like

Actually, I am using the “Official” Kodi theme. Stable and fast. And the girls (got 4 in all) are able to use it intuitively. That’s all there is to say :} Just works, rock stable :slight_smile: