Hash mismatch

Added the s in /etc/apt/sources.list:

deb https://apt.osmc.tv stretch main

Still not working out:

osmc@vero4kp:/etc/apt$ sudo apt update
Hit:1 ht tp://security.debian.org stretch/updates InRelease
Ign:2 ht tp://ftp.debian.org/debian stretch InRelease
Hit:3 ht tp://ftp.debian.org/debian stretch-updates InRelease
Hit:4 ht tp://ftp.debian.org/debian stretch Release
Ign:5 ht tps://apt.osmc.tv stretch InRelease
Err:7 ht tps://apt.osmc.tv stretch Release
SSL: certificate subject name (metweb.osmc.tv) does not match target host name ‘apt.osmc.tv
Reading package lists… Done
E: The repository ‘https://apt.osmc.tv stretch Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

So what next, should I change the hostname ti metweb.osmc.tv to match the cert?
The other error message I have no idea how to remedy.

You will need to use the HTTPS FAU mirror directly or resolve the issue with your ISP.

A bit more specificity would be appreciated:

deb https://ftp.fau.de/ stretch main

This gets rid of the cert error, but still:

Ign:5 https://ftp.fau.de stretch InRelease
Err:6 https://ftp.fau.de stretch Release
404 Not Found
Reading package lists… Done
E: The repository ‘https://ftp.fau.de stretch Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I am guessing I would have to tell apt to go under this directory:

/osmc/osmc/apt/dists/stretch/main/binary-armhf/Packages.gz

to find the Packages.gz, but what would be the sources.list line for that?

You need to use the full URL. Enter apt.osmc.tv in your browser and copy from there.

Nope:

deb https://ftp.fau.de/osmc/osmc/apt/dists/stretch/main/binary-armhf/ stretch main

E: The repository ‘https://ftp.fau.de/osmc/osmc/apt/dists/stretch/main/binary-armhf stretch >Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

It should be

deb https://ftp.fau.de/osmc/osmc/apt stretch main

Yep, just go to this point, removing the last dir one-by-one and retrying, works, thanks!
sudo apt dist-upgrade running now.
Hope this will be useful for guys with ISP transparent proxy related hash sum problems in the future!

This means that your ISP is spying on you.
We are moving our services over to HTTPS in the future, but this is not possible just yet.