Hauppauge WinTV-Duet Dual DVB-T Receiver


Having now tried 6-7 releases going back as far as January 2018, I decided that there must be an issue with the App Store version of TVHeadend - to test this, I installed it as per the App Store, and then from SSH, uninstalled just the TVHeadend package (to keep the dependencies):

sudo apt-get remove *tvheadend*

Then do the needful to install TVHeadend from their repository:

sudo wget -qO- https://doozer.io/keys/tvheadend/tvheadend/pgp | sudo apt-key add

echo "deb http://apt.tvheadend.org/stable raspbian-stretch main" | sudo tee -a /etc/apt/sources.list.d/tvheadend.list

sudo apt-get update

sudo apt-get install tvheadend

sudo service tvheadend restart

Then login, scan, and this finds nearly 130 services, all working perfectly - currently this is installing TVHeadend 4.2.8-23

The options.conf for modprobe.d still needs to be altered to make my tuner work, but the firmware is installed by the App Store version of TVHeadend now, so I didn’t need to install it manually.

When installing the standard version of TVHeadend, the following packages are installed in addition to what the App Store version installs:

dtv-scan-tables dvb-apps libx11-6 libx11-data libxau6 libxcb1 libxdmcp6 libzvbi-common libzvbi0

Installing them manually alongside the App Store version unfortunatley doesn’t fix it.

Could we have the App Store version fixed please?

I can bump the TVHeadend version; but I’m not able to reproduce tuning issues with the current version.

Did you check that the mux definitions were the same?

Identical - the issue is most likely specific to my particular tuner, or (very) similar ones, but bumping the version certainly fixed it for me. The above makes it work on my Vero also - which has pleased my wife as I no-longer have extra cables in our bedroom lol

I’ll bump this for the next update


Unfortunately the version bump hasn’t corrected the tuning issue for me - if I remove the app version and replace it with the official repo version, then it still works fine. I’m happy to pull logs from wherever?

@JimKnopf found some issue yesterday or the day before.

It might help to see what TVheadend logs while you scan the muxes, no guarantee:

Have you compared the TV adapters settings between the TVheadend versions? Is anything different?
Also compare the mux settings of one you think which should work in any case.

The tuner configuration is the same on both:

As are the configured muxes:

There’s three extra muxes on the working one that don’t work, because the tuners don’t support HD.

Here’s a log from the working one: 2019-05-22 08:51:56.129 [ INFO]:main: Log started2019-05-22 08:51:56.131 [ - Pastebin.com
And another from the one that doesn’t: 2019-05-22 09:05:02.636 [ INFO]:mpegts: 538MHz in DVB-T Network - scan no data - Pastebin.com


Are there other settings visible below “Force old status”?

There is “Remove scrambled bits” - but it’s disabled on both. Then there’s just some Read-Only info