Hauppauge WinTV-SoloHD USB device on Vero4K

Your device should work as soon as Sam found the time and the means to backport these drivers, which he’s already looking into. The only extra bit needed to support your device (which is basically the same as mine) would be to add its USB ID (from the commit you mentioned). The drivers themselves should be the same.

At least Sam will now have access to at least two testers as soon as he gets the code backported from the 4.4 kernel :grin:

Cheers

I’m working on this.

have you already made any progress?

I also followed this procedure, but still no luck…

Support for more tuners is coming in the next update

Hey @olli, did you already install the latest OSMC update and check whether your DVB device now works as expected? It should be detected properly now. Unfortunately mux scanning doesn’t yet work for my (more or less identical) device, so I’m interested to hear whether it works for yours.

Thanks

Hi, my vero now runs with version 2017.05-2 and it seems to download the required firmware:

dmesg
...
[   17.697108] si2168 2-0064: downloading firmware from file 'dvb-demod-si2168-b40-01.fw'
[   17.915062] si2168 2-0064: firmware version: B 4.0.11
[   17.920923] si2157 3-0060: found a 'Silicon Labs Si2157-A30'
[   17.969018] si2157 3-0060: firmware version: 3.0.5

However, after configuring the device in tvheadend I was not able to find any channels. Probably this is the same problem you have @brevilo ?

After disabling tvheadend server I ran a locally compiled w_scan and get this:

./w_scan -ft -c DE 
w_scan version 20170107 (compiled for DVB API 5.10)
using settings for GERMANY
DVB aerial
DVB-T Europe
scan type TERRESTRIAL, channellist 4
output format vdr-2.0
WARNING: could not guess your codepage. Falling back to 'UTF-8'
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
WARNING: YOU ARE USING OUTDATED DVB DRIVERS.
        /dev/dvb/adapter0/frontend0 -> "Silicon Labs Si2168" doesnt support TERRESTRIAL -> SEARCH NEXT ONE.
main:4007: FATAL: ***** NO USEABLE TERRESTRIAL CARD FOUND. *****
Please check wether dvb driver is loaded and
verify that no dvb application (i.e. vdr) is running.

Now, I am running out of ideas.
Suggestions, anyone?

What’s the exact error message? When you run the network scan in the Tvheadend web interface you can pull up the system log by clicking on the double-up-arrow in the lower right corner.

WARNING: YOU ARE USING OUTDATED DVB DRIVERS.
        /dev/dvb/adapter0/frontend0 -> "Silicon Labs Si2168" doesnt support TERRESTRIAL -> SEARCH NEXT ONE.
main:4007: FATAL: ***** NO USEABLE TERRESTRIAL CARD FOUND. *****

That might actually be misleading and might also be due to a failed ioctl call. I’d have to look at the code to verify that though. But it’s good to have another pointer for investigation.

Cheers

This is now ticketed so will look at this soon.

Sam

Hey @olli, any improvements at your end after the June update (released tonight)?

Cheers

Running 2017.06-1 now. Still no improvement. w_scan exits with the exact same error. Do you have any idea @brevilo?

Cheers

Ah, ok. I have just read through your conversation in this thread:

If I understand correctly the only thing we can do is wait…

BTW, I got the same error in the web interface of tvheadend:

2017-07-10 20:56:36.815 linuxdvb: Silicon Labs Si2168 : DVB-T #0 - DTV_CLEAR failed [e=Inappropriate ioctl for device]

Is there anything we can do to speed up the support for this device? It would be really great. It was actually the main reason why I bought the vero4k…

When I have something to test, I’ll let you know. The best way to accelerate things will be to test regularly. We should get it in pretty soon.

@olli There’s a patched Tvheadend version available you want to try. I doubt that it’ll fix the issue for your device (as it didn’t for mine) but it’s definitely worth a try.

Cheers

If it doesn’t fix it – you know what I need :wink:

Logs.

Still the same error after installing both the July update and the Tvheadend patch:

2017-08-03 20:03:26.510 mpegts: 578MHz in M-DVBT2-H265 - tuning on Silicon Labs Si2168 : DVB-T #0
2017-08-03 20:03:26.510 linuxdvb: Silicon Labs Si2168 : DVB-T #0 - DTV_CLEAR failed [e=Inappropriate ioctl for device]

At least it’s consistent. Sam is looking into it (he actually bought a stick for that purpose!)…

Sorry to recover and old thread, But I have this device working in a Raspberry Pi3 and I am thinking in porting my system to a Vero 4K+.

Is the device currently supported in it ?

(for the pi, I had to fiddle with udev/rules.d, but it is working great).

This should work now.

Sam

Great thanks.
By the way (a little bit off topic): using this device with vero and tvheadend: is transcoding active in vero 4K+ ?

No – we do not enable transcoding for any OSMC platform; as TVHeadend cannot leverage hardware based acceleration.

Sam