HDMI sound?

Hi again!
OK - now i can reboot - and the sound is working.
the thing about the “scatchy” sound is the same though.
even after hotplugging the HDMI after reboot.

if i let the television sit for 1 - 2 minutes and then activate the remote control - the sound will be scratchy ( muffled ) at the first movement in the menu - the next entry is good enough though.

could it be an buffer issue with my television.

i will try to remove the gui-sounds and see if they disappear all together.

br Ronni

Try turning off ‘Keep audio device alive’ if it’s on in Settings. Let me know what is set there anyway.

Thanks for testing the new kernel and confirming that a more minimal approach is appropriate. That’s good to know.

A quick way to test could be with another display. I’m not quite sure what the issue is at the moment. It’s probably a bit of hassle, but if you could see if it was only introduced by my new kernel (by reinstalling from osmc.tv/download), this would be quite helpful.

Sam

Hi Sam!
Just tried to change the keep a live setting - and voila! - when i change the settings to keep audio active all the time - not glitches… what i heard - was simply the deactivation / activation of the audio-interface.

So having solved this - i think everything is working properly for now :slight_smile:

br Ronni

1 Like

Good stuff.

The idea with keeping the audio device alive is to make sure that brief menu sounds work properly, but it doesn’t work well for all receivers.

Sam