Help please I think I messed up bad

I just bought a velo 4k+ to use with my synology nas, well it wouldn’t see the drives and so I followed a official wiki on how to mount them, however I think I did something horribly wrong as I thought I had done it but then rebooted the velo and got this pop up.
Oh please don’t let me have bricked it already lol.
This is the faq I thought I was following


and this is what my velo says when I try to boot it.

Thanks in advance and sorry for being a muppet !

Hi,

I would say /etc/fstab may have become miss formated. I would attach keyboard and issue

cat /etc/fstab

take a photo of the screen and share here.

Alternatively you could reinstall:

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

I would also suggest mounting your shares via autofs, rather than fstab:

Thanks Tom.

1 Like

Thanks for the reply, which version of linux for it should I download or would you recommend to just get the image, and if yes for the image how do I go about installing it to the usb drive.

See https://osmc.tv/wiki/vero-4k/reinstalling-osmc/. This should help you.

Sam

Holding down the button for thirty seconds seemed to fix it.
Thank you very much.
Now to try and not break it again when I mount the drives.

I am a complete novice when it comes to linux so I think i may well be misunderstanding some of it.
I have tried to go through step by step on the link provided on how to mount a drive using autofs.
I don’t know how to do logs so I can show you what I have or haven’t done correctly, I tried grab-logs -f -J but nothing seemed to happen.

Hi,

Are you mounting NFS or Samba?

-f won’t help as autofs doesn’t use fstab, and for future reference the flags are concatenated, so it should have been:

grab-logs -fJ

Thanks Tom.

NFS
judging by the text I think it says the problem is -bash: syntax error near unexpected token `newline’

Hi,

Please provide the output of the following:

cat /etc/auto.master

cat /etc/auto.nfs.shares

&

showmount -e IP_of_your_NAS

Thanks Tom.

https://paste.osmc.tv/yebinoxiwi logs

osmc@osmc:~$ cat /etc/auto.nfs.shares
cat: /etc/auto.nfs.shares: No such file or directory

osmc@osmc:~$ showmount -e 192.168.0.28
Export list for 192.168.0.28:
/volume1/video 192.168.0.213
/volumeUSB9/usbshare 192.168.0.213
/volumeUSB8/usbshare 192.168.0.213
/volumeUSB4/usbshare 192.168.0.213
/volumeUSB6/usbshare 192.168.0.213
/volumeUSB7/usbshare 192.168.0.213
/volumeUSB2/usbshare 192.168.0.231
/volumeUSB3/usbshare 192.168.0.213
/volumeUSB1/usbshare 192.168.0.213
/volumeUSB5/usbshare 192.168.0.213
/volumeSATA/satashare 192.168.0.28
/volume1/Movies and TV 192.168.0.213
osmc@osmc:~$

Hi,

Still need the output of:

Also which shares are you trying to mount?

Also could you please provide the output of:

ifconfig

Thanks Tom.

sudo nano /etc/auto.master
/- /etc/auto.nfs.shares --timeout 15 browse
/mnt// <192.168.0.28>:</volume1/Movies and TV>

I am hoping to mount all of the ones listed about, so satashare to usb9 and movies and tv.

osmc@osmc:~$ ifconfig
eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC> mtu 1500
inet 192.168.0.213 netmask 255.255.255.0 broadcast 192.168.0.255
ether c4:4e:ac:28:5d:dd txqueuelen 1000 (Ethernet)
RX packets 12538069 bytes 18744626283 (17.4 GiB)
RX errors 0 dropped 3 overruns 0 frame 0
TX packets 1141813 bytes 107210630 (102.2 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 40

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 4096
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 0 (Local Loopback)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

osmc@osmc:~$

Oops give me a second pasted in wrong command

osmc@osmc:~$ cat /etc/auto.master

Sample auto.master file

This is a ‘master’ automounter map and it has the following format:

mount-point [map-type[,format]:]map [options]

For details of the format look at auto.master(5).

#/misc /etc/auto.misc

NOTE: mounts done from a hosts map will be mounted with the

“nosuid” and “nodev” options unless the “suid” and “dev”

options are explicitly given.

#/net -hosts

Include /etc/auto.master.d/*.autofs

The included files must conform to the format of this file.

+dir:/etc/auto.master.d

Include central master map if it can be found using

nsswitch sources.

Note that if there are entries for /net or /misc (as

above) in the included master map any keys that are the

same will not be seen as the first read key seen takes

precedence.

+auto.master
sudo nano /etc/auto.master
/- /etc/auto.nfs.shares --timeout 15 browse
/mnt// <192.168.0.28>:</volume1/Movies and TV>

Hi,

You will need to check to the NFS rules for satashare, as it seems to be set to only allow the nas to access it.

you need to create /etc/auto.nfs.shares, so:

sudo nano /etc/auto.nfs.shares

And then add shares, I will provide a couple of examples:

/mnt/video 192.168.0.28:/volume1/video 
/mnt/USB9 192.168.0.28:/volumeUSB9/usbshare

Once the shares are added, you can either reboot or issue:

sudo systemctl restart autofs

Thanks Tom.

Do I need to exit and save before the reboot
also i have /mnt/satashare 192.168.0.28:/volumeSATA/satashare for the satashare drive is that correct ?

Hi,

Yes.

Its correct, but you will need to log in to the synology and change the nfs rules host ip (this is under nfs permissons for the share) to 192.168.0.213; before the share will work.

Thanks Tom.

Ok done (i couldn’t see the bit where i put in a manual ip for satashare so i just said everyone like i had on all the other drives) and rebooted like you said.

Hi,

So have the shares mounted?

you can check for example:

ls /mnt/USB9

Do you see your files from your nas?

Thanks Tom.

osmc@osmc:~$ ls /mnt/USB9
1080 TV Shows 1080P Movies 4K Movies @quarantine USB9
osmc@osmc:~$

So looks like it has worked, if you give me a minute i will check to see if my player can now see the drives as mountable.

Seriously, thank you for your time so much mate. Very much appreciated.

1 Like

Ok I have worked out how to mount most of them
Satashare, usb 2 nothing happens when I click ok like I do the other drives
and Movies and TV drive is not listed at all.

https://paste.osmc.tv/niponecava
https://paste.osmc.tv/ivedexazex
https://paste.osmc.tv/ditugajifu

having to edit this one as i am a noobie and reached my post limit.

Well I think we need to look a bit deeper then.

  1. Let us ensure your fstab is clear. Please post URL of paste-log /etc/fstab
  2. Post urls of paste-log /etc/auto.master and paste-log /etc/auto.nfs.shares
2 Likes