Hotel WiFi captive portal landing solution?

I’m trying to log into the hotel WiFi while on hols and found no solution for completing the captive portal login form that is required after connecting to the WiFi.

So far I’ve tried Web Viewer add-on which fails to load the page correctly or even function in anyway regarding selecting anything.

Also tried Chrome Launcher but it won’t even launch as I don’t have Chrome browser installed and don’t know how to install.

I’m using Vero 4K+ on 18.3 and would really appreciate some help.

Unfortunately there isn’t a trivial solution for this at this time.
You may be able to tether from another device.



I’ll have a look at the chrome x-windows launcher during the day.

Try this solution:

You got to run this installer while having internet connection, then when you are at a hotel you could run this and login to the hotels auth. service and then exit the desktop and have an ip for your vero4k.

I’ve installed it on a fresh install on the Vero4k, and chromium launches okey. Chromium is located under internet, in the “start menu”. And when you exit the desktop, you go Logout on start menu, and then Logout in following window.

There have been some reports of it just starts with a black screen. If that’s an issue for you, you got the solution in the thread (increasing sleep in the scripts).

Good luck.

thanks for the helpful reply, only issue here is I only have the remote with me, no keyboard.

looks like I’m out of luck :frowning:

i recommend this one for future endevors:

Alternatively a Amazon link:

It has replaced the need for a remote completely for me, all you can do with the remote you can with this.

1 Like