How do you install samba for file sharing?

i think so it says connected in the network info

also i dont know if i have the app store or i cant find it but i think ive looked everywhere, does the app store need installing?

Starting from the top (you are using the OSMC skin?), Select MyOsmc, and then look for the shopping trolley icon. Pick Samba (smb) Server, and then go to the Install button - whereupon it should install
Derek

2 Likes

ok ive still been searching and looking at the images on google theres what looks like an osmc (desktop?) where theres a circle of features i dont have this when osmc boots i have a list on the left hand side videos, music, pictures ect

are there two versions of osmc i dont remember there beeing an option when i downloaded?

There is only one version of OSMC for any given hardware (eg Pi1, Pi2, vero,ATV…), and the home window is the same for all (as far as I know)
Half way down the list on the left hand side there is MyOSMC …
Selecting this gets that circle of options, and the lowest right hnd icon is the one I mentioned before
Derek

1 Like

Select MyOSMC

@AbleArcher,

as Derek already wrote there is only one version of OSMC and you should have in the list on the left “MyOSMC”.
Only reason you don’t have that is if you changed the skin. If that is the case I suggest to (at least for a moment) change the skin back to OSMC to go to the APP Store why MyOSMC.

wow ive spent over 2 hours tring to install samba and i cant believe i didn’t see myosmc on that list once, i know im a little hungover but even still! my eyes were blind to it and as soon as it was mentioned it appeared on my screen, no wonder i couldn’t find any info on it cause its so bleeding obvious,

ahh well installed now took like seconds!

should i be able to see it on my pc now as in should it show in my network or do i need software on my pc so i can file transfer to my Pi?

Probably, but it may not spontaneously appear in your network locations list on Windows due to the historic issues plaguing Windows/Linux samba integrations. Reboots of both systems may resolve this or, you may have to enter \ip.of.your.pi in windows explorer (not internet explorer) to access it though you may be able to set it then as a mapped location.

thanks for all the replys i spent over 2 hours doing something that should have taken seconds so im going for a walk and clear my head i’ll have another look at this when i get back, hopefully with fresh eyes :blush:

all working now thanks for the help

Hi,
Is there a way to install samba from the store via ssh command line ?
I understand installing from the store is not the same as installing via apt-get install samba
When I install from the store samba works properly for me, when I install from ssh with the above command line it does not.

The reason I want to install from a command line is, I am deploying osmc on a headless system without a display ( for audio ).
To install samba from the store I need to hook up a display which is a tough thing given my use case scenario.

TIA
-SF

I guess that sudo apt-get install smb-app-osmc would do the job.

Well as a backup I always suggest to have a VNC on hand it helps if something in Kodi gets stucked.

Thank you. sudo apt-get install smb-app-osmc did the trick for me.

I got the Smb intalled from the app store, but it only share the /home/osmc/…
How can I share my hdd too?
Mounted in /media/hd


edited:
found it!
Just had to edit the /etc/samba/smb.conf

Careful with this as smb.conf may be overwritten causing you to lose your settings, you should really have any customisation in smb-shares.conf instead.

2 Likes

Disks are automounted and shared anyway, so you shouldn’t need to make any changes

1 Like

Don’t edit /etc/samba/smb.conf - your changes will get overwritten in future updates. It very clearly says not to do this in the comments section within smb.conf :wink:

You should not need to do anything for your external drives to appear as shares automatically. Did you reboot after installing Samba ?

1 Like

Hi,

how could I prevet this? I dont want to share all my files.

Thanks.

never touched this before, but here we go…

get all the instruction from the smb.conf file:
cat /etc/samba/smb.conf

make a copy of the conf file:
sudo cp /etc/samba/smb.conf /etc/samba/smb-local.conf
edit the conf file:
sudo nano /etc/samba/smb-local.conf
comment out the bits you don’t want by adding a hash # at the start of the line.

restart the samba service:
sudo service samba restart
Have a read:
https://www.samba.org/samba/docs/using_samba/ch06.html

1 Like

You sir are a legend. I had to sign up to thank you. Since reinstalling my last instance of OSMC I couldn’t figure out how to see my external HDD library from my windows pc. This fixed it. Thanks again.