How to change Wi-Fi password?

Hi there! :wave:

My OSMC setup was doing well and then yesterday I changed my Wi-Fi password for security reasons and wanted to change it on my Raspberry Pi using the GUI with My OSMC but the connexion times out when I try to enter the new password and I can not forgot my WiFi network within My OSMC … :sweat:

Can somebody help me please? :pray:

I tried to connect using SSH with wired connexion however I don’t know how to proceed in


How can I delete my network in the command line to connect to it again after with the right settings?

Thank you in advance for your time and help! :slight_smile:

This has worked for me through the GUI before. The only problem is knowing exactly what you are entering (from a hardware keyboard) as the password is hidden. I’m never sure if the caps lock is working. Also, a hardware keyboard is always assumed to be US English so if you have a different kb you have to do some translation.

And try disabling WiFi then re-enabling it.


Sorry to hear your having issues. As Grahamh has reported it should work with no issues through the gui. It maybe worth trying again with debug logs enabled, so we can see whats going on; details of which can be found here.

If you still wish to proceed with using ssh, a connman cheatsheet can be found here

Thanks Tom.

1 Like

I had the same issue as qgrisez.
Kept the same SSID but changed the passphrase and OSMC always failed to connect to the network.
So I followed the advice of Tom_Doyle and gone into SSH but it failed also with connmanctl…
I went radical and moved into /var/lib/connman folder and ran:

sudo rm -r wifi_(MACAddress)_*


I then was able to connect to my WiFi through the GUI settings.
Surely there’s the need of a “Forget network” inside MyOSMC -> Network.