How to install CouchPotato and SickChill on Raspberry Pi


Nice to hear that you finally solve all difficulties :smiley: I hope you manage to solve the following task :wink:
You’re welcome and thank you for compliment!


Hello! I installed CP and SB but I get a weird message. Whenever I reboot or shutdown my Pi I get the message “A stop job is running for SickRage daemon (1m 30s)” And I have to wait one minute and thirty seconds for it to conclude. Any ideas on what may be wrong? I installed everything with the manual instructions.

Thanks in advanced!


Connect with ssh, and try following:
sudo nano /etc/systemd/system/sickrage.service

Under ExecStart add following:

Ctr+x, Y, enter.

It should look like this:

Description=SickRage Daemon


ExecStart=/opt/sickrage/ -q --daemon --nolaunch --datadir=/opt/sickrage



You’re a genious!!! :smiley:
Thanks so much for the fast reply!
Happy new year!


Hello and thx for this script. It should theoretically also work on a vero or vero2 right?
Just one info concerning the sickrage github branch:
SickrageTV branch is the old one, all devs except one apperantly moved to this branch:

There are some words of one sickrage member explaining internal problems as reason for moving from sickragetv branch…but at the moment I can’t find the corresponding article…
Maybe you can change that in your howto and script.
Once I get my vero2 I’ll try it :slight_smile:


sudo git clone sickrage
change to
sudo git clone sickrage


…obviosly, yes. maybe @nenad could change it in the scripts and in the howto.
I’m sure there are people who just download the script and don’t read this whole tread :wink:


Theoretically it should work on every edition of osmc, even it’s vero :slightly_smiling: Thank you for information, I updated the scripts and howto.


Just want to say, GREAT SCRIPT, works perfect.
Thank you very much

And as Morte said,


besgum,Thank you! :smile: I made changes in scripts and in howto, did you try new link or one before 4days?


I used the old one (before 4 days) but I manually change the sickrage repo, let’s wait for some feedback from new users


After some weeks using couchpotato, I get several errors related to permissions. I have this question: after create couchpotato user, which password have this user?

I will try to change my couchpotato user preferences to “couchpotato” instead OSMC, but I don’t know the password for this user.



I don’t think that user couchpotato has password. I recommend to check what persmission is set to couchpotato and download folder.


ls -lh

This is how it’s should be for couchpotato folder


Thank you for your quick answer, @nenad. I mean that wrong permissions are in torrent download folder, not in server app folder. Specifically, renamer plugin can’t rewrite names inside download/** (movie) folder.

I dont know why. Couchpotato has setup OSMC as a user in settings. Also, movie folders, inside download folder, has OSMC as a user and group (OSMC:OSMC). But, then, renamer has no permissions to write (showing an error in log).


no problem, i think that this command should resolve issues:

sudo chmod 775 -R /path to your download folder


Yes, I tried, but new folders for new movies are created with 755.


Then you should try this command on folder where you have movies. You can try sudo chmod a-x /folder with movies
Or sudo chmod a-x -R /folder with movies


Ok, I did it, and it works with the present folders. Although I think it does not work with folders that will be created from now. This folder will be created with 755 again. So, I think I should run this command every time a new movie folder is created from transmission. I will tell you :slight_smile:


Did you run script or install manually? Try this command to give couchpotato permissions from osmc group. Maybe user couchpotato doesnt have enough permissions, because it’s not in group OSMC.

sudo usermod -a -G osmc couchpotato


Yes, I did it some days ago. The scenario seems to be this:

couchpotato user belongs to OSMC group
Folders with movies are created osmc:osmc and 755 (group can’t write)

So, couchpotato user, as OSMC member, can’t write new movie folders.

I think this issue should be solved if new folders can be created automatically 775 instead 755, but I don’t know how to do it.

I did install manually. Do you recommend me to reinstall it from script?