How to install CouchPotato and SickChill on Raspberry Pi


Can you try to use this command, maybe there aren’t enough permissions with cochpotato and use it on your Movies and Completed Movies folder.

I totally missed your folders permissions, it should be like you have it in folder Series:

drwxr-xr-x 11 osmc osmc - Movies
drwxrwxr-x 2 osmc osmc - Series

That means, root user can read,write and execute.
But osmc users can only read and execute. And the same for everyone.

Root and osmc users can read,write and execute, but everyone can read and execute.
This is how it should be, because couchpotato runs with user couchpotato, which is in the same group like osmc.


Root|osmc|everyone (7 7 5)

First letter d is for dir aka folder.


I tried that suggestion but no luck. I ended up reinstalling Couchpotato and a first test seems to work well. I’m trying another few to see if they get renamed as well…


Weird thing :slight_smile: does it now work fine? Or yoi have the same problems?


No, not at all. I’ve downloaded a few more movies and they were all processed correctly. I think something must’ve gone wrong with permissions the first time and that was corrected with the new installation. Anyhow, glad it works now! Thanks for the help!


You’re welcome :wink: Happy to hear that is working now and maybe will this help somebody in future :smiley:


You Sir are a legend. This was too easy.

You should create a deb package for this :slight_smile:



I get this erros: “Problem setting permissions or writing file to”. I’m already did chmod 777 at this folder.


Any help? My problem is with downloaded folder, I run “sudo chmod -R 777 FOLDER” and works. But new files and folders downloaded keeps with no permissions.


Which program do you use for downloading torrents? Transmission? Did you install it via osmc store? I believe one person already have same problem and he fix it with reinstallation.


I use transmission and installed from store but I’m already reinstalled.


Ok, can you please tell me the location of downloads folder? Maybe are there problem with parental folder, did you check permissions before and after if are the same with parental folder or folder on top?


My download folder is “home/osmc/downloads” and complete folder is “home/osmc/downloads/complete”. I checked now my permissions: “osmc”, “downloads” and “complete” is 777 and “home” folder is 755.


That is not good idea, i have got bad sectors in half year on the sdcard on rpi1, if you have external drive or usb flash drive, try to move location there. Maybe just for test. And before using folder, take permission with 775. That should work.


I have to move my download folder? Can I set to download at /home/Downloads and /home/Downloads/Complete instead /home/osmc/Downloads?


Maybe is better if you create new folder for example /home/osmc/torrents and under that two folders like Completed and incompleted, then you set folders permissions. After this you need to change download path in transmission. If this doesnt work, then you should probably do this on external drive. Example: /media/usbdrive/downloads


I create /home/osmc/Torrents/Complete and Incomplete like u said. Lets see if solves my problem.


“/home/osmc/Torrents/Complete/” didn’t worked, same error. Now I’m trying “/media/usbdrive/Torrent”


Worked!! I moved “Complete” folter to external HD and now it’s ok. Thanks!! My other question is about sickrage update, when I used with Openelec, I get sickrage update almoast every week and now everytime I check for updates I get nothing.


Finally :smile: hmm, how did you install sickrage? There are two versions, one is older which doesn’t get updates. Second is new version with updates, maybe you could install new version.
Try this:
sudo service stop sickrage
cd opt
sudo git clone sickrage
sudo chown -R sickrage:sickrage /opt/sickrage
If doesnt work, then first rename old version of sickrage.
Maybe you could look at notifications in sickrage, if are enabled to shows them on kodi. Or look on official sickrage github for version number and compare to your on rpi. If are the same, then you are on the latest if not, then you can see how behind is it. Here is a link of sickrage versions numbers:


This is my version:

I installed with automatic script. Should I reinstall like u said?