How to use Netflix on OSMC (RPI2)


#25

Probably yes. I haven’t tried it because I don’t have account to neither of these services (not accessible in my country and I am too lazy to setup DNS or VPN). But there are plugins in kodinerds repo (it si a repo of german kodi enthusiasts). Here you can find a manual to install Amazon on kodi 18:

kodinerds.de -> Amazon Instant Video

It is in german, obviously. You can use google translate to read it if you want, but actually my manual above is almost the same. The only thing you have to do differently is add kodinerds repo and install prime and/or skygo plugin.

But be wary. I haven’t tried it and you have to upgrade to unstable branch of osmc. Anything can go wrong.


#26

thank you


#27

Hi folks, I did a write-up about how to install instant video and netflix on OSMC with Kodi 18. Check it out here: https://laclaro.wordpress.com/2017/10/14/rpi-streaming-station-with-amazon-instant-video-and-netflix/

Cheers

Henning


#28

Wondering why you make it complicated with first download to PC and the scp to OSMC. Why not also use wget as you did later wget -O netflix.zip https://github.com/asciidisco/plugin.video.netflix/archive/master.zip


#29

That’s true. Adjusted.


#30

Also why not link to the GMC post here for the latest Leila builds and instructions


#31

Also true. Same info was linked, but that source is indeed more recent :wink:


#32

Are raspberry license keys required? MPEG-2 and VC1 ? Most of netflix content will be H.264, right?

To install pycryptodomex you need first to install the deps:

sudo apt-get install build-essential libgmp3-dev python-dev

And to install latest pip:
wget https://bootstrap.pypa.io/get-pip.py
sudo python get-pip.py

Don’t we also need widevine?
wget http://nmacleod.com/public/libreelec/getwidevine.sh
sudo sh getwidevine.sh


#33

Thank you for the hint about pycryptodomex. I found a different solution which does not involve python-pip. However, to directly use a python package is cleaner.

The required libs of widevine are installed automatically to /home/osmc/.kodi/cdm/ during the process. I don’t know exactly when though. Maybe it is already content of Kodi 18 or some plugin pulled the files.

Best,

Henning


#34

So I managed to get Netflix installed and mostly working on my Raspberry Pi 2. I am however having issues when actually playing a video. If I use Hardware Decoding with OMXPlayer all I get is garbage video with the audio track. If I uncheck OMXPlayer in the OSMC Player settings then the video shows properly but it stutters severely as its using Software Decoding. OMXPlayer seems to work well with movies stored on my NAS just not Netflix. I apologize for not having logs to add, I’ll see if I can get some tonight. Just wondered if anyone else is having this issue. I haven’t seen anything similar on the Netflix App Github.

Thanks,
Robert


#35

Aye, same issue as rspierenburg, log below…

03:15:18.271 T:1958871040 WARNING: Previous line repeats 40 times.
03:15:18.271 T:1958871040  NOTICE: VideoPlayer: Opening: http://localhost:49757/manifest?id=80117698
03:15:18.271 T:1958871040 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
03:15:18.272 T:1153430512  NOTICE: Creating InputStream
03:15:28.973 T:1153430512  NOTICE: Creating Demuxer
03:15:28.980 T:1153430512  NOTICE: Opening stream: 1 source: 256
03:15:29.110 T:1153430512  NOTICE: Creating video thread
03:15:29.111 T:1153430512  NOTICE: Opening stream: 2 source: 256
03:15:29.171 T:1153430512  NOTICE: Creating audio thread
03:15:29.282 T:1153430512  NOTICE: Opening stream: 1 source: 256
03:15:29.331 T:1153430512  NOTICE: Opening stream: 2 source: 256
03:15:29.708 T:1153430512  NOTICE: OMXClock using audio as reference
03:15:29.813 T:1212150768 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
03:15:33.491 T:1958871040  NOTICE: CVideoPlayer::CloseFile()
03:15:33.492 T:1958871040  NOTICE: VideoPlayer: waiting for threads to exit
03:15:33.498 T:1153430512  NOTICE: CVideoPlayer::OnExit()
03:15:33.498 T:1153430512  NOTICE: Closing stream player 1
03:15:33.527 T:1203762160   ERROR: AddOnLog: InputStream Adaptive: Download http://37.77.186.131/?o=AQGPzwrrnr-d-4PtVkuR78nM4FB6_BOboiVKLQDVQ41y83ZUK1OMao-Njbx82sDLxJt0ll43nrULBcKitBEhAw3ezTAfdroeXZMaf15-qIq_-d7-L8QcxC7wUHxSvm7he-5gu2aVdxR4mT-lTaEql9zQO6jhO7xqgbHweuoVxqNg18B3-s_FdwkwJTSbwENv0nLc0L79BrQpWlvpVSNXKQ&v=3&e=1511103718&t=-oySxeuYZ5cAYLRp049RzvGO4q0 doesn't provide any data: invalid
03:15:33.529 T:1195373552  NOTICE: thread end: OMXPlayerAudio::OnExit()
03:15:33.623 T:1153430512  NOTICE: Closing stream player 2
03:15:33.651 T:1289745392   ERROR: AddOnLog: InputStream Adaptive: Download http://37.77.186.131/?o=AQGPzwrrnr-d-4PtVkuR4MjL4Vd4_BObojJKLQDVQ41y83ZUK1OMao-Njbx82sDLxJt0ll43nrULBcKitBEhAw3ezTAfdroeXZMaf15-qIq_-d7-L8QcxC7wUHxSvm7he-5gu2aVdxBu1mvNc5wJlvmnbq-oK6Vmj7f4bPUClKd41sdts8PSJR4jJjOOwks5nWHe2IqTAPJrWEypRWgaP3I&v=3&e=1511103718&t=EsvNwp0PeBtplTUkn8Gw5fB3H4Y doesn't provide any data: invalid
03:15:33.652 T:1212150768   ERROR: OMXPlayerVideo: Got MSGQ_IS_ERROR(-1) Aborting
03:15:33.653 T:1212150768  NOTICE: thread end: video_thread
03:15:33.702 T:1958871040  NOTICE: VideoPlayer: finished waiting
03:15:34.417 T:1958871040  NOTICE: CVideoPlayer::CloseFile()
03:15:34.417 T:1958871040  NOTICE: VideoPlayer: waiting for threads to exit
03:15:34.418 T:1958871040  NOTICE: VideoPlayer: finished waiting
03:15:34.418 T:1958871040  NOTICE: CVideoPlayer::CloseFile()
03:15:34.418 T:1958871040  NOTICE: VideoPlayer: waiting for threads to exit
03:15:34.418 T:1958871040  NOTICE: VideoPlayer: finished waiting
03:15:44.201 T:1958871040   ERROR: Control 55 in window 10025 has been asked to focus, but it can't

#36

I have followed this.

But yet I cannot install the netflix plugin.

I am getting this error message:

CAddonInstallJob[plugin.video.netflix]: The dependency on script.module.pycryptodome version 3.4.3 could not be satisfied

Pycryptodome is already installed. Version 3.4.7

osmc-leia:~$ pip install pycryptodome
Collecting pycryptodome
  Downloading pycryptodome-3.4.7.tar.gz (6.5MB)
    100% |################################| 6.5MB 38kB/s
Building wheels for collected packages: pycryptodome
  Running setup.py bdist_wheel for pycryptodome ... done
  Stored in directory: /home/osmc/.cache/pip/wheels/f7/cb/16/1ed6dc50b92888af9051bda6f59f335dfd966a1ce5edd8a4af
Successfully built pycryptodome
Installing collected packages: pycryptodome
Successfully installed pycryptodome-3.4.7

Could you someone help me?

Thanks.


#37

Waiting for my 2nd Vero to arrive this week so I can give Leia and Netflix myself a try. Can you verify you don’t have a conflict between the python version of Kodi and pip?

# pip --version
# ldd /usr/lib/kodi/kodi.bin | grep python

Kodi 17.6 still uses python 2.7 which Debian Stretch switched to 3.5.


#38

This guide now works for Vero4k.


#39

I have same issue, someone can help ?


#40

Hi all,

Did anyone of you testing Leia and Netflix try to listen to 5.1 audio tracks? Anyone with external USB or hat audio board (like Digiberry)?
What are your observation and thoughts?
Cheers!


#41

same here


#42

5.1 passthrough is not working for me with Netflix plugin, despite correct settings and non adapting videos working ok.


#43

Does it mean that you don’t get any sound (and have to disable audio passthrough to hear the sound) or you get just 2 front channels?


#44

Long short story.

I was getting PCM stereo via passthrough even on videos with audio streams that Kodi showed to me as Dolby 6 channel audio.

So i decided to enable all logs and carefully investigate what was happening.

Evidently, my RPI3 was resampling and remapping the 6 channels to stereo even if I had passthrough enabled. In logs I found the answer for this: Multichannel streams in Netflix South America are encoded as Dolby Digital Plus, despite audio characteristics of the streams inside the container could be perfect AC3, they are sending it as E-C3. My receiver can manage Dolby Digital AC3, but not Dolby Digital Plus E-C3, or more commonly knowledged as E-AC3. My RPI3 didn’t found via HDMI an E-C3 capable receiver so there’s the reason for the automatic resampling and remapping to stereo. The poor little thing fights to send you some kind of audio and adapts dynamically to the conditions.

if i enable “E-C3 capable receiver” i lose all audio, because that’s the enconding you’re enforcing to pass to the receiver. In my case, if I do this, my receiver don’t understand what is coming in and then goes totally silent.

So, I have recurred to a last resort: Enabling AC3 encoding and leaving passthrough enabled. In that case the RPI3 just remaps the 6 E-C3 channels to 6 valid AC3 channels to the receiver: Voilá, real Dolby Digital AC3 without costly resampling. This method can’t manage well stereo programs and despite being sended as Dolby Digital 2.0 by Netflix, the receiver keeps receiving stereo PCM audio. i consider this a minor innacuracy, but not a problem.

So, if Netlix globally sends audio streams encoded like Dolby Digital Plus 5.1 like here in South America, you will need a Dolby Digital Plus capable receiver or if you have an older receiver like me you will need to use the method i described here.

PS: HiFi Berry has an optical output an it isn’t capable to transfer audio streams with frecuencies over 96hz. HDMI ports can transfer 192hz. is important to know this, because if a Netflix stream is sampled over 96hz frecuency, there will be resampling to a lower frecuency in addition of a remapping. One of the main ideas to have a digital receiver is to avoid RPI3 to make any audio processing outside demuxing it. If resampling and remapping happens, CPU cycles are lost. If you use GPU Acceleration to resample, also you will have less room to exploit maximum video capabilities. So, is very important to know your gear capabilities to know what to do.

Martin