[HowTo] Install a vnc server on the Raspberry pi

I am using dismax to view graphical programs in vnc! I used it before on my raspberry pi under both OSMC and Raspbian and it worked well. I just want to know if I can do the same under Ubuntu? I am not 100% Remmina is? I have actually found another solution which is to use MobaXterm.

Hi
having the problem that remove mouse is not available with kodi 18 beta.
does anyone have a solution?
I re-compiled everything but mouse still not moving.

Thanks T

Yeah mouse is working on kodi 18 yet. I think it was working at first, but now there are still some things missing…no idea when they are gonna fix it. I mean, they’d rather fix useless modules like game, skins and pvr first instead of that…i’ve been waiting for that fix for months now. :confused:

The solution I found is to set the Picture quality to Low, though not ideal gets the job done.
I too would be very interested to know if there is any other fix for this.

If i remember correctly using OpenElec i managed to make it work at higher quality but it was very slow…Low quality is super fast (if only we had mouse support also (kodi 18) that would be great), and besides whats the point in having so many colours :stuck_out_tongue:

Hello,

with the help and many tests from Sandbird, I present you a GUI for installing the vnc server on osmc (for raspberry pi only)

Login to your OSMC (putty or else)

Grep the install file:
wget https://raw.githubusercontent.com/MarkusLange/VNC-Server-install-script-for-OSMC/master/osmc_vnc_install_cli.bash

Make it executable:
chmod +x osmc_vnc_install_cli.bash

Start the GUI with:
sudo ./osmc_vnc_install_cli.bash

Now you see this:

Now you can follow the Options…

Also you can use it as CLI installer for automatic installations without interacting:

You can get the help with sudo ./osmc_vnc_install_cli.bash --help or just run it without sudo.

Sandbird and I have test it as best we can but no warranty for 100% working, please feel free to make suggestions.

Markus

8 Likes

Thank you Markus, you did awesome work with it. When i get home i’ll add it to the first post.

edit: 1st post updated :slight_smile:

Good job.

Thanks

Thanks a lot, i installed dispmanx several months ago, it worked, and since Kodi was updated to Leia, it did not work anymore with the mouse.

But now, thanks to you, i have a fully functional vnc access to my PI, great job dude !

@MarkusLange: I followed your instructions and everything works so thanks from my side aswell. Unfortunatelly if I remotly access from my vnc viewer on pc (VNC-Viewer-6.19.923-Windows.exe) I get english keyboard mapping and I can not change any keyboard layout at the VNC viewer side. Do you have any advice?

unfortunately you cant, the way i do it is install the unicode language i want in the pi’s keyboard as well, and then when i got the keyboard out for text, i switch languages (Press the English QWERTY button), then i press the unicode characters with the mouse.

Sorry, but what is “the english QWERTY button” ?

If you install a 2nd language (Settings->Regional->Keyboard layouts) then you get to switch languages like this:

1 Like

Thank you.

1 Like

Hi

I tried this via ssh

got an error:

> sudo ./osmc_vnc_install_cli.bash                                                                                  
> 
> cannot initialize curses
> Error opening terminal: screen.xterm-256color.
> 'screen.xterm-256color': unknown terminal type.

How to get around? thanks T

If I look right. Based on this, 1. Answer It seems like you have a problem with the terminal definition.

You should do this

export TERM=xterm

and then try it again.

Hi Markus,
today I found this post and installed the vnc server using your instructions. It looks as if the installation was successful. However, when I try to contact my Raspberry using “UltraVNC viewer”, I get error messages:
Server closed connection

  • Manual closed
  • Network disconn

and the screen on my Windows computer looks as shown in the picture attached.
As I can see the cursor mooving on the monitor attached to my Raspberry, it looks as if the connection works and only graphical settings are wrong.

Do you have any idea what I could do to see the Raspi screen from my Windows machine?
(upload://hQ24SPddmEtwkhhOf0uZvHX3xaz.jpeg)

Try the realvnc viewer

Thank you. Now the image is clear.

The only restrictions I noticed so far are:

  • the scroll wheel of my mouse does not work on the remote Raspi
  • although the keyboard setting is “German QWERTY” on the remote Raspi and on the Windows machine, I get e.g. “Z” when entering “Y”
  • I did not arrive in pasting text into fields of the remote Raspi.

Is this normal, or is there any possibility for changing this?