[HowTo] Install a vnc server on the Raspberry pi


#243

yea now i’m trying to figure out a main.o error, ive been here before i just can’t remember how i went about fixing it, in process right now, it’s happening at the make step, i’ve updated and upgraded first
main.c:21:22: fatal error: bcm_host.h: No such file or directory #include “bcm_host.h"
EDIT FYI fixed this issue with
export CFLAGS=”-I/opt/vc/include"
export LDFLAGS="-L/opt/vc/lib"

Then run make.


#244

And somehow i end up in the same postion again. This just doesn’t make any sense? I’ve searched far and wide across many forums and it seems my problem is unique? What could possibly be going on here??


#245

Which version of dispmanx_vncserver are you using? Have you tried the one mentioned in Step 1 of the first post in this thread? The compiler error you got in main.c suggests that you are using one of the other forks.


#246

Where can i find the specific version? I looked in the downloaded folder and checked out the README file and didnt find my answer. I used each step in the tutorial to the letter.


#247

If you have a main.c file you have probably used the deprecated instructions in the thread start. If you have a file called main.cpp you have the “correct” version. If you have both you have probably downloaded an unzipped both. I would suggest trying to delete or rename the folder and retry downloading, unzipping and compiling. Make sure you use the link https://github.com/patrikolausson/dispmanx_vnc/archive/master.zip with wget following Sandbird’s instructions…


#248

Ok that worked, i’m not sure why i had such trouble, i went through and completely removed everything and started from scratch again, using your link with wget did it, but using the one outlined above in this tutorial, i only found trouble.
Anyways i’m all set now, thank you all so much! I appreciate the help! Take care!


#249

Well as both URL’s are exactly the same the issues you had must have been somewhere else.


#250

Yes, the links are the same. I pasted the link from Sandbird into my post. My guess is that @DaddyJake4 by mistake scrolled too far down in the instructions the first time and used the link in the deprecated version of the guide. Not an unlikely mistake to make if you read the whole guide first I guess, and I think I have helped someone once before in this thread with the same thing.


#251

Thanks, Sanbird! One issue I am having. When I connect through my pc I have no issues, but if I connect through my phone it connects but if I go into some add-on it keeps saying “Re-attempting to connect to VNC Server”. Any ideas?


#252

I have the same problem with the “original vncviewer app” on my Android-Phone but RemoteToGo an another vnc app works, may there are more apps for vnc for the iPhone.


Sound Distortion
#253

Try setting picture quality “Low” in your client settings. The server cant handle full colours cause its a pi :slight_smile:


#254

That did it. Thanks! Is there a way to see who is connected to the VNC server?


#255

hmmm not sure about that…Maybe its written in a log somewhere…but i dont think you can see it within the client.


#256

Thanks, Sandbird. I did find one issue I keep having. I would randomly get sound distortion even without a client connected to the vnc server. However, if I disable the server the sound distortions would go away. I am running on RPi2 Kodi v16. The sound distortions weren’t persistent, but do happen sporadically (at least once per video).


#257

well, thats weird…I’ve never heard a similar problem before…but then again i have fixed settings in my config.txt about the sound. Maybe that’s why.( hdmi_force_edid_audio=1 )


#258

Hi @Sandbird

Is there a way to keep the vnc server alive when exiting kodi. I have @joakim_s x11 desktop installed and when i open that the vnc viewer closes on my pc.

I’m assuming its not possible does the vnc server shutdown when kodi closes?

Thanks for any info


#259

No, the vncserver is not related to Kodi. It even will show the console if you exit Kodi.


#260

Thanks so is there setting to keep the vnc viewer open when i’m using x11 desktop?


#261

Hi @the_bo
It’s simple, in the vnc-server servicefile change the top 4 lines to this:

[Unit]
Description=VNC Server
After=network-online.target
Requires=network-online.target

This will make it so you can have vnc-server running when kodi exits and X11 starts


#262

Thanks @joakim_s where is the vnc-server service file location again?