[HowTo] OSMC Skin, Hiding the Pause OSD (On-Screen-Display) After Amount of X Seconds

Black Glass Nova (my current favourite) has a preferences option to disable the OSD overlay in pause.

That seems to have been added fairly recently as I switched to Refocus for a few months and when I went back it had been added.

Skins can be deleted in System->Addons->My Addons->Skin. Obviously you can’t delete the currently active skin.

Be aware that skins typically cause other addons to be installed as well (such as TV Tunes, artist slideshow etc) and you must remove these manually after removing the skin if you wish.

1 Like

Thank you. Couldn’t get to the DialogSeekBar.xml of the osmc skin at all. Was nowhere on my microSD card.

I did try Black Glass Nova but my goodness I find it so ugly. I guess I’ll keep trying others until I find one that looks good and has no OSD on pause. I really like the OSMC skin for being so clean and looking more like regular file lists. I never liked the XBMC-type side scrolling main menu.

Thanks anyway!

Some skins will hide the visible element in an includes brought in from a different file, but other than that this same trick can work for them too.

FYI I am working on a small addon that runs on startup making this specific edit. It would mean that the changes will take effect on next boot. But I won’t release it until it can follow the includes links.

On skins with this feature already, the lesser of the skins timing and the addons timing would take effect.

Repeat the find command if the first run comes back with no result.
I do not know why but I often have to invoke the command twice.

Example:

login as: root
root@osmc-pi's password:

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Nov  5 00:13:43 2015 from 192.168.178.28
root@osmc:~# find / -name DialogSeekBar.xml 2>/dev/null
root@osmc:~# find / -name DialogSeekBar.xml 2>/dev/null
/usr/share/kodi/addons/skin.osmc/16x9/DialogSeekBar.xml
/usr/share/kodi/addons/skin.confluence/720p/DialogSeekBar.xml
root@osmc:~#

It’s this working this ad today ?

I know it’s a two years thread but it’s an interesting feature.

I have tryed (but i don’t know if i applyed correctly) on today release of osmc but apparently it’s no works.

I like to try to add this feature also on currently Estuary skin…

EDIT
For obtain a workaround:
I remove:

 Player.DisplayAfterSeek | [Player.Paused + !Player.Caching] 

From DialogSeekBar.xml

Now when a video it’s on pause no more bar appears as OSD. The OSD it’s appears only if i click “OK”…

It’s not same idea but it’s better than nothigs.

@FaustoGSR If you want the seekbar to disappear after 5 seconds when having pressed the PAUSE button you can change the file /usr/share/kodi/addons/skin.osmc/16x9/DialogSeekBar.xml that way

<window>
        <!-- seekbar -->
        <defaultcontrol always="true">901</defaultcontrol>
        <visible> ... Player.DisplayAfterSeek  + !System.IdleTime(5)| Player.Paused  + !System.IdleTime(5)...
        <animation 

means extend Player.DisplayAfterSeek and Player.Paused in the visible tag of the seekbar block in the beginning with “+ !SystemIdleTime(5)”.

Set @Chillbo to this post. Perhaps, this is something we want to consider being in the OSMC skin in long term or make it configurable?

See also On screen display removal? - #18 by JimKnopf in another thread.

I setup a poll for this: Poll, OSMC Skin, Automatic OSD/Seekbar Hiding While Videoplay + Paused.

You speak about skim.osmc… i usually used the Estuary… the default line it’s like:

<visible>Player.Seeking | Player.DisplayAfterSeek | [Player.Paused + !Player.Caching] | Player.Forwarding | Player.Rewinding | Player.ShowInfo | Window.IsActive(fullscreeninfo) | Window.IsActive(videoosd) | Window.IsActive(musicosd) | Window.IsActive(playerprocessinfo) | !IsEmpty(Player.SeekNumeric)</visible>

I have edited the Player.DisplayAfterSeek adding this !System.IdleTime(5) but nothigs append.
On Player.Paused how i need to add the !SystemIdle ? Inside of Outside of [ xxxx ] text ?

@FaustoGSR With skin Estuary you have to change one line in file /usr/share/kodi/addons/skin.estuary/xml/DialogSeekBar.xml:

<visible>Player.Seeking | Player.DisplayAfterSeek + !System.IdleTime(5) | [Player.Paused + !System.IdleTime(5) + !Player.Caching] | Player.Forwarding | Player.Rewinding | Player.ShowInfo | Window.IsActive(fullscreeninfo) | Window
.IsActive(videoosd) | Window.IsActive(musicosd) | Window.IsActive(playerprocessinfo) | !IsEmpty(Player.SeekNumeric)</visible>

mmmmm… yeah… i have tryed but it’s not works:
Apparently it’s works whit “normal” OSD during reproduction (example… i press ok on my remote and i see the normal buttons on osd like pause->info->stop etc etc) but if i press pause the osd remain on tv.

@FaustoGSR: That is strange. I just retested and it works with Estuary as I wrote in the post before. Here, it does not work with the normal OSD if you press OK but that was intended, it should only vanish if you pressed the pause button while playback.

Look again in the file. Perhaps, you have inserted a typo or forgot an exclamation mark (!) befor both System.IdleTime(5).

Announcement: There will be a new option for this in the next update which will allow to adjust the behaviour of the video OSD during pause. :+1:t2:

1 Like

Hi @Chillbo, @sam_nazarko ,

Did this ever get implemented?

I’m running the default theme on the latest update on my Vero4K, and cannot find the option anywhere.

Maybe I’m mussing something obvious…

I think you mean this: Hiding the OSD when paused - #2 by joakim_s

Hi,

[Edit: wondering if I’m not actually using the default theme… checking now]

Before posting, I went through all options within

Settings->Interface->Skin->Configure skin

There are three sub menus: General, Main menu items, and Artwork

Unfortunately none contain ->OSD->Display time of video OSD during pause

Not sure why

Looks like it.

Sorry for misleading anyone.

Seems i switched my theme to Estuary 18 months ago, as soon as I bought the Vero, and forgot.

I can’t get on with the default (is it Confluence? It’s just named OSMC skin)

Please help!

Switched to OSMC skin.
Selected a different background.
Used Backup/restore menu to reset skin.
Changed back to Estuary.

Skin now broken. Error message was displayed, but I didn’t catch it. Something has been logged apparently.

No background image.

No idea what else is broken.

Sh*t

Anybody have a way to restore Estuary (and a clue as to how switching to OSMC broke it)?

Error message:

Skin Shortcuts

Unable to build menu
Install kodi log updater add-on

how did I forget doing this (before switching back to Estuary):

…i tried to configure the OSMC skin to change which mrnu items where being displayed. It forced me to install:

Skin shortcuts 1.0.17
Skin helper service 1.1.3
Skin helper service backgrounds 1.0.21

Wish i hadn’t fiddled with anything whilst taking OraMorph…

Any ideas @sam_nazarko (sorry to impinge on your time sir)

EDIT:
In case anybody can help, I’ve uploaded logs to:

Https://paste.osmc.tv/votibexoja

EDIT 2: I may have fixed it by switching off the Skin Shortcuts add-on option to ‘share settings with compatible skins’ (or something similar)

Rebooting appears to have restored Estuary, but I’ll need to dig around

EDIT 3:

Now I’m trying to nuke the add-ons I mindlessly installed (see above), but can only find Skin Helper Service listed in Add-ons /My Add-ons / All

Installing ‘Skin shortcuts’ forced installation of ‘Skin helper service’ and ‘Skin helper service backgrounds’. No idea why the first dependency is the only add-on I can find.

That should indeed do the trick :+1:t2: Why not stick with our OSMC skin?

1 Like