Hyperion not working after update to 07-2015 release

Hi there,

I had some problems with Hyperion before after updating to RC3, but got it working after manually enabling SPI in boot.txt.

I just upgraded to the 07-2015 release and Hyperion isn’t working again.
dtparam=spi=on is still in the boot.txt
I also enabled it in My OSMC

Read this thread: OSMC RC3 + PI 2 + Hyperion + Lightberry = Not Working - #18 by duri, no solution except reinstall.
I’d like to avoid that :wink:

Any suggestions?

I have the same problem… but do time yet to investigate…

I’m having the same issue. RPI 2 using the latest update of OSMC. (July 2015 2015.07-1 according to the OSMC Control app.)

My config.txt still has the correct setting of dtparam=spi=on, howevering lsmod shows no mention of spi. Also there are no spi devices in /dev/.

I have tried manually specifying the overlay in the config.txt, reinstalling hyperion and updating hyperion’s dependencies.

I have not tried a full OSMC reinstall from scratch.

Two seemingly unrelated issues:

  1. When using the OSMC config app, selecting the option for “Pi config” does nothing.
  2. Deselecting “Enable Mouse and Touch Screen Support” in kodi does not actually disable keyboard and mouse support.

Device: Raspberry Pi 2
Installation media: MicroSDCard
Connection: Wired, static ip and dns
Peripherals: Wireless Keyboard and Mouse
Storage Device: Samba shares via networking (all working)
OSMC version: 2015.07-1"
XBMC version: 15.1-RC1
Codecs: mpeg2, vc1 both purchased and inserted to config.txt Confirmed working via vcgencmd
Audio/Video Output: HDMI
Overclocked: No
Config.txt Extras:


Full debug log showcasing the two issues above: http://paste.osmc.io/umefosagub.vhdl

Relevant portion of the non-debug log:

23:52:38  36.150669 T:1742742560  NOTICE:  StorageServer Module loaded RUN
23:52:38  36.151096 T:1742742560  NOTICE: StorageClient-2.5.4 Starting server
23:57:04 302.986572 T:1636299808  NOTICE: Thread JobWorker start, auto delete: true
23:57:26 325.069611 T:1592648736  NOTICE: Previous line repeats 2 times.
23:57:26 325.069885 T:1592648736  NOTICE: Thread LanguageInvoker start, auto delete: false
23:57:27 325.146393 T:1592648736  NOTICE: -->Python Interpreter Initialized<--
23:57:28 327.001770 T:1751131168   ERROR: EXCEPTION: Non-Existent Control 300
00:01:11 549.742310 T:1729360928  NOTICE: config_tools.read_config received: pos0: /boot/config.txt
00:01:11 549.748352 T:1729360928  NOTICE: config_tools.read_config [0.00553107261658]  returns: {'disable_overscan': '1', 'dtparam': 'spi=on', 'hdmi_ignore_cec_init': '1', 'decode_MPG2': '0x9652364e', 'start_x': '1', 'gpu_mem': '256', 'decode_WVC1': '0x6bf91c16'}
00:01:13 551.619019 T:1729360928   ERROR: Exception in thread Thread-20:
                                            Traceback (most recent call last):
                                              File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
                                              File "/usr/share/kodi/addons/service.osmc.settings/resources/lib/CompLogger.py", line 61, in wrapper
                                                func(*args, **kwargs)
                                              File "/usr/share/kodi/addons/script.module.osmcsetting.pi/resources/osmc/OSMCSetting.py", line 366, in run
                                              File "/usr/share/kodi/addons/service.osmc.settings/resources/lib/CompLogger.py", line 71, in wrapper
                                                result 	= func(*args, **kwargs)
                                              File "/usr/share/kodi/addons/script.module.osmcsetting.pi/resources/osmc/OSMCSetting.py", line 345, in populate_pi_settings_dict
                                                setting_value = translate_method(setting_value)
                                              File "/usr/share/kodi/addons/service.osmc.settings/resources/lib/CompLogger.py", line 71, in wrapper
                                                result 	= func(*args, **kwargs)
                                              File "/usr/share/kodi/addons/script.module.osmcsetting.pi/resources/osmc/OSMCSetting.py", line 865, in translate_gpu_mem
                                                self.me.setSetting('gpu_mem_1024', str(val1024))
                                            NameError: global name 'val1024' is not defined
00:02:53 652.079346 T:1729360928  NOTICE: Thread JobWorker start, auto delete: true

Should soon work again -> dev-spidev0-0-missing-after-2015-07-update

Edit: I just updated but hyperion is still not working. The Hyperion server seems to run, I can connect with my remote app. But the LEDs not going.

Does anyone know a solution for this issue?

Same here,

Server seems ok, but no output to the ledstrip :’(

after the second update its working here…see the other thread…