Hyperion / Raspberry PI 2 / OSMC... How?

Hi,

I have a pack of 50 LED Pixel (ws280), a raspberry PI 2 and the lastest OSMC and I would like use Hyperion…

I have made this :
sudo apt-get update
sudo apt-get install libqtcore4 libqtgui4 libqt4-network libusb-1.0-0 libprotobuf9 ca-certificates
wget -N https://raw.github.com/tvdzwan/hyperion/master/bin/install_hyperion.sh
sudo sh ./install_hyperion.sh

add dtparam=spi=on in Config.txt

After generating the file on my computer
cp hyperion.config.json /etc/hyperion.config.json
sudo service hyperion restart

and when I test with…
hyperion-remote –priority 50 –color red –duration 5000
nothing :frowning:

I have use this wiring


except for DI and CI because I have only DO et CO on my LED…

with MOSI on port 19 and SCLK on port 23

I have the first LED who are blue but nothing after…

Who can help me ?
Akhlan

Be carefull : usually, you have DI/CI with I for IN, and DO/CO with O for OUT.

Be sure to connect your raspberry to the IN (DI/CI) connectors of your LED strip.

Yes I know that but I haven’t these ports

I have use these pins

It looks like DI CI are on wires on the other side of the board ?

Ho, i see. I’ve never used those kind of LEDs.

It seems that a previous version of OSMC had bugs with spidev (cf. /dev/spidev0.0 missing after 2015.07 update - #15 by duri). Be sure to update to the last one (My OSMC -> Updater -> Manual Controls -> Check for Updates).

How many LEDs do you have ? Power out on Raspberry is limited, so if you have too much LEDs on it, this might be the problem.

Hy,

my OSMC is up to date :wink:

I have 50 Leds and for the power supply, look my schematic, I don’t use the power out of the raspberry, I have a second power supply (5V / 8A) that power the raspberry and LEDs

Get to a command prompt by either exiting while holding escape or using SSH to connect.

Issue the following commands and paste their output:

lsmod | grep spi

Expected output: spi_bcm2835

ls /dev/spidev*

Expected output /dev/spidev0.0 /dev/spidev0.1

If these two commands do not issue the expected outputs, you most likely do not have the SPI enabled, or your OSMC needs to be updated. You will need to manually search for an update via the My OSMC menu to find it.The version missing the SPI was pushed out about 2 days ago and a fix was issued yesterday afternoon, so unless you have updated in the past 12-16 hours you are probably not on the latest update.

It’d better :wink:

root@osmc:~# lsmod | grep spi
root@osmc:~# 
root@osmc:~# ls / dev / spidev *
ls: cannot access dev: No such file or directory
ls: cannot access spidev: No such file or directory
install_hyperion.sh

/:
bin   dev  home  lib64	     media  opt   root	sbin	 srv  tmp  var
boot  etc  lib	 lost+found  mnt    proc  run	selinux  sys  usr  walkthrough_completed

/:
bin   dev  home  lib64	     media  opt   root	sbin	 srv  tmp  var
boot  etc  lib	 lost+found  mnt    proc  run	selinux  sys  usr  walkthrough_completed



root@osmc:~# sudo apt-get upgrade && sudo apt-get update                         
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  armv7-libafpclient-osmc rbp2-image-3.18.10-1-osmc rbp2-image-3.18.13-1-osmc rbp2-image-3.18.9-5-osmc
Use 'apt-get autoremove' to remove them.
Done
The following packages have been kept back:
  rbp2-kernel-osmc
The following packages will be upgraded:
  mediacenter-addon-osmc rbp2-mediacenter-osmc
2 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/44.0 MB of archives.
After this operation, 8938 kB disk space will be freed.
Do you want to continue? [Y/n] y
Progress: [ 90%] [###########################################################################################################..........] Se
Hit http://ftp.debian.org jessie InRelease
Get:1 http://ftp.debian.org jessie-updates InRelease [123 kB]             
Hit http://security.debian.org jessie/updates InRelease                   
Hit http://apt.osmc.tv jessie InRelease                                   
Hit http://ftp.debian.org jessie/main armhf Packages
Hit http://ftp.debian.org jessie/contrib armhf Packages           
Hit http://ftp.debian.org jessie/non-free armhf Packages          
Hit http://ftp.debian.org jessie/contrib Translation-en           
Hit http://ftp.debian.org jessie/main Translation-en              
Hit http://ftp.debian.org jessie/main Translation-fr              
Hit http://ftp.debian.org jessie/non-free Translation-en          
Get:2 http://ftp.debian.org jessie-updates/main armhf Packages/DiffIndex [505 B]       
Hit http://security.debian.org jessie/updates/main armhf Packages                      
Get:3 http://ftp.debian.org jessie-updates/contrib armhf Packages [14 B]               
Get:4 http://ftp.debian.org jessie-updates/non-free armhf Packages [14 B]                  
Get:5 http://ftp.debian.org jessie-updates/contrib Translation-en [14 B]                   
Get:6 http://ftp.debian.org jessie-updates/main Translation-en/DiffIndex [229 B]           
Get:7 http://ftp.debian.org jessie-updates/non-free Translation-en [14 B]                  
Hit http://security.debian.org jessie/updates/contrib armhf Packages                       
Hit http://security.debian.org jessie/updates/non-free armhf Packages                      
Hit http://security.debian.org jessie/updates/contrib Translation-en                       
Hit http://security.debian.org jessie/updates/main Translation-en                          
Hit http://security.debian.org jessie/updates/non-free Translation-en                      
Get:8 http://apt.osmc.tv jessie/main armhf Packages/DiffIndex [2023 B]                     
Ign http://apt.osmc.tv jessie/main Translation-en                            
Ign http://apt.osmc.tv jessie/main Translation-fr
Fetched 126 kB in 15s (8195 B/s)                                                                                                          
Reading package lists... Done
root@osmc:~# 



root@osmc:~# sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  armv7-libafpclient-osmc rbp2-image-3.18.10-1-osmc rbp2-image-3.18.13-1-osmc rbp2-image-3.18.9-5-osmc rbp2-image-4.1.2-1-osmc
Use 'apt-get autoremove' to remove them.
Done
The following NEW packages will be installed:
  rbp2-image-4.1.3-2-osmc
The following packages will be upgraded:
  rbp2-kernel-osmc
1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/16.6 MB of archives.
After this operation, 61.1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Preconfiguring packages ...
Progress: [ 90%] [###########################################################################################################..........] Se


root@osmc:~# reboot -n


root@osmc:~# lsmod | grep spi
spi_bcm2835             4989  0 
root@osmc:~# ls / dev / spidev *
ls: cannot access dev: No such file or directory
ls: cannot access spidev: No such file or directory
install_hyperion.sh

/:
bin   dev  home  lib64	     media  opt   root	sbin	 srv  tmp  var
boot  etc  lib	 lost+found  mnt    proc  run	selinux  sys  usr  walkthrough_completed

/:
bin   dev  home  lib64	     media  opt   root	sbin	 srv  tmp  var
boot  etc  lib	 lost+found  mnt    proc  run	selinux  sys  usr  walkthrough_completed
root@osmc:~# 

I haven’t “Expected output /dev/spidev0.0 /dev/spidev0.1” with the command “ls /dev/spidev*”

remove the spaces between /dev/spidev*. There should only be a space after ls.

Regardless, the lsmod command did not show spi being enabled, so either your config.txt file is missing the proper line or you need to update OSMC.

Try this. Goto My OSMC -> Updater -> Manual Controls -> Check for Updates now and see if that helps.

root@osmc:/dev# ls /dev/spidev*
/dev/spidev0.0 /dev/spidev0.1

root@osmc:/etc/modprobe.d# cd /dev/
root@osmc:/dev# ls -ltr | grep -i spidev
crw-rw---- 1 root osmc 153, 1 Aug 5 17:49 spidev0.1
crw-rw---- 1 root osmc 153, 0 Aug 5 17:49 spidev0.0

root@osmc:/dev# vi /boot/config.txt
gpu_mem_1024=256
over_voltage=0
force_turbo=0
over_voltage_sdram=0
core_freq=450
initial_turbo=0
start_x=1
sdtv_aspect=0
disable_overscan=1
arm_freq=900
sdram_freq=450
hdmi_ignore_cec_init=1
dtparam=spi=on <---------------- I have put this line manually yesterday

Why ? I have already made the last update with these commands ?
sudo apt-get upgrade && sudo apt-get update
and
sudo apt-get dist-upgrade

but just to see… When I do an update via OSMC, nothing… (OSMC july 2015 2015.07-01)

SPI is working then. Check to see if hyperion is running with

ps aux | grep hyperion

If it is, try changing the lights to red again. If that is still a no go I am inclined to think the issue might be with either wiring or the LED Pixels you have. Can you link to the place you purchased them?

root@osmc:~# ps aux | grep hyperion
root 241 1.8 2.2 94968 16660 ? Sl 20:15 0:03 hyperiond /etc/hyperion.config.json
root 572 0.0 0.0 2148 560 pts/0 S+ 20:17 0:00 grep hyperion

I have buy these items on eBay (rjianzhou1984) on may 2014… ^^

  • 50PCS WS2801 RGB Full Color 12mm Pixels digital Addressable LED String DC 5V
  • EU 5V 8A Power supply AC to DC Adapter for WS2811 WS2801 HL8806 LED String Light

unable to launch the command
hyperion-remote –priority 50 –color red –duration 5000

priority and duration doesn’t exist for this command…

On OSMC, in “OSMC Settings” / “Pi Config”, have you change something ? I see “Enable SPI Support” in “Hardware support”

Try this command:

hyperion-remote --priority 50 --color red --duration 5000

Please be aware that before priority, color, and duration there are two dashes each. Alternatively you could try this command with single dashes.

hyperion-remote -p 50 -c red -d 5000

Use

hyperion-remote --help

for reference. Paste whatever your output is.

hyperion-remote --priority 50 --color red --duration 5000 work fine :wink:

root@osmc:~# hyperion-remote --priority 50 --color red --duration 5000
Connected to localhost:19444
Set color to 255 0 0
root@osmc:~#

but nothing on leds

the port 19444 is open
root@osmc:~# netstat -an | grep 19444
tcp 0 0 0.0.0.0:19444 0.0.0.0:* LISTEN

Have you check that ?
root@osmc:~# netstat -an | grep 19444
tcp 0 0 0.0.0.0:19444 0.0.0.0:* LISTEN

Have you check that on your OSMC ?

It appears your hyperion is working properly. The problem most likely lies in your wiring. Make sure you are sending the clock and spi signals in from the side that has the large black chip and out from the side that has the 5 small silver chips. I’m 99% certain the power can flow either direction (at least thats how it is with my ws2801 strip.)

If you have a multimeter, you can try testing continuity between the spi and clock and ground to make sure there is no soldering errors.

http://www.ladyada.net/library/metertut/continuity.html