Image Quality Issue


I recently set up my newly received Vero 4K+.

I have the following setup at the moment.

  1. TV - Vizio 65" M65Q8-H1
  2. Raspberry Pi 4 8GB running Kodi on Raspbian connected to TV via HDMI and connected to router via Ethernet cable.
  3. Vero 4K+ running Kodi on OSMC connected to TV via HDMI cable and connected to router via Ethernet cable.
  4. Synology NAS connected to router via Ethernet cable.

All Ethernet connections are via 1gig.

Description of the issue:
After setting up the Vero 4K+ and testing out a sampling of 4K videos, I noticed that the video quality did not seem very high. I apologize for not having the technical vocabulary to describe exactly what’s wrong, but playing the exact same videos on the RPi4 produces a much higher and crisper image quality.

I tried to capture this difference with my camera but it’s hard to convey. But if I have the same video paused at the exact same moment on both devices, and I switch between them with my TV remote, the issue is very apparent. I would say even the image coloring seems off with the Vero.

I am not sure if this is related, but another issue I noticed is that when displaying my videos in “Wall” display mode, the video thumbnails (which I’m assuming Kodi/OSMC is downsizing) appear very grainy.

Would appreciate any advice you might be able to offer to get comparable image quality to what I am seeing with the RPi4 setup.

Please provide logs so that we can check your configuration.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

We need to see logs to comment further.

If anything I’d expect the Pi to look off when playing 4K content as HDR is still a work in progress.



Thanks for the prompt response, Sam! I will get those shortly.

Hi @sam_nazarko. Per your request, I’ve uploaded the logs to

Thank you for taking the time!

While there might be different problems coming together (considering you are talking about grainy and colors.
As a starting point I would suggest to try the below recommended setting first.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.


Per your suggestion, I’ve applied the above settings.

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop
System>Display>Force 4:2:2 colour subsampling> (enable)

I’ve reproduced the issue again and uploaded the logs to

Also - I am not sure which setting change is responsible for it, but I do notice an occasional flicker on the video now. It’s very infrequent but still seems to happen. To reiterate the overall issue, though, it appears as if the image quality of the video is lower than expected (at least based on a comparison with the similar Pi4 setup).

Thanks again for any help.

I was going to try and grab some screenshots from both the RPi and Vero to compare but when I take a screenshot in OSMC this is what I get :pensive:

For reference, here’s a screenshot from playback on the RPi:

In the hope that it’s helpful to diagnosing the issue, I’d like to add another datapoint - I have another device on which I am playing the same video.

It’s a MacBook Pro running Kodi. Also worth mentioning is that in all of these scenarios Kodi is running the videos via the Kodi Jellyfin plugin.

As far as I can tell, the image characteristics that the Mac is displaying are identical to the ones that the RPi4 is. I.e they both seem to be playing the video in identical quality.

That is most kind of expected due to the security layer of the Vero that will allow playback of protected content.

Generally the screenshot would not be the best to show as it doesn’t represent how your TV displays the content. Suggest to take picture with the mobile phone ideally without any AI Mode enabled.

That actually looks colorwise a bit washed out. What is the Video Mode the TV shows when you play the file from the Pi?

While I doubt it makes a difference I suggest for testing to play the video directly via Videos - Files.
Especially as the Jellyfish Plugin make reading the Logs very difficult.

Well at least I can see that the Vero switches to 4k
AMLUtils::aml_set_display_resolution new video mode is 2160p24hz

Can you provide Mediainfo for the Video? Is a HDR or HDR+ file?

Hi @fzinken,

Thanks for the note about why the screenshot was not successful. TIL.

I did try and take a picture with my phone, although it displayed various artifacts that I wasn’t sure how to deal with.

I’ll try to run the video directly off of the Vero instead of through Jellyfin. Will report back!

I’ve made the Mediainfo for the file available at GeneralUnique ID : 2151177081981198196871500552 -

Thanks so much your time.

SMPTE ST 2086, HDR10 compatible
Ok so it is a HDR10 movie. Would be interesting if you see the same “quality issues” with a none HDR movie.

This is playing on a RPi 4 via Kodi on Raspbian

And this is the same file playing on a Vero 4K

The RPi 4 image shows the washed out image that you get when you try to play HDR on a player not capable as expected. If what you are seeing in a RPi 4 currently looks “correct”, then perhaps you adjusted your TV to make the RPi look better and as a result it is now very much out of calibration?

1 Like

@darwindesign Thanks so much for going to the trouble. I believe the Vero 4K image you posted is somewhat similar to what I am seeing.

Would you say that the Vero image displays higher quality than the one being displayed by the RPi4? I’m not disputing that the RPi4 is incapable of actually displaying HDR characteristics, but the image being displayed by the Vero appears to me to have somewhat of a very strong contrast… As if overall the image is darker and certain image features are being drowned out in blacks.

That was my Cell phones doing. The images to my eyes looks even more washed out on the RPi and natural with correct contrast and color saturation on the Vero. Another thing that may be a possibility is the color settings of the display in HDR mode. Your RPi is not switching to HDR so it is using the color settings that you see normally. HDR mode afaik is always a separate calibration. On My LG the default HDR looks terrible, oversaturated, over sharpened, and overall just very unnatural. However just switching the color setting over to the default movie mode it is pretty decent. Once I turn off the rest of the post processing junk it is even better.

HDR in general seems to have a bit of a learning curve to it. For example we have had quite a few that thought they were getting it until they were informed they needed to enable deep color or the like on their TV.

Thanks so much, @darwindesign, I’m going to do a deep dive of my TV’s manual, I did see a mention online that HDR needs to be enabled.

This forum is teaching me a lot - I really appreciate it.

Hi, quick question as I continue to debug this - on my Vizio TV, there is an option to choose between Auto, HDMI 1.4 and HDMI 2.1 for the input. I noticed it was set to Auto. I attempted to change it to 2.1 but the screen went dark. Only HDMI 1.4 and Auto (which I assume fell back to HDMI 1.4) works. Could this possibly have anything to do with the issues I’m encountering? I ordered a “Certified” cable off of Amazon which should get here in a couple of days, so I figured maybe it was the cable.

I guess I’m asking - should I even be able to switch this configuration field to HDMI 2.1 when connecting the Vero 4K+ to the TV?

HDMI 2.1 should work, although Vero only supports HDMI 2.0b so you only need a 18Gbit/s cable.

If you set the GUI to 1080p as suggested above you should get a picture OK even with the TV set to HDMI 2.1. If you still don’t, or have issues with 4k video, try setting chroma sampling to 4:2:2.

FYI, HDMI 1.4 should be good for all resolutions up to 4k30Hz. You only need HDMI 2.0 or higher for 4k60Hz.

Ok, I have some more information I’ve been able to collect:

Apparently, this Vizio TV will display on the screen the format of the Video/Audio being played.
So I was able to go on Netflix and Prime Video and load a few videos that are either HDR10+ or Dolby Vision and have the screen recognize them as such.

Playing “The King” on the Vizio Netflix app, notice Dolby Vision:

Playing “Sound of Metal” on the Vizio Prime Video app, notice HDR10+:

Playing “Sound of Metal” on Kodi via Jellyfin running on RPi4, notice no HDR indication:

Playing “Sound of Metal” on Kodi via Jellyfin running on Vero 4K+, notice no HDR indication:

Mediainfo for “Sound of Metal” video played on Kodi in the above two scenarios (Indicates HDR10+): GeneralUnique ID : 1845395428282585709558758763 -

I also loaded a sample file directly onto the Vero (via scp) and played that on the TV via Kodi running on Vero 4K+ (notice this is loading directly from the device’s storage, which means Jellyfin is eliminated from the flow):

Mediainfo for the above sample (Indicates HDR10): GeneralUnique ID : 3084271859402799213728797625 -

Would appreciate any additional advice the forum members might be able to provide… Would love to be able to get the Vero 4K+ sorted out.

Adding to the above - I was able to get a USB drive formatted properly and copied the Dunkirk sample onto it.

I then played it directly off of the TV from the USB drive - the TV doesn’t provide the same HDR indication as before but it does display the string HDR10 on the top right of the screen.

So at this point, it seems to me that the setup of my Vero 4K+ connected to the TV via HDMI (with the TV recognizing it as an HDMI 1.4 input) and playing an HDR10 video from the Vero’s storage - does not seem to work properly.