IPv6 - No connection possible

Helly OSMC Forum,

since some days i’m also a proud owner of a Pi 3. OSMC is running fine and quite fast - very happy with it. Yesterday i also set up a VPN Server on the Pi and its working. Due to i have a IPv4 and IPv6 adress at home I want to use the IPv6 as well for the Pi.

And here the problem starts. After some hours of trying I could get a IPv6 adress for my Pi but it’s only a local adress and i can’t ping any IPv6 (like ipv6.google.com)

maybe you can help me to find the mistage in my settings to make IPv6 working for me… By the way: My Laptop have no problem with IPv6 connection using the same router (FritzBox)

Here some outputs from my Pi:

osmc@osmc:~$ ping -6 ba-ts.dynv6.net
PING ba-ts.dynv6.net (2003:78:ef7f:b42e:c225:6ff:fe65:8f02): 56 data bytes
ping: sendto: Network is unreachable

osmc@osmc:~$ ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::ba27:ebff:fe19:597d/64 scope link
       valid_lft forever preferred_lft forever

osmc@osmc:~$ ip -6 route
fe80::/64 dev eth0  proto kernel  metric 256

osmc@osmc:~$ route -6
Kernel IPv6 routing table
Destination                    Next Hop                   Flag Met Ref Use If
::1/128                        ::                         U    256 0     0 lo
fe80::/64                      ::                         U    256 0     0 eth0
::/0                           ::                         !n   -1  1    85 lo
::1/128                        ::                         Un   0   5    10 lo
fe80::/128                     ::                         Un   0   1     0 lo
fe80::ba27:ebff:fe19:597d/128  ::                         Un   0   2     2 lo
ff00::/8                       ::                         U    256 3   514 eth0
::/0                           ::                         !n   -1  1    85 lo

osmc@osmc:~$ ip neigh show dev eth0 lladdr c0:25:06:65:8e:ff REACHABLE dev eth0 lladdr d0:ae:ec:46:d9:bd STALE dev eth0 lladdr 80:56:f2:a5:97:5d STALE
fe80::c225:6ff:fe65:8eff dev eth0 lladdr c0:25:06:65:8e:ff router STALE
fe80::ba27:ebff:fe19:597d dev eth0 lladdr b8:27:eb:19:59:7d router STALE
osmc@osmc:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:19:59:7d
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::ba27:ebff:fe19:597d/64 Scope:Link
          RX packets:2403 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2521 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:892355 (871.4 KiB)  TX bytes:364168 (355.6 KiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:  P-t-P:  Mask:
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

osmc@osmc:~$ ^C

thank you in advance… i realy looking forward your answer :slight_smile:


IPv6 is disabled in OSMC by default, as many routers don’t implement it properly and it can cause problems for the user. It should be possible to get it going, however you will not be able to do this via My OSMC’s Network interface.

First, check lsmod shows ipv6 is loaded.

You will then need to manually enable IPV6 via ConnMan’s configuration file for the interface. See this resource for some guidance: doc/config-format.txt - pub/scm/network/connman/connman - Git at Google


Output of lsmod

osmc@osmc:~$ lsmod
Module                  Size  Used by
tun                    23320  2
bnep                   12310  2
hci_uart               22713  1
btbcm                   8478  1 hci_uart
bluetooth             425568  22 bnep,btbcm,hci_uart
8021q                  22147  0
garp                    7622  1 8021q
stp                     2430  1 garp
llc                     6031  2 stp,garp
xt_connmark             2118  2
iptable_mangle          1868  1
iptable_filter          1933  0
evdev                  13192  1
uinput                  9818  1
xt_nat                  2060  1
iptable_nat             2144  1
nf_conntrack_ipv4      15321  3
nf_defrag_ipv4          1888  1 nf_conntrack_ipv4
nf_nat_ipv4             7479  1 iptable_nat
nf_nat                 17492  2 nf_nat_ipv4,xt_nat
nf_conntrack          110903  4 nf_nat,nf_nat_ipv4,xt_connmark,nf_conntrack_ipv4
ip_tables              13095  3 iptable_filter,iptable_mangle,iptable_nat
x_tables               22152  5 ip_tables,xt_nat,iptable_filter,xt_connmark,iptable_mangle
brcmfmac              234783  0
bcm2835_wdt             4081  0
brcmutil                9348  1 brcmfmac
cfg80211              565548  1 brcmfmac
snd_bcm2835            24938  0
rfkill                 22502  4 cfg80211,bluetooth
bcm2835_thermal         2541  0
snd_pcm               115812  1 snd_bcm2835
snd_timer              25966  1 snd_pcm
snd                    78512  3 snd_bcm2835,snd_timer,snd_pcm
bcm2835_gpiomem         4026  0
lirc_rpi                9315  3
lirc_dev               11576  1 lirc_rpi
uio_pdrv_genirq         3885  0
uio                    10428  1 uio_pdrv_genirq
rc_core                25745  1 lirc_dev
fuse                  107913  1
ipv6                  447942  46

Okay – looks like you just need to configure ConnMan appropriately then. The ipv6 module is loaded.

maybe you can help me to configure ConnMan ?
this is my /etc/connman.conf


You need to configure via /var/lib/connman so you can enable IPV6 for the service.

I can’t easily test IPV6 in my environment, so cannot give much advice on this subject, but the documentation should cover it pretty extensively.


Better not screw with the config files. Connman has a control cli.

root@osmc:~# connmanctl 
connmanctl> services 
*AR Wired                ethernet_b827ebb16bfb_cable
connmanctl> config ethernet_b827ebb16bfb_cable --ipv6 auto
connmanctl> quit

This will enable IPv6 and save it persistently to the config

1 Like

the – is at the wrong place for it to work

1 Like

You are right, thank you. I edited my post to not puzzle people that find it anytime in the future.

1 Like

its still wrong --ipv6 auto is the correct syntax :slight_smile:

is it possible enable ipv6 on tap adapter permanently?

thx for your reply