Issues with mount and SMBv3 (connect to remote NAS)


I am using a FritzBox (router) with an attached HDD. The FritzBox shares the content of the HDD via SMB. After a recent FritzBox firmware update SMBv1 got disabled and it is recommended to connect with version 3.

But how can I get SMBv3 working? I am using entries in /etc/fstab to mount but the entry that worked fine for SMBv1 does not work anymore:

//fritz.nas/FRITZ.NAS/HDD4TB/mount/ /mnt/mount_fritz/ cifs noauto,x-systemd.automount,username=*****,password=****!,uid=1000,gid=1000,iocharset=utf8 0 0

I know that I can enable SMBv1 within the settings of the FritzBox again but I like to change my config to use a more up-todate protocoll.

Any suggestion is welcome.

Thanks a lot.

Check this: Configuring fstab based Samba share mounts

Thank you for the link. by following the instructions I was able to mount my directories

// /mnt/mount_fritz/ cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=*******,password=********,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=3.0 0 0

Great to hear that.