Kodi 16.0 - No audio visualization available

Nice idea! Got it back here too. Thanks.

is it a bug or a feature? I didn’t mind the visualisations (which aren’t very pretty) to be absent…

Same here, after the update I have no visualizations available to select. RaspberryPi2.

I also don’t see the active music being played anywhere like in the bottom left corner of the screen?

How do I get visualizations back? As it is it stays in the track selection screen and I’m unable to jump forward and back, only seek works.

I don’t have an old install to pull the old visualizations from.

…between this and Jarvis breaking my remote I’m not digging the update at all. Feels more like a regression than a progression.

edit: I’m looking for instructions on what I need to download and where in the downloaded file I can find the needed files. Trying to avoid installing to another sd card just so I can extract the needed files for copying to my working install.

If you have another linux box hanging around it’s quite simple. I ran the osmc installer in Windows and created another SD card install (I selected v 2016.1 and said no to update the installer). I then plugged that card into my linux box so I could mount the linux partition.

I then opened the file “filesystem.tar.xz” and extracted the files mentioned by webdandy. Finally copied them to the /home/osmc folder on both of my Pi’s, logged into an ssh session and moved them to the correct folder.

I then had to go into Programs/Addons and select which one to use.

I do but it’s a headless server so not likely to go that route with it- I’d be much more likely to just do anoter SD card on my windows netbook.

All in all it looks like this is just going to be more hassle for something that should have stayed in the default install if for no other reason than to showcase what is possible… to be honest I haven’t been that dig of a visualization fan in the past, but since it was there, I played with it and it won me over. Really not a fan of the Jarvis rollout.

But hey- thanks for the suggestion all the same :slightly_smiling:

Yup, all my linux boxes are headless as well. I do all the above through ssh.

I am too stupid - where did you copy those directories ? Both to .kodi/addons so that they merge ? And then what ? I did that and I don’t see them in a screen which allows to set visualization.

I didn’t make it clear in my original comment. I extracted the following folders from the archive:


I coped them all across to the user osmc’s desktop. I then logged onto each Pi through SSH (I have two Pis running osmc) where I found two folders waiting on the desktop:

/usr/lib/kodi/addons/ and /usr/share/kodi/addons

Move (or copy) the contents of each of these folders into the same folder on the Pi:

sudo mv /home/osmc/usr/lib/kodi/addons/* /usr/lib/kodi/addons/
sudo mv /home/osmc/usr/share/kodi/addons/* /usr/share/kodi/addons/

Don’t put the contents of one folder into both locations, they hold different information.

1 Like

You then have to go into the OSMC onscreen menu and go to Programs/Addons. Go into Look and Feel and you should be able to find the two visualization addons now listed - Gl spectrum and Waveform. Open up the one you want to use, and highlight “Use” and then OK and exit out.

I can’t remember where I went to test it, I think it was Settings, Appearance, Screensaver (I’m at work now). But then I made sure “use visualization” was selected, then went to Preview. I had a music file running, and up came the visualizer.

Yes, thank you, that worked. How did you know I used glspectrum and waveform ? What a coincidence :grin:

My headless linux box doesn’t have a card reader so it kinda puts me back at step one again… was honestly hoping I was overlooking an easy route to the files needed. ie: overlooking their location in the OSMC repo or some such. Guess I’ll be digging around looking for a spare SD card later. I need to buy a couple spares anyway I just don’t want to make a trip to MicroCenter just for though since I already decided I’ll be waiting to make a trip until they get Pi3s in stock.

Ha ha, because they’re the only ones in there!

Hi m_pan. I’ve zipped them up here: http://spacewarp.co.uk/stuff/visuals.zip

Would that help? unzip it and you’ll find two folders. If you’re only using Windows, the program WINSCP will help you copy them both across to your pi’s osmc desktop. You can then ssh in and copy the contents of each folder to the correct place.

Alternately (and probably easier!), load the SD card into your Windows card reader and copy the folders to the Fat32 partition. Put it back and fire up the PI, then ssh in. cd /boot will take you to the fat32 partition and you can sudo cp from there.


Brilliant! Exactly what I needed but didn’t want to ask for :smile:

I’m in the Filezilla camp but same end-effect. Thank you.


copied the files to what I think are the proper destinations…

my /usr/share/kodi/addons folder now shows: (only listing vis*)


while /usr/lib/kodi/addons shows:


I went into Add-on Browser ; My Add-ons ; Look and Feel ; Screensaver but it only shows Black, Dim, Qlock and Unary.

Settings ; Music ; Playback ; Visualization shows ‘None’

grrr… advice?

(the process I followed was to copy visuals.zip to a thumb drive on my Pi, putty’d in, unzipped visuals.zip to ‘vis’, cd /thumb/vis, sudo mv usr.lib.kodi.addons/* /usr/lib/kodi/addons/, sudo mv usr.share.kodi.addons/* /usr/share/kodi/addons/ )

edit: looking more- Visualisation in Jarvis

Did you reboot?

1 Like

I did not. Didn’t see it mentioned and I was in the middle of watching an episode as I did the above.

But I have now done so and there is a Visualization category under look and feel with Spectrum and Waveform in it.


Yes, the addons load at boot time, so you won’t see them unless you reboot. Sorry, should have mentioned it, but I’m working this out as I go along myself! Your command line looks correct from here. Both the usr/lib/kodi/addons and /usr/share/kodi/addons folders should both now contain two further folders “visualization.glspectrum” and “visualization.waveform” (though I admit I seem to have copied a third folder - visualization.vortex in one of them - ignore that).

However the contents of each of these folders are not identical. The …share/kodi/addons ones contain an xml file and a png. While the …lib/kodi/addons ones contain just .vis files.

EDIT: you sorted it as I was writing this! Excellent.

I am curious though, are the missing visualisations a bug in relation to the addition of “popcornmix’s ShaderToy visualisation” repo?

Personally I can’t find anything in relation to this repo on my osmc - Do these visualisations work with the pi?