KODI 17 on RPi, very slow start of viewing

I have an RPi with the latest OSMC and KODI Krypton.
I installed it fresh back when it was released on an RPi with wired connection to my router, which in turn is connected to the Internet by a 250 MBit/s fiber system.
Now after using KODI 17 for a while I am pretty annoyed by the slowness when starting to show any Internet based media. It displays “LOADING…” for close to 30 seconds before showing anything.
Is this a known issue or is there some kind of setting I can modify to make it run faster?
Showing local mp4 media is not a problem, it starts instantly. But all of the add-ons which display web media have this behavior. :frowning:
Note that everything else is the same as before (RPi unit, network connection etc) only the version of OSMC and KODI have changed, so either KODI 17 is inherently much slower or they have decided thta before showin anything they need to buffer several minutes of data or something…
Is there anything a user can do to improve this?
It is really frustrating to view for example the CBSN app where news snippets are listed, each maybe a couple of minutes long when changing to the next invokes a 30 second pause.
It was almost instant viewing in KODI 16.


We need to logs to diagnose, How to submit a useful support request

Also under kodi 16 were you using kodi cache, as the flags have changed under kodi 17.

Thanks Tom.

OK, I have enabled logging and debug.
Rebooted the system and then went to the CBSN Add-On and selected one news item, it took almost 30 s to start showing.
This is all I did except stopping playback and heading to MyOSMC to upload the log
The final upload screen showed this URL: http://paste.osmc.io/motilalanu (all in caps if that matters).
I used the CBSN add-on just because it was first in the list. THe loading problem is present on all internet related add-ons like YouTube, NASA, TED-Talks, SVTPlay and more

Start-Date: 2017-02-12  21:55:01
Commandline: /usr/bin/apt-get-real -o APT::Status-Fd=4 -o APT::Keep-Fds::=5 -o APT::Keep-Fds::=6 -f -y dist-upgrade

Does the issue persist if you upgrade to the most current version?

I did the update from my OSMC, it took a while and again it reset my skin setting to use the horizontal menu, which gives no overview at all. It did so also when I rebooted after removing the debug logging before…
Anyway I now went to CBSN Add-On and selected one news item and timed it. Took 32 seconds of “LOADING…” until the video was shown. :frowning:
Same in principle.
The download of the 100 MB update files went speedily though, so there seems to be no Internet connectivity issue here.

Hi Bosse_B,


According to the last post on this forum, neither the author or kodi are providing suport for this plugin. It may now be being supported by another author, but have you updated this addon since updating to Krypton?

You have also say you are saying you seeing this issue in other addons, have these also been updated to latest or auto-update turned on if available?

Being as cbsn may nolonger supported, could show the systems again with another addon as it may be easier to pin point the issue?

Thanks Tom.

I did not know that about the CBSN add-on. Bad because there was rather good info to be gotten from it.
Anyway I switched to SVTPlay add-on instead and tested it on a few programs.
The loading times were shorter than on CBSN but still substantial, like 16-17 sec for the 4 shows I tested with.
I don’t know how I can check if I have the latest, but I think that they do autoupdate.
The settings screens are now very different from what they were earlier so I am getting lost there.
By the way, the page you linked me to for creating the debug log is wrong for KODI 17. There is no setting as written in the place stated (Settings -> System -> and selecting Enable Debugging). I had to start looking around in order to find it…
Maybe a slight update is in order so that the navigational help actually is correct?

Thanks, the subsection -> Logging was missing.
I have now updated it as Settings -> System -> Logging and selecting Enable Debugging

Hi Bosse_B,

It seems your are correct and the instructions for debug logging are slightly out. I’m assuming you are using the OSMC skin, please advise if this is not the case.

Debug Logging

Setting > System > logging, on the right hand side under debug enable dubug logging using the radio button. The reboot and try and use sdtv again.

You should be able to double check if your video addons are up to date (I suspect your are correct in saying they are set to auto update)

Settings >> Add on browser >> My addons >> Video Add-ons

Here will be a list of you video addons, if you click on one of ones you are having issues with, that click update.

Thanks Tom.

@fzinken your post wasn’t here when I started mine, thanks for updating the guide.

No, I am using the AMBER skin since I started using KODI (on RASPBMC) a few years back.
Question regarding skins:
Can I activate a different skin (like the new OSMC skin) and see how they look like and if not to my liking go back to my AMBER skin and keep my custom skin settings for AMBER?
I have customized the skin to get rid of the extra fluff tha is still there in AMBER and I would really not like to lose that while checking out a different skin…

They are all set to auto-update, however the CBSN add-on update is only showing three versions in local cache. I guess that is because they discontinued this add-on…

Hi Bosse_B,

I don’t use amber skin, and I’ve just use the OSMC one. So I will not be able advise if you will retain your custom settings. Someone else should be able to advise.

Using provided instructions, you should still be able to provide debug logins for stream content from sdtv player. Could you please do so, so we can diagnose further?

*apologies SVTPlay

Thanks Tom.

The problem is not as apparent in SVTPlay as it is in CBSN, about half the loading delay or c:a 16 seconds. And on SVTPlay there are no short snippet items, just regular programs lasting 30 min or more, so the start delay is not as annoying, even though I would like to know why it is there.

Another observation is that after having updated to the really latest KODI as part of this troubleshooting effort the CVSN add-on has suffered more…
Now when trying to use it it still delays a lot for loading but now when it finally starts it also does not show video properly, it is totally broken up and only occasionally can one see a normal video. Sound is also stuttering along. All but useless now.
So I tried to find another add-on that could supply sensible US political news information (and is not in the alt-right camp like Breitbart or similar), but failed. I realize that this is OT here, but is there any way to get a news feed into KODI like the one via CBCN, when one lives in Europe?

Forum issue
Finally, tonight (European central time) the email alerts on the replies in the thread above arrived. During the active time there were no emails so I had to manually check for activity on this web page. How come the emails were not generated immediately when the reply posts were made?

It’s resolved.

Hi Bosse_B,

I had some time the another night to test with 2 of the plugins of you mentioned, I was unable to reproduce your issue; so I was awaiting more debug logs to investigate further.

I found the latest version of CBSN

GitHub · Where software is built (3.02 seems to be the latest version, what version do you have?)

a few second delay then the clips played fine.

SVTPlay - The same as CBSN, I think my slight delay is being caused by network setup (Network over powerline.)

Sorry I do not know of any alternatives for CBSN.

Without further debugging logs, I can’t say for sure what will resolve your issues. But I can advise the following:

Try a different network cable.
I could see in your logs you have a wifi adaptor attached (Product: 802.11n WLAN Adapter), Have you tried streaming over wifi. If the result is the same, then its probably not a network issue.
Restart your router.
If you are connecting through openvpn client, try temporarily disabling this. It could be issue with the openvpn server or client config which is causing this.

Thanks Tom.

I tried to find a way to quote your post in my reply, but there seems to be none except manually entering quote tags and text…
So here I list my answers:

  1. CBSN version: same as yours 3.0.2

  2. I tested again when checking the version and today there are no breakup of the video once it is playing…
    But the almost 30s loading delay persists before video starts showing

  3. Networking is like this:

  • 250 Mbit/s fiber from Internet
  • Wired (I think by a short CAT6 cable) to an 8-way switch in my study
  • Longer wired stretch (probably CAT5) to another 4-way switch in my living room
  • Short wired cable to the RPi unit running KODI
  1. WiFi usage
    I have not used the WiFi at home, it is only there to handle Internet connection when I am in my vacation home during summer. I might try and set it up to connect to the home router’s wifi too.

  2. No OpenVPN connection is used to access the Internet from this RPi

  3. I will try to produce a debug log again after I get back in a couple of hours.

Hi Bosse_B

Quoting text: Highlight the text you wish to quote from a post, a grey box should appear click quote.

Will review to new debugging logs, when you have uploaded.

Thanks Tom.

Back again:
I tried to use the WiFi adapter. I connected via MyOsmc and once done I disabled the Ethernet.
I even rebooted afterwards. But now I cannot get any video on CBSN or SVTPlay, both reports that items failed to load…

So I went back and disabled WiFi, enabled Ethernet and rebooted.
At this point both CBSN and SVTPlay seem to work and the load delays in CBSN have normalized to the same for SVTPlay, about 15-18 seconds.
Next I enabled logging, rebooted OSMC and went to CBSN and selected an item for display. Load delay about 16-17 seconds.
The logfile thus created is uploaded via MyOsmc as:
I then disabled logging and rebooted, still the load delay is between 15-20 seconds for both CBSN and SVTPlay.
Better but not really good.

If you’ve looked at the Kodi log, you’ll see a load of errors like:

11:54:05.107 T:1515189232   ERROR: ffmpeg[5A4FF3F0]: [h264] SPS unavailable in decode_picture_timing
11:54:05.108 T:1515189232   ERROR: ffmpeg[5A4FF3F0]: [h264] non-existing PPS 0 referenced

I don’t have any profound understanding of ffmpeg so I just did a search for the error and came across this post. The money quote was

These kind of errors in the log are “normal” for mpeg-ts files and just a sign of a bad cut, it should start playing after it skipped the broken part.

Which seems to be what happens. It skips n seconds and then starts playing.

Slow random 4k r/w speeds of your sdcard could easily also be an issue here. What card are you using? Have you tried another? Have you benchmarked?

8 GB Sandisk Ultra Class10 MicroSD HC I
I think it should be OK.
I have all of the media on a USB connected 1TB hard disk.