Kodi is crashing with portrait iPhone videos and hardware acceleration enabled

Please allow me to bump my topic/problem

Hi, should I expect support or should I look for a return ? Thanks

This will be fixed. I haven’t had a chance to look at this yet and reproduce the problem.

If the device does not meet your requirements, you can raise a request to return it via My OSMC.

It would be useful if you could provide a sample file as well as I could not produce this on iPhone XS on 4.9 kernel.

I sent you the files in PM

Received.

As mentioned to you in PM today, this issue seems resolved in our 4.9 release.

Cheers

Sam

1 Like

Hello Sam,
What do you call 4.9 release ? I’m up to date in My OSMC and it gives me the version 2020.03-1. For the linux kernel, the command uname -mr gives me “3.14.29-158-osmc aarch64”.

Thank you

The 3.14 kernel is now end of life.
See [TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

1 Like

Updating Linux kernel solved the problem. Thank you very much.

One more question : portrait videos are now stretched in landscape ratio while playing. If I modify the aspect ratio to the minimum (0,5) in the settings while playing, it’s better, but it’s annoying to do that on every video. Is there a way to play portrait videos with good ratio by default ?

Thanks

Thanks for confirming.

You could try ‘Set as default for all videos’

But it applies this ratio to landscape videos as well, so they become the ones stretched the wrong way.

And even with this ratio, portrait videos are still stretched in a weird way.

Disabling hardware acceleration allows to have perfect ratio on portrait and landscape videos without any settings, but then my .mkv files (MP4/h264) are playing in slow motion, so I can’t stay like this.

I have noticed that with hardware acceleration disabled, much more options are available in the settings while playing a video.

Any chance to get the good ratio with hardware acceleration ?

We can make the AR 0.5 for portrait by default if that’s what you want.

That would be great, but something is strange. With 0,5 ratio, minimal I can go, the video is still slightly too stretched horizontally.
Normal landscape ratio is 16:9. Portrait is 9:16 then. 9/16 = 0,56, so 0,56 should display correctly isn’t it ?
We need to go lower than 0,5.

OK, let me check it later.

With hardware acceleration disabled, what settings do you change to make it appear correctly?

Sam

Absolutely nothing, that’s why I don’t understand. Default settings everywhere, view = normal, and portrait videos display correctly without hardware acceleration. When acceleration is activated, portrait videos are now playing with 4.9 kernel but are stretched to 16/9.

Thank you Sam

Ok, can you show me a screenshot of the video settings in both instances?

Sam

Hello Sam,

Here is the settings window with hardware acceleration. You can see in the background that the video, supposed to be in portrait mode, is displayed incorrectly :

Here is the settings window without hardware acceleration. You can see in the background that the same video, supposed to be in portrait mode, is displayed correctly this time. More settings seem to be available :

Thank you for your help

Ok,
I will check this

Sam

Are you willing to try some test builds?

Sam

Hi, of course yes, just tell me how can I help :slight_smile: