KODI keep restarting when browsing my library

Hey i’m running the latest OSMC build on my brand new Verok 4K+
Kodi keeps resetting and then completely erasing my settings on Aeon MQ8 which is really frustrating when i’m trying to tidy up my library


Hoping to try and play something but this surely shouldn’t be happening it’s worse than my RPI4.

I’m also wondering why i can’t seem to get 4K at 60hz and i seem to be limited to 24hz which makes the menus feel real choppy. Especially when my TV is an LG C9 and should be fine.

Any help is much appreciated

To start I would recommend switching to our recommended display settings. Additionally I would recommend to disable video tag reading in your settings. Your audio channel setting should be set to “2” and not “5” as it currently is (you will still get multichannel via passthrough).

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Thanks and really appreciate the help so far.
I’ll hopefully get a log uploaded in the next couple hours but copying your settings exactly I still get freezes on 4K content. This content has played fine on all other devices i seem to get the BSOD about 1 second after executing play

Hey i’ve literally just had a crash i wasn’t doing anything CPU intensive, just browsing the ‘Movies’ section really slowly


Any help is appreciated.

I would switch your skin over to Estuary or the My OSMC skin and see if the crashing stops. Also your channels setting should be two, not three (2.1).