Kodi only plaus first video

when using OSMC and streaming video, the first video is shown only, then only audio is played.
HW is Raspberry 2, OSMC with latest update.
Video addon : SkyTG24, Rai On Demand.
The first stream after boot, is played then only audio is played.
Changing Skin to Transparency allows video to be visible as background of Main Menu screen.

The same doesn’t happen on other HW.

Dude… Logs…


Please see https://discourse.osmc.tv/t/how-to-obtain-provide-necessary-info-for-a-useful-support-request-includes-current-versions/5507s for information on how to provide a useful support request.


I’m having the same exact problem, loads the sources but won’t display them and freezes. Worked fine yesterday.

And a “me too!” without any meaningful logs/info will get no one any closer to a solution…

I don’t know how to upload my log, the link above does not work for me either

Is this the log?

Just activate Debugging and then go to MyOSMC log uploader (assuming your OSMC has still Internet access as you write earlier).

How can I upload the log if it freezes and all I can do is pull the plug and restart? Will it save the log through the reboot?


Your issue is not even remotely like OP’s issue and quite outside the scope of this forum. Seek support from your add-on developer.

The show played audio only like he described and now just freezes.
These are all shows I have on network tv and was using kodi vs my DVR. It worked fine yesterday and now nothing works after the update installed today.
I’ll keep searching, thanks

Your provided log demonstrates no failed attempt to play content from any local source.

while trying to catch the log, I had a problem with one of the video addons that stopped working.
What I did then is to try with a clean installation of all addons.
I uninstalled all the video addons first, then I removed the addons directories by means of File Manager.
Then I installed the video addons again and tried to reproduce the problem, without success.

I guess that one of my addons had a messy configuration, and this had side effects on all the others,
but I cannot help anymore as the problem is gone.

In my opinion, the fault was in one of the addons, if I manage to get the fault again, I’ll post the request
towards the addons.

OSMC and Kodi work simply great!