Loading Media Information From Files hangs at 0%

Every time I switch on my TV and the Vero 4K comes out of sleep mode, it quickly says ‘loading media information from files,’ but this never goes past 0%. When it’s doing this, playback for everything is super laggy, so I have to reboot.

Does anyone have a fix for this?

We need to understand the problem first…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Thank you for giving me the steps to log the error.

My only concern is that if I reboot the device twice, it won’t start ‘loading media information from files’ for quite a while and then the debug logging will run for a long time. Updating the library manually does not result in this issue, so I have to leave it to start doing that on its own.

Will it still be fine to upload that log?

What is a long time? Depending on your setup the logs still maybe reasonable sized after 1 day.
Also you could try to enable Library Update at startup to see if that triggers the error.

It won’t be a full day, so I am assuming it’s fine. Will enable that (disabled it to see if it would help) and will post the logs. Thanks you.

Here is my log file: http://paste.osmc.tv/ariputerup

I was able to recreate the error quickly by adding startup scans for both video and music.

I would highly recommend changing your UI resolution to 1080p

Click for more info on Display settings

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

and to disable the “sync playback to display” player setting.

As for the slowdown it looks like there is an issue accessing your music share. I’m not sure exactly why. I would probably start by double checking your share and file permissions.