Lost 2160p on vero after update

I just got my Vero. I plugged it in and set my display resolution to 2160p. Seemed to work fine.

Did an update of OSMC. Now my TV won’t sync up with whatever Vero is putting out for 2160p. When I select 4096x2160 (what I had selected before the update) I get no video output black screen until the “keep this setting” times out and it returns to 1080p.

I try 3840x2160p and the screen flickers, like there’s some kind of sync issue. I will see the full screen image for about 1/10 of a second before it goes black again for a few seconds and then displays again for 1/10s until the timeout completes again.

Please note: This all worked properly BEFORE I did the update. So the Vero was working properly out of the box, but not anymore.

I purchased the Vero4K for 2 reasons. HEVC playback and 4k support.

My TV is a Vizio E48u-D0, According to its specs, it can do 2160p60. I have verified this by connecting a Windows PC to the TV and switching to 4k resolution.

Please advise.

Don’t set the GUI to 2160p, it’s best to run it at 1080p.
With Adjust Refresh Rate enabled, OSMC will automatically switch to 2160p when necessary.

More info at New Vero 4k User initial setup.

If you keep getting flickering, try another HDMI cable.

That still doesn’t explain why it was working fine before the update with the same HDMI cable. I will test with leaving the interface at 1080 and running some 4k video.

I was just doing initial setup testing and wanted to verify that the Vero could, in fact drive my TV at 2160p60…and initially it did. then I do an update and poof! No changes to hardware at all. Just a software update was the only variable.

I don’t know if any of the other HDMI cables that I have are 2.0 certified. I’ll try the one that my Pi3 uses if I still have trouble. Keep an eye on this thread and I’ll update in a few minutes

There have been a lot of changes in recent updates; and some HDMI cables won’t work properly with the latest changes, particularly with the HDR10 improvements.

Rest assured, the device will meet your 4K and HEVC needs.


Here’s the update:

interface at 1080p with adjust frame rate=always and sync to display on.

Supplied cable: no video.
Old cable from Pi3: works.

2160p30 playback is smooth and crisp.
2160p60 is choppy.

I tried from both a network source and direct from a USB3.0 flash drive plugged in. Still choppy. Both are watchable, but not smooth.

I am using the Big Buck Bunny vid (x264) videos I mentioned in the thread where we discussed my plans to review the Vero.

The 2160p60 example is a 10 minute video, with a file size of 650MB. So I doubt it’s anything to do with being a “killer sample.”

Hopefully in the coming months, updates will improve this.

Disable Sync Playback to Display. It will break passthrough and give you

To be clearer about the “choppiness,” it only occurs in scenes where the entire frame is updated, such as when there is a camera pan, etc. If most of the background of the scene is static, playback at 60fps is smooth. Hoping that some improvements to the decoder will enable it to get those frames out to the tv faster.

As for disabling sync to display… when I do the video and audio on the 60fps samples get out of sync.

I don’t use passthrough, so having that turned on won’t hurt me.

I can play the video currently without issue. So I’m not sure that a new update is what we need here. I am using an NFS share however with some buffer tweaks, because there are high bitrates at the start of the video.

I’d disable Sync Playback to Display. Even if not using passthrough, Adjust Refresh Rate being enabled is better.

I’d also screenshot your settings so we can check them. Sometimes people don’t set up audio to use HDMI and it’s on PCM (you hear sound, but this should be changed).

Try the Jellyfish 120Mbps clip. I can play this smoothly off the internal storage (eMMC) without any system tweaks.

Well, I was on PCM. Switched to HDMI. Still have to turn on sync to display.

Which settings screens would you like screen shots of?

The Jellyfish 300Mbps clip works fine off eMMC as well. It starts instantly. Although this is quite out of spec: UHD Blu-ray discs only go up to about 120Mbps.

The 300Mbps Jellyfish clip should work for you. It will also test your USB3 drive’s speed. Let me know if you need Sync Playback to Display for that. The clip has no sound.


OK. It will take some time to get both of these clips. I have really slow (1.5Mbps) internet out here in the middle of nowhere. Once I get your test clips, I will test all with your recommended settings and directly from the eMMC.

Just to confirm:

Audio set to HDMI
Adjust display refresh rate = always
Sync playback to display = off
UI resolution = 1080p

Are there any other settings I need to make sure are adjusted to the baseline before testing the jellyfish (when I get them, lol…maybe sometime next week, lol)

That should be it.

If you have some local content (films etc on the drive), play it back / watch TV as normal and let me know if you experience any problems.

Will do. Wife is tired of all the tinkering. So we will “use normally” for a while, although we don’t have any 4k or high bitrate content in our “normal” stuff since we (until now) couldn’t play it.)

OK. I tested the 120mb and 300mb jellyfish files. They play perfectly smoothly. Unfortunately, neither video has audio, so I can’t verify audio sync (which is an issue for me with the 4k60 version of the Big Buck Bunny film.

I am playing all these videos off the eMMC, so that should give me the highest throughput.

What do I need to test/change/log in order to get useful information to you about the audio sync issue? You told me that you were playing the BBB 4k60 file without issue, so there must be a settings issue somewhere since we are using the same source on the same hardware.

Please advise.

You can learn more about how to submit a useful support request here.

But I took another look at this and realise the BBB 4K60 clip I sent you was the wrong one :rolling_eyes:.

How are other clips working?


I downloaded the BBB directly. From here:


4k60 file

I used the torrent link, but it’s to the same file.

I’ll go get some logs for ya as soon as I’m done watching the WAN Show.

That’s H264, not HEVC, which explains it. I pointed you to the wrong sample. I think I tested a different clip. I’ll look in to the one you linked.

Let me know how it goes.

The one I linked is x264 also. There are no “official” BBB clips in HEVC, which is why I transcoded one. I just hope that by transcoding I didn’t introduce too many variables for a good test.

Not official but at least a file that you might have the same starting point with