Manually add refresh rate

I know this is a bit of an odd situation but I was wondering if there was a way in OSMC running on a Vero 4K+ to manually add a resolution/refresh rate that’s not present in the EDID. Specifically I want to add 1080p50Hz (for playback of UK content). I know my TV supports this refresh rate and with my NUC running LibreELEC I used an xrandr command to accomplish this task but it doesn’t seem to work in OSMC on the Vero 4K+. In fact the Vero doesn’t seem to be running X as far as I can tell.

My TV is strange in that it will advertise the 1080p50Hz when it is off, but not when it is on. Since it advertised it when off I figured it may support it which is what lead me to try the xrandr command years ago in LE.


% cat /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap


% cat /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap

Any help would be appreciated.

It should be possible.

First question: are you connected directly to your display or is there an AVR in between?

There is an AVR in between. In anticipation of your next question, I connected the Vero directly to the TV and the 1080p50Hz still doesn’t show.

Which would indicate that the TV doesn’t support it and just the AVR fakes that mode when no device is active

Could be, though the mode does work and the TV displays it properly when it is forced as I had been doing for years on the NUC with the xrandr command. I’d just like to be able to do the same on the Vero.

Did you consult the TV’s manual to confirm? I don’t think it makes sense to sent something that is not supported natively.
Anyhow to answer your question, save the fake EDID the AVR is sending merge it with your TV’s one and force it to be used.

OP will need to manually add back the 4k modes to the copy of disp_cap.

My TV’s manual specifies the resolution and max refresh rates but not the individual refresh rates.

Anyway, I did the copy of disp_cap while the TV was on (when it displays most of the modes I want), and manually added 1080p50hz to the file, rebooted, and it appears to have worked. All of the previous display modes, including the 4k, appear to work and the 50Hz works as well.

Thanks for the help.