Migrating Kodi 14 from Pivos to OSMC on Vero 4K+

I finally received my Vero 4K+. Yay!

I updated Kodi 14>15>16>17 on my Mac and set up a new skin (Xonfluence) also on Mac.

Now how do I get my whole addons, userdata, and thumbnails folders over to .kodi on the Vero? Is FTP the only option? What about via a microSD card? How?

Edit: Moot since I’m now transferring via SFTP (couple hours to go…) Still for academic purposes for info for others…

Other questions, if not answered here will start new threads:

  1. Is there any diagram of the connections on the box itself? I assume that’s a microSD card slot… (there are no labels at all as you know)

  2. What’s the correct power state to be in when replacing the userdata folder? Right now it’s suspended and so far so good…

  3. Can we keep backup folders on microSD card?

  4. how do we return to orginal OSMC set up screen? Or can you?

  5. Since ethernet is working maybe best to shut off wifi?

  6. Confused about remote profiles. See a bunch in MyOSMC, and included remote seems to work, but there is no matching remote selected there. If we select another – for compatibility with a universal remote for example – will the included remote work?

  7. what the heck are all the remote buttons?

  8. really is there a manual for the 4K+ online? That’s one skinny printed manual. :slight_smile:

  9. why the USB dongle for infrared? why not built-in?

  10. where do you plug the extender (there seem to be two matching holes), and does that over-ride the USB dongle?

I will try to answer what I know

Not that I am aware of. But most connectors should be clear. I think the only one that might not be clear are the two 3.5mm connectors. The port nearest the HDMI is the analogue audio out, the port near the edge of the Vero 4K is for the IR receiver.
The SD Card slot is next to the USB Port above the two ventilation slots the one with the notch.

Well ideally you don’t want to have the mediacenter running. You could achieve that by choosing Exit from the Power menu and then login the command line (mediacenter will not restart till you type exit). Or login via ssh and use sudo systemctl stop mediacenter

Yes, even can use the backup tool from MyOSMC

You would need to delete the file \walkthrough_completed

Doesn’t harm to keep it enabled but feel free to disable

Those profiles are for IR remotes. They will work in parallel to the OSMC remote

There are really not much buttons! Which one is not clear to you?

No, but you have the wiki https://osmc.tv/wiki and for everything else please feel free to ask here.

IR is build in the Vero, but the OSMC remote is not IR but RF and therefore you need the USB dongle. Advantage no line of sight needed.

See my earlier replies. The one closer to the edge and no doesn’t replace the RF USB dongle.

1 Like

Thanks for the excellent answers, fzinken.

The main one got lost there – tho still sort of moot, hours later I’m still transferring 3+GB by STFP.

So:
A. How could I copy data from a microSD card to the Vero box?
B. Can the userdata folder be on the microSD card and pointed to it? Like with a symlink? How? Should it?

For me, exit returned to ba blue screen and then just started right back up.

Ok, thanks. I ask for another reason: I just want to determine which IP is ethernet and which is wifi. Ideas on that?

OK, my goal is to program a universal remote, so I suppose I just pick any common remote profile, and plug the IR extender in if necessary. Correct?

Then you’re also saying the USB dongle is used for RF with the included remote. Correct?

There are a couple buttons on that remote that aren’t clear, like a playlist icon, don’t have it in front of me right now. Be nice to have a diagram.

This indicates a network issue (shoulnd’t take longer than an hour). Suggest checking your network speed with iperf3.

Yes the SD Card wild be automount under /media and you simply can copy from there.

Technically yes, but not recommended as the emmc will be 10x faster and reliable than the SD Card.

Sorry, forgot. When the blue screen comes up need to press ESC but anyhow the SSH method is easier.

MyOSMC -> Network -> Wired/Wireless will show the IP

Yes that is how people do it

Correct

I think the chap has covered everything; but do let us know if anything is outstanding,

Sam

Thanks again fzinken & Sam. Almost got this up and running as desired. Main remaining problem is acceptable control with Harmony Remote, but as I realize there are other threads here for that, I’ll pick (most of) those up elsewhere. So here are some questions and comments on experience:

Questions

  1. Any idea why it’s mounted under media/3333-2222/ (I mean with such a number) and is that path expected to be stable?
  1. How do you press ESC? (If it has to be mapped onto a universal remote, how is that done, pref with the keymap editor addon?)

  2. This is probably a question for Harmony thread, but any idea why a startup action would cause the OSMC to reboot each time? In the action I’m using (based on Phillips SRM 5100), if I switch “activities” and back to OSMC, the box doesn’t reboot. If I power off system and hard power back on, Vero reboots (though it had remained on).

Comments

• A migration guide would have been helpful in the Wiki. It could include some of the main things I’ve been asking about in this thread, esp how to transfer an old set up via an SDCard to new Vero box. Best practices, etc, including how to copy, how to quit the mediacenter, etc.

• I found that NFS access on Vero under Kodi 17 is more restrictive than Pivos under Kodi 14. Don’t know where problem cropped up, but with the former I couldn’t access certain directories on NFS shares that I could with the latter. It turned out that I had to set permissions on directories for read access to “everyone”. read/write access for user, system, admin was not sufficient as it was previously. Seems related to this thread.

• Great place to put some diagrams of the box connections and the remote buttons. May seem obvious, and mostly is, but would be good reference…

It’s auto mounted under the “label” of the SD Card. If you want to change that you need to change the label of the SD Card.

Well this only make sense if you have a keyboard attached. Generally I would do all command line operations via SSH as it is much easier.

Feel free to start a Wiki entry, people can contribute.

1 Like

You can rename the drive in Windows to something more unique if you prefer, like ‘redrocklobster card’.

See Accessing the command line - General - OSMC

Not sure – maybe it’s sending a reboot remote code.

To be honest: not a lot of people migrate from such old versions of Kodi. I’m sure we can get something sorted for the near future.

For security reasons NFS is a bit more locked down than it used to be

Sam

1 Like

I managed to install iperf3 on my Mac via homebrew. It doesn’t appear to be pre-installed on OSMC, nor is there even a /usr/bin/ruby/ … I’m marginally familiar with unix, and can follow directions, but I have no idea how to install iperf3 on the OSMC. I don’t even know if I’d be looking for a ubuntu or linux binary or what. Suggestions?

Hi,

sudo apt-get install iperf3

Thanks Tom.

1 Like

awesome. installed. attempted to follow directions here, but can’t connect. I see the server operates on a particular port. Do you need to specify the port on the client? I tried with IP:port, but that didn’t work either. I tried with Mac as server and vice versa. With Vero as server:

osmc@Vero:/$ iperf3 -s
-----------------------------------------------------------
Server listening on 5201

MacPro: user$ iperf3 -c 192.168.0.234
iperf3: error - unable to connect to server: Host is down
MacPro:user$ iperf3 -c 192.168.0.234:5201
iperf3: error - unable to connect to server:

with Mac as server, without specifying port it just runs with no output until terminated. with specifying port it errors.

MacPro:doc lryter$ iperf3 -s
-----------------------------------------------------------
Server listening on 5201

osmc@Vero:/$ iperf3 -c 192.168.0.202
^C- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
iperf3: interrupt - the client has terminated
osmc@Vero:/$ iperf3 -c 192.168.0.202:5201
iperf3: error - unable to connect to server: No such file or directory
osmc@Vero:/$ 
-----------------------------------------------------------

Hi,

On the vero could you please issue:

grab-logs -A

and post the provided URL here.

Thanks Tom.

If it’s to the Vero 4K +, then it’s not a network issue (physically).
RX is not impacted in any of the 12 affected units.

SFTP is, very, very slow however by its nature. I suggest you install the FTP server and use that instead.

Sam

Just to clarify: where are we transferring things (sender and destination); and on to what medium?

Sam

You do not need to specify a port when running iperf3. I think that’s your issue.

Hi Tom. Seems Sam, below, doubts it’s a network issue (will comment on that below). But still would be curious how to get iperf3 running to test. Here’s an edited down version of the log. FWIW I believe there’s a lot in these logs that are too invasive and potentially a security risk (I used to have cleartext passwords in kodi logs for some share access, no longer, but…), it would be better to ask for the relevant portions IMO.

Hi,

It doesn’t appear to be a network issue on the vero side being as there are no TX drops (RX for matter) from the log provided.

It shouldn’t make any difference but you could try disconnecting from the wifi and try iperf again. If not you please provide the ifconfig from the mac?

Thanks Tom.

Unfortunately it can be hard for users to know what portions are relevant.
We strip out sensitive data where we can. Unless you publish a link to the log, no one can see it either.

Your Wired Network looks fine.

Simple way to test is turn off WiFi. If things play smoothly, you should be fine. While most playback is RX based, TCP requires ACKs (TX side); so if you had a physical network problem you’d soon notice.

SFTP’s not the fastest way to transfer files; and from above it seems you’re transferring to an SD card. That could be a limiting factor as well.

Cheers

Sam

I’ve no idea what this means. But yes, the original problem was it took a good 8 hours to copy 3GB to the Vero via SFTP on what’s supposed to be a 1g/bit ethernet connection. (If I had known how to copy from an SDCard that would have helped. Still unsure how to do it since the Vero is headless, no keyboard, etc. Other than copying userdata from /media/disk/ to ~/.kodi/ via SFTP client on Mac (Transmit). Would that be the best way to do it? Cuz I’d now like to go Vero->Mac for a full local backup.)

How to do that? Not in the Wiki. :slight_smile: Also via apt-get?
edit: apparently yes. But how to get the ftp server running then, and how to do so at boot (as SFTP)? Also how to set password?:
update-alternatives: using /usr/bin/netkit-ftp to provide /usr/bin/ftp (ftp) in auto mode

No I was transferring to the root of the Vero, to ~/.kodi/ … Was interested in using SDCard to transfer but not sure how (as above).

I tried both with and without, as shown. Still interested in running iperf3.

Not sure how to do that either, without going thru original boot sequence. But at any rate, why should that matter? The ethernet & wifi have different LAP IPs, and I’m trying to test the ethernet IP.

Kodi logs can have tons of sensitive data. Can’t see how it could be auto-stripped. :slight_smile:

You can disconnect from the wifi via myosmc. It shouldn’t be preventing the connection, just something worth checking.

Thanks Tom.