Mounting CIFS/SMB share from NAS

I’ve been streaming movies from my DS1010 to my Popcorn C200 for years, so I know it works. However, I cannot get the Vero to see the share using the normal user interface. The only way I have got it to work was to SSH to the Vero, and manually mount the cifs share:

“sudo mount -t cifs //DS10/movies ~/Movies”

which worked fine and the mount command showed the mounted share. I then shutdown and powered down the Vero, and restarted it. I can still see and access my movies from the share, but the mount command doesn’t show the mount anywhere! How is that working?


Ok two options:

If you want to be able to mount from within Kodi you can follow this advice (suggest to read the whole thread)

Alternatively (suggested) do a automount via fstab eg check this wiki

Hi fzinken,

Thanks, yes I plan to use the fstab method eventually, but I’m confused as to how I am currently able to access the share when it doesn’t appear to be mounted anywhere after a reboot!


That’s… odd.

Check cat /proc/mounts for a more verbose list of mounts.


I’ve added the fstab entries and on restart now get the following from /proc/mounts :slight_smile:

systemd-1 /mnt/Movies autofs rw,relatime,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct 0 0
// /mnt/Movies cifs rw,relatime,vers=1.0,cache=strict,username=guest,domain=DS10,uid=1000,forceuid,gid=1000,forcegid,addr=,unix,posixpaths,serverino,acl,rsize=1048576,wsize=1048576,actimeo=1 0 0

which I guess is correct? It seems to take a long time for the share to become visible.

Incidentally, if you power the unit off using the remote, how on earth do you turn it back on, there is no power button anywhere? The only way I’ve found was to power cycle it. Weird omission IMO.

Before without the fstab entries your mounting was not permanent

Can you explain what you mean with “long time to become visible”? These are automounts so their are only mounted when you access them and not before

The unit is designed to run 24x7 so don’t power it down. This topic as most of the issues in this thread had been discussed several times on this forum

He has used autofs, not x-systemd-automount

Thanks, assumed he followed the wiki I linked

I thought I had - I used the second (suggested) link you gave me and cut and pasted the fstab entry given there. Here’s what I put in fstab:

// /mnt/Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=guest,guest,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

It makes sense now - I was looking for the mount immediately after restarting the daemon etc, before I had tried to access the share.


Dave _

Yes, have found that discussion after I posted and understand. What I really need is to be able to turn the HDMI output off when I’m not using the unit. All to do with multiple HDMI sources and auto-sensing switch. Will post in feature requests if there is nothing in there already.