Mounting SMB shares from Macintosh on OSMC

I was using an older version of OSMC, pre the big SMB security update, with my Macintosh OS X 10.8.5 system. I was able to browse to and mount the SMB shares from my Macintosh.

I have now upgraded my Macintosh to OS X 10.12.6. I am still sharing files using SMB. The OSMC on my Raspberry Pi 3, hardwired ethernet connection, computer was no longer able to access the shares. The only thing that changed was the Mac OS.

To try to solve the problem I upgraded the OSMC to the latest version, OSMC 2018.1-1, Kodi 17.6.

I can still airplay to the Raspberry Pi so there is a connection between the devices.

In particular. I’m trying to add a video source under video>Files. I choose SMB. I choose to browse. WORKGROUP appears and I choose it. iMac appears (name of my Macintosh). I choose it. The wheel spins a bit and I get a dialog saying: “Operation Not Permitted”.

I also find that the OSMC does not appear when I browse the network for shares. An old Raspberry Pi 2 running OpenELEC does appear when I browse for it.

It would seem like there is an issue with respect to both the newer Mac OS and the newer OSMC.

Without SMB1 no browsing will be possible. Either need to reenable SMB1 or better add the sources via IP directly

Or better yet, use fstab :wink:

I don’t understand.

What is SMB1? Would it need to be reenabled in OSMC or Macintosh? I haven’t seen such an option in either place.

I think I’ve tried adding via IP but I don’t know precisely what the format OSMC is looking for. I’ve tried adding:
where my machine is : iMac
and the mounted drive is: video
and mount point is in the directory: volumes
It didn’t work, it just said “Operation Not Permitted”

Thanks for the reference. I’ll look at that.

Haven’t tried tutorial yet. Looking at it quickly I notice the use of smbclient to verify you can talk to the server. I did the:
smbclient -L -U sokolikm
it asked for my password which I gave. I got:
Connection to failed (Error NT_STATUS_CONNECTION_REFUSED)
Does this shed more light on what is going wrong?