Music Player / Wifi / BlueTooth Questions

No Problem :slight_smile: Thank you for your really fast answer!

First - The Log File is from MY Pi
Hope to get a Log from his Pi this week :slight_smile:

Problem 1 - I don’t know which player is used by the Pi in the moment. The Movie on this evening was an AVI, as well as the series. I boosted both the OMXPlayer and MMAL Player in the settings menu.

Problem 2 - Okay… So no solution so far for that “standard music player” thing. Could it be solved with any addon?

Problem 3 - Upcoming Log, hopefully tomorrow :slight_smile:

Problem 4 - As stated, the Log is from my Pi. Where the network issue IS an issue :smiley: And thanks for the “brother-in-law” vocabulary… Missed that one for the last posts :laughing:

Network Traffic issue:
Well… It could get interesting here… He has ~two walls between Pi and Router. Nothing in between, in another Angle (and between those two walls) are the smartphones.
I’m a floor above - installed a repeater in the room above=>next to his router - perfect signal. And between that repeater and MY Pi is just a plasterboard (?) wall and ~4meter distance.

All tested files work perfectly fine when watched on normal home computer. So its either a network traffic issue or a hardware issue with the Pi.

About the network issue, I always thought it wouldn’t be possible as my brother-in-law and my sister sit in another corner with their smartphones and not between the Pi and the router. But it could be possible to test the repeater in their room, too.

I didn’t have the chance to activate debugging on his and watch CPU-usage while those stutters… Because as already stated, when I sit next to his Pi, it works perfectly fine… That thing is scared of me :smile:

Ok, I think we need to go back to basics a little here.

  1. Pick one media file that isn’t behaving.

  2. Play it in each of these configurations and report back here which work and which don’t:

  • On your Pi over the network.
  • On your Pi from a USB stick
  • On his Pi over the network
  • On his Pi from a USB stick.

This will determine whether the network is the problem or the playback. And if the playback is different between the 2 Pis.

It would also be good if we could find out more about the file you are having issues. Please see the mediainfo section in How to submit a useful support request - General - OSMC

Also if these files have mpeg streams or vc streams then you will get much better playback performance if you purchase and install the appropriate licences from the Raspberry Pi official website. They are only a few $ and will enable hardware decoding which will make for much smoother playback.

Okay, maybe we can close something out.
The movie I’ve seen yesterday was “despicable me 2” as an AVI File. Dunno which codec, I’m gonna look that up after work today.

I asked him today if he watched it, too. He told me he did that multiple times.
Here’s the listing for that file:
On PC, it works flawless

On HIS Pi, he watched it several times. Sometimes it stuttered, sometimes it worked flawless. XSMC Boost ENABLED.

On MY Pi, I watched it ONCE, with a stutter in the beginning. I enabled XSMC Boost and it worked flawless from that on.

If necessary, I’ll try it out with an USB Stick on both Pis.

If I understand you correctly, you guess that it’s a network issue?

If it stutters when played across the network but not when you play it locally from a USB stick then it is the network that is causing the stuttering. There are things that can help with this like increasing the buffer cache which are detailed on other threads here.

If the same file also stutters when played locally then the issue lies with the playback and could be that it is a codec which isn’t supported on the Pi (like HEVC 265), or one for which you haven’t licenced hardware decoding (like mpeg) or it could be other settings on the Pi.

We will only know where to look once you have tested the file from a USB stick or the SD card and then we can determine the system which has a problem.

What exactly is XSMC Boost?!

Gnah, sorry. Always thought that was its name. Looked it up again - those both options are called “MMAL” and “OMXplayer”
Not XSMC. But you have to admit, when you’re not used to it, its possible to misspell some! :smiley:

Sorry for my mistake there!

Sooo… Progress this far:
Network Playback from Thursday - Saturday: Almost unplayable. Always stuttering.
USB Playback today (Sunday): Everything works fine…

Network Playback: Going worse. As always, as soon as I sit next to it, it (mostly) works fine. When my girlfriend watches something when I’m not home, its stuttering.
USB Playback: Couldn’t test it up to today. But I guess it would come out with the same.

So, this means, that the SMB Playback over Network is a problem?
What are the solutions?

  1. Ultimate solution fix the network
  2. You can try fstab based samba mounts or change to NFS which give better performance

Sooo… Finally time for that topic.

Today I tried fstab samba in the Pi. According to following manual:

My girlfriend had problems with Grey’s Anatomy - stuttering etc. With fstab, last episode worked flawless. Have to test furthermore.

I interrupted him watching a series from USB. Worked >flawless<
After the series was over, I set up fstab the same way I did on MY PI.
Set up the interface, so “Series” directly routes to his series drive and “Movies” to the movies drive. (path was /mnt/series/)

Now… Guess what. When selecting “Series”, the list was almost instantly up (before it was like 3-5 secs delay until the list was loaded). Back, now to “Movies” - Same fast list loading.
Chose a Movie - tested an AVI and a MKV Version.
In the first 5 seconds… Stutter. After 10 secs - complete hickup. I finally noticed something! The WLAN Dongle lost connection. It blinked like it was searching for a signal. Pi was warm, not hot. No temperature signal or anything. Sadly, I didn’t have the chance to check debug if CPU Cores were at 90-100%.
The complete hickup endured about a minute, I then disconnected the WLAN Dongle… Finally could step one menu down, exit the movie. As it might be seen in the log - I had to disconnect the keyboard & the dongle multiple times.
BUT! I finally got to upload a Log.
Here it is. Hope you can get anything from it :slight_smile:

Thanks in advance!

Next steps until next advice:

  1. Setting up a Pi with OMV and SMB / NFS Share - so I can test the NFS Share function.
  2. Watch my Pi how its behaving with the fstab samba setup.
  3. Let him watch over USB until then. :slight_smile:

Some more things that came up my mind:
We’re both “cooling” the Pi with simple heatsinks (no fans) and both use the RYDGES 2.5A 5V Power Supply.

We cannot troubleshoot 2 different pi at the same time. There is too much information to confuse between the two. Select one and we’ll carry on.

You are using Rpi3 with an additional USB Wifi Dongle? Why not use the onboard wifi? Did you disable the onboard wifi?

Did you test with a wired connection to confirm you have a wifi issue and not a problem with the server of the content?

Ok, it may claim to be 2.5A at 5V but has anyone confirmed that? Do you ever see the lightning icon?

Then lets focus on HIS PI for now. Watching over Network is more important to him than me :slight_smile:

Yes, RPi3 with additional wifi dongle as I read that the internal Wifi sometimes causes some issues. But if you tell me everything is alright, I can take the dongle away and try without it.
I disabled it in the ssh, although on next start its back up again… And as it didn’t seem to cause any issues, I ignored it.

Didn’t check with a wired connection - can do that too. Although often it works. And the server of the content is being inactive while something is being streamed from it.

I admit, I never measured the power source. But - yes, I did see the lightning icon ONCE while using a 1.5A power supply. Since using the 2.5A power supply, I’ve never seen it again.

How are you doing that?

Yet you are here reporting issues… Did you ever try with the onboard wifi and the dongle disconnected?

That will be a key bit to know moving forward.

This is not a debug enabled log. We need more verbose info from Kodi. Please enable debugging and demonstrate again in a new log.

Ideally we’d want logs for all affected devices.

A new post for each device will make things clearer.

@Terri this is what you need to focus on!

  1. Ensure internal wifi adapter is disabled
  2. Ensure that your power supply is up for the task
  3. Check signal strength with wavemon
  4. Check network throughput with iperf3
1 Like

Can’t retype it now as I’m still not so familiar. But I did it nearly the same way as enabling bluetooth on my Pi for RetroPi and PS3 controllers. Guess I’d have to disable it somewhere in a file?

No. As I said, didn’t think that would cause any issues. I’m using a RPi3 on my 3D Printer with a Dongle as well, and everything works perfectly fine, without disabling onboard WLAN. This made me guess that it wouldn’t cause any trouble.

I already had a feeling about that :confused: Okay, a few questions about that.
Enabling debugging makes that white headline with CPU Core status etc appear at the top corner of the screen, right?
Does that have to be >enabled< while the stutter is happening, or is it enough to enable it when the stutter has happened and just before I upload the debug log? Might be a dumb question, but as I told him to activate it he was all like “Ah… this annoys me a lot when watching a movie” - which I definitely understand. But when its necessary for troubleshooting, maybe I can test it again with the movie from today.

Yeah. I’ll put my Pi aside for a while as I think it might be the same problem. After I cleared his problem, I will get to mine again.

  1. will google where to disable it entirely and get back to that
  2. Okay… As no “Lightning Icon” has popped up until now, I guess the supply might be okay? Or is there any way to read that from a log or command, too?
  3. & 4. Will test those!

Thank you guys for your concerns and for helping me out with advice, although I’m not so familiar with the hardware :slight_smile:

Add dtoverlay=sdhost to config.txt in /boot

Not really any direct info in the logs. Not having lightning bolt is good. Overall was just a reminder that USB dongles are also depending on good power.


More or less annoying than watching a file with stuttering? Capture 2 minutes of the file stuttering with debug enabled them upload the logs. We’ve provided clear instructions in the link. If it was anyone’s intention to have people annoyed then we would simply be ignoring this thread instead of attempting to help.

1 Like

If you activate it via command line by editing advancedsettings you can enable debug logging without the OSD

    <loglevel>2</loglevel> <!-- Change this to "1" to hide the on-screen debug log text -->

Today I had some time to get to the topic.
As we already said, we’re now focussing on HIS Pi

I set the onboard WLAN with Drivers on the Blacklist, resulting in that the Pi only uses the Dongle now.
Wavemon was installed. He spits out a signal + quality, but he doesn’t show the graph for the Dongle.
Important to notice: After Boot, the quality of the signal is volatile. from 20-80% After 5 minutes, it calms down and floats around 50-70%. Closing the wooden door (which has a small glass plate in it) doesn’t affect the signal.

As I use a repeater on my floor, it plugged it in in his room, set everything up - still no change in Signal. Around ~50-80%. Repeater shows full signal on its side.

Fun Fact: When I take his Pi up to MY Floor, with repeater and everything, connected to HIS WLAN, I got stable 90-100% Signal Quality and fine playback - although it was at my PC in my work room, not my living room.

Third: Checked on that Power Supply. Aukro 5V 3A Power Supply. Was my mistake last time. It has 3 Amps.

So… Lets test those movies again. This time, HD Asterix, ~4 GB.
Started it and… Stutter. Made some more tries, checked wavemon etc… So - with debug enabled, I made a log file.

After that log, I disabled debug log, rebooted, started the film again… first 10 seconds, stutter… paused it, talked a little bit, resumed - it worked out fine. Even when fast-forwarding 30 minutes (which should definitively need another time to buffer) it worked instantly at that spot. Made some jumps forwards and backwards in the movie… No problems at all. Was the same movie all the time.

Oh… and all movies work out fine when they’re played locally with USB Stick.

Hope this one spits out some information.

Thanks again to all of you for your help :slight_smile:

Why not disable it via dtoverlay?

Also suggest to test network throughput with iperf3 over eg 10 minutes.
WiFi signal below 60% will cause scanning due to roaming.