My Bluetooth speakers won't connect either!

Hi Sam,
Many thanks for the frank reply. I appreciate you have only so many hours in the day and much to do, so I shall be patient. I am surprised however that there is no alternative or work around, surely my question is neither new nor unique.

I assume my Vero4k and Vero4k+ will also have the same problem. Am I correct or is the hardware sufficiently different. If so could use one of these pro tem? Possible?
Regards,
Budgie

Bluetooth audio streaming is a software solution. When we introduce it, it will work for all OSMC platforms.

We’ve never actually supported Bluetooth audio streaming yet in any official capacity, but we anticipate doing so soon.

There is indeed a work-around. You can install bluez-alsa now and a search on the forums should show you how to do this. But keep in mind that it is experimental.

Thanks

Sam

1 Like

Hi Sam,
Many thanks but what about me using my Vero4k for bluetooth speakers instead. I have a Vero4k I can use but need to know before I pull it from another use.
Budgie

The steps would be the same of Pi and Vero.
If you want to give it a try @grahamh could give you the details.

Hi fzinken, I saw the thread between Tunttis and @grahamh for which thanks. That discussion and successful outcome was working with a Vero4k+. I am going to try it with my virgin OSMC installation on the RPi3b but may need some help. Not sure of forum etiquette but would it be possible for me to link to that thread or just continue here and ask question if I get stuck?

either will do. Just mention me in any question.

There’s a draft HowTo here but I think Sam’s working on some steps to make the process simpler, hence it’s not officially published.

Hi graham and thanks for the prompt reply. I downloaded armv7-bluez-alsa-osmc.deb and tried to install it and found three dependencies missing:-

dpkg: dependency problems prevent configuration of armv7-bluez-alsa-osmc:
armv7-bluez-alsa-osmc depends on libbluetooth3; however:
Package libbluetooth3 is not installed.
armv7-bluez-alsa-osmc depends on libsbc1; however:
Package libsbc1 is not installed.
armv7-bluez-alsa-osmc depends on libfdk-aac1; however:
Package libfdk-aac1 is not installed.

dpkg: error processing package armv7-bluez-alsa-osmc (–install):
dependency problems - leaving unconfigured

I am used to using zypper and repo sites so have no idea how to sort these dependencies. I am working with ssh on my laptop but have keyboard and mouse connected so whichever is easier but please give me a clue!

You can try:
sudo apt-get install --fix-broken
It can often pull in the missing dependencies.

If that doesn’t work try:

sudo apt-get install wget libbluetooth3 libsbc1 libfdk-aac1

Oops! I missed that bit out. We should have a proper apt-get install soon which will deal with those dependenices.

Hi and sorry to have missed the important part of the thread. I now have everything installed and on my screen I can see that my KEF MUO is highlighted in the Paired Devices column in the bluetooth tab of My OSMC network page.
Sadly I cannot get any sound out of it. I tried turning off the Settings>System>Audio>Keep audio device alive but I still get the sound through HDMI.

From the command line I could achieve pairing and trust succeeded but then the BT device failed to hold the connection and turned off. I turned on the BT device again then tried to connect and then I received a Legacy Pairing message. Now lost again so did agent off and quit. Here is where I lost my way:-

Linux osmc-Barnaby 4.19.122-2-osmc #1 SMP PREEMPT Sat Jul 4 02:39:56 UTC 2020 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Dec 10 20:44:09 2020 from 192.168.169.235
osmc@osmc-Barnaby:~$ bluetoothctl
[NEW] Controller B8:27:EB:E2:F3:2F osmc-Barnaby [default]
[NEW] Device 40:EF:4C:CC:DE:9E KEF MUO
[bluetooth]# agent on
Agent registered
[bluetooth]# scan on
Discovery started
[CHG] Controller B8:27:EB:E2:F3:2F Discovering: yes
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -66
[CHG] Device 40:EF:4C:CC:DE:9E TxPower: 4
[bluetooth]# pair 40:EF:4C:CC:DE:9E
Attempting to pair with 40:EF:4C:CC:DE:9E
[CHG] Device 40:EF:4C:CC:DE:9E Connected: yes
[CHG] Device 40:EF:4C:CC:DE:9E Paired: yes
Pairing successful
[CHG] Device 40:EF:4C:CC:DE:9E Connected: no
[bluetooth]# trust 40:EF:4C:CC:DE:9E
Changing 40:EF:4C:CC:DE:9E trust succeeded
[bluetooth]# connect 40:EF:4C:CC:DE:9E
Attempting to connect to 40:EF:4C:CC:DE:9E
Failed to connect: org.bluez.Error.Failed
[bluetooth]# connect 40:EF:4C:CC:DE:9E
Attempting to connect to 40:EF:4C:CC:DE:9E
Failed to connect: org.bluez.Error.Failed
[CHG] Device 40:EF:4C:CC:DE:9E LegacyPairing: yes
[CHG] Device 40:EF:4C:CC:DE:9E LegacyPairing: no
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -56
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -69
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -55
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -65
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -56
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -67
[bluetooth]# agent off
Agent unregistered
[bluetooth]# quit
[DEL] Controller B8:27:EB:E2:F3:2F osmc-Barnaby [default]
osmc@osmc-Barnaby:~$

Is there something obvious I have missed?

What does
info 40:EF:4C:CC:DE:9E
give you in bluetoothctl?

What does systemctl status bluealsa give you?

Had to install info and it may not be correct but here are the results;-

osmc@osmc-Barnaby:~$ info 40:ef:4c:cc:de:9e
info: No menu item ‘40:ef:4c:cc:de:9e’ in node ‘(dir)Top’
osmc@osmc-Barnaby:~$ systemctl status bluealsa
● bluealsa.service - Bluealsa daemon
Loaded: loaded (/lib/systemd/system/bluealsa.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Docs: GitHub - Arkq/bluez-alsa: Bluetooth Audio ALSA Backend
osmc@osmc-Barnaby:~$

Looks like I messed up again but hope you can help.

Nope, as @grahamh wrote

So first start bluetoothctl and then run info 40:ef:4c:cc:de:9e

To fix this try

sudo systemctl enable bluealsa
sudo systemctl daemon-reload

Then in bluetoothctl

remove 40:ef:4c:cc:de:9e

and go though the agent/scan/pair/trust/connect sequence again.
Sorry there’s so much manual intervention, but this is work in progress/experimental.

Absolutely no need to apologise, I am just so grateful you are taking time to help. I am concerned as I have crossed with fzinken in this thread and I think it should be me who apologises to both of you for my being so dumb. I ran the commands sequentially and at least the results will give you a clue as to what is going on. My BT device now has a connected light indication that it is connected.
Going to the RPi device and looking at the My osmc>network>bluetooth the KEF MUO is in the paired devices column but the sound is still coming from HDMI.
In my Settings>system>audio>audio output device I have ALSA:bcm2835 ALSA, bcm2835 ALSA.and also ALSA: Default (bcm2835 ALSA bcm2835 ALSA).
Whichever I select I get a brief hiccup and playing on HDMI continues.
While typing the BT device has decided it has nothing to do and turned itself off.

It would help if you had the info!!!

osmc@osmc-Barnaby:~$ bluetoothctl
[NEW] Controller B8:27:EB:E2:F3:2F osmc-Barnaby [default]
[NEW] Device 40:EF:4C:CC:DE:9E KEF MUO
[bluetooth]# info 40:ef:4c:cc:de:9e
Device 40:ef:4c:cc:de:9e not available
[bluetooth]# sudo systemctl enable bluealsa
Invalid command
[bluetooth]# exit
[DEL] Controller B8:27:EB:E2:F3:2F osmc-Barnaby [default]
osmc@osmc-Barnaby:~$ sudo systemctl enable bluealsa
Created symlink /etc/systemd/system/bluetooth.target.wants/bluealsa.service → /lib/systemd/system/bluealsa.service.
osmc@osmc-Barnaby:~$ sudo systemctl daemon-reload
osmc@osmc-Barnaby:~$ bluetoothctl
[NEW] Controller B8:27:EB:E2:F3:2F osmc-Barnaby [default]
[NEW] Device 40:EF:4C:CC:DE:9E KEF MUO
[bluetooth]# remove 40:ef:4c:cc:de:9e
Device 40:ef:4c:cc:de:9e not available
[bluetooth]# agent on
Agent registered
[bluetooth]# scan on
Discovery started
[CHG] Controller B8:27:EB:E2:F3:2F Discovering: yes
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -61
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -73
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -57
[CHG] Device 40:EF:4C:CC:DE:9E RSSI: -75
[bluetooth]# pair 40:ef:4c:cc:de:9e
Device 40:ef:4c:cc:de:9e not available
[bluetooth]# trust 40:ef:4c:cc:de:9e
Device 40:ef:4c:cc:de:9e not available
[NEW] Device 30:95:6A:50:B2:EC 30-95-6A-50-B2-EC
[bluetooth]# connect 40:ef:4c:cc:de:9e
Device 40:ef:4c:cc:de:9e not available
[bluetooth]# scan off
[CHG] Device 30:95:6A:50:B2:EC RSSI is nil
[CHG] Device 40:EF:4C:CC:DE:9E RSSI is nil
[CHG] Controller B8:27:EB:E2:F3:2F Discovering: no
Discovery stopped
[bluetooth]# agent off
Agent unregistered
[bluetooth]# quit
[DEL] Controller B8:27:EB:E2:F3:2F osmc-Barnaby [default]
osmc@osmc-Barnaby:~$

Now I have “info” command working. Error my copying and paste. I think this is what should appear:-

[bluetooth]# info 40:EF:4C:CC:DE:9E
Device 40:EF:4C:CC:DE:9E
Name: KEF MUO
Alias: KEF MUO
Class: 0x240428
Icon: audio-card
Paired: yes
Trusted: yes
Blocked: no
Connected: no
LegacyPairing: no
UUID: Serial Port (00001101-0000-1000-8000-00805f9b34fb)
UUID: Vendor specific (00001107-d102-11e1-9b23-00025b00a5a5)
UUID: Audio Source (0000110a-0000-1000-8000-00805f9b34fb)
UUID: Audio Sink (0000110b-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb)
Modalias: bluetooth:v000ApFFFFdFFFF
[bluetooth]#

Time flies when you are having fun. I saw that after running bluetoothctl and then info most of the info looked right so I tried running connect from the bluetooth prompt and I now have a connection and the prompt is KEF MUO thus:-

osmc@osmc-Barnaby:~$ bluetoothctl
[NEW] Controller B8:27:EB:E2:F3:2F osmc-Barnaby [default]
[NEW] Device 40:EF:4C:CC:DE:9E KEF MUO
[bluetooth]# info 40:EF:4C:CC:DE:9E
Device 40:EF:4C:CC:DE:9E
Name: KEF MUO
Alias: KEF MUO
Class: 0x240428
Icon: audio-card
Paired: yes
Trusted: yes
Blocked: no
Connected: no
LegacyPairing: no
UUID: Serial Port (00001101-0000-1000-8000-00805f9b34fb)
UUID: Vendor specific (00001107-d102-11e1-9b23-00025b00a5a5)
UUID: Audio Source (0000110a-0000-1000-8000-00805f9b34fb)
UUID: Audio Sink (0000110b-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb)
Modalias: bluetooth:v000ApFFFFdFFFF
[bluetooth]# connect 40:EF:4C:CC:DE:9E
Attempting to connect to 40:EF:4C:CC:DE:9E
[CHG] Device 40:EF:4C:CC:DE:9E Connected: yes
Connection successful
[CHG] Device 40:EF:4C:CC:DE:9E ServicesResolved: yes
[KEF MUO]#

Looks better but sound still coming from HDMI.

Does the BT device show up in Settings-System-Audio?

If not, have you constructed a .asoundrc file? (note the dot .) It should look like this:

pcm.kefmuo {
type plug
slave.pcm {
        type bluealsa
        device "40:EF:4C:CC:DE:9E"
        profile "a2dp"
}
        hint { show on description "KEF MUO"}
}

If you type nano ~/.asoundrc you can cut and paste what I’ve typed above into that file - Ctrl-X to save and exit.

Then restart Kodi with Power-Exit.