New bug in NFS? Almost nothing playing from my NFS share, started like four days ago

Logs here:

Situation in logs: first start playing “The Big Short”, black screen after few seconds, then movie stops by itself. Second, “Changeling”, movie does not even start, just black screen.

I believe that these bugs are related to NFS, because when playing “Changeling” directly from USB, it seems to work.

NFS share works perfectly when tested from other clients, also software NFS runs on did not change last months at all, hard drives all in perfect condition.

I am quite lost now.

What is the NFS server?

1 You seem to have a deprecated NFS package still installed, armv7-libnfs-osmc, that might be causing a conflict with the Debian package, libnfs12. I don’t think any harm will occur if you remove the deprecated package:

sudo apt-get remove armv7-libnfs-osmc

then reboot.

2 Your log is showing an error message:

2021-01-30 22:39:21.390 T:3939885280 ERROR: Failed to close(mnt/Multimedia/Movies/The Big Short (2015)/ - close call failed with "NFS: Commit failed with NFS3ERR_ROFS(-30)"

that appeared recently here. The takeaway from that thread was that the OP should wait until after Kodi 19 is released and report back if it still occurs.

Sure, it is:

nfs-utils 2.5.2-2
nfsidmap 2.5.2-2

/etc/nfs.conf has all options commented out, so vanilla setup is used, /etc/exports is:


Server is Arch Linux, everything updated to latest.

Name : nfs-utils
Version : 2.5.2-2
Description : Support programs for Network File Systems
Architecture : x86_64
Licenses : GPL2
Groups : None
Provides : None
Depends On : rpcbind nfsidmap gssproxy libevent device-mapper
Optional Deps : sqlite: for nfsdcltrack usage [installed]
python: for nfsiostat, nfsdclnts and mountstats usage [installed]
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 1372.36 KiB
Packager : Andreas Radke
Build Date : Sun 25 Oct 2020 09:57:55 PM CET
Install Date : Wed 04 Nov 2020 08:52:39 AM CET
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

I am pretty sure that everything worked even after I updated to latest nfs-utils.

Follow up: Tried to revert to 2020-06 release, issue persists. I will investigate the server side.

Do you recommend any alternative protocol to replace NFS on local network? I have experience that NFS provided me with relatively fast seeking and just worked. Do you recommend anything other?

Since you claim other nfs devices do not have an issue with the server, my first idea is to inspect the infrastructure between the Vero and the nfs server, have a look here: [How To] Check Network Performance with iperf3

On linux, using SMB with autofs mounts I’ve never had a problem with playback or seeking on local network.

There was (is?) a guide on here how to setup autofs but I can’t find it at the moment.

Use kernel-based NFS.

THis is exactly what I tried right now. It works. Case closed.

Only one thing, I did not find how to change keyboard layout in osmc’s linux distro. So much different from Arch…

See if ths thread helps. OSMC on RPi3B+ how to change keyboard layout?

Here you go

1 Like

I decided to use systemd automounting feature with fstab.

Well, that sucks.

OSMC should really really implement/add “loadkeys” support and “setfont” support. Much easier to use:

You have the kbd package installed, so both those commands should be there.

I’m happy to accept a PR on this.

You aren’t using Hanewin on a Windows box, are you?



I’m experiencing the same problem with my NFS shares on my vero 4k+.

Everything was working smoothly until my server (my Archlinux computer) updated to kernel 5.10.8 (or .9, I can’t really remember). Since then, It’s like I have a <10mbps LAN. Everything’s working fine with the samba shares.

When I boot my computer with the LTS kernel (5.4.x serie), it works normally.
And I have the same problem with my rpi3 still running libreelec (latest stable). So it’s like the old 3.4.x kernel doesn’t like the “newer” NFS. Because I don’t experience any problem with all my computers playing the same videos. Computers on Archlinux and Debian.

I made the shares from kodi UI, like a simple user. You were talking about using kernel NFS. So when you use the UI, what does it use ? userland NFS ? So what is the kernel NFS ? The fstab mount ?

Thanks a lot for your help.

(I know I could stick with the samba shares, but I prefer NFS, I find it usually more stable…)

Are your NFS shares read-only?

Yes, or autofs.

Yes, I completely removed “Kodi shares” and mounted all my network drives with fstab-based method with NFS, specifically, I used this code fragment - NFS - ArchWiki

Now, it works to perfection.