New Rpi4 install does not output hdmi

If I install an older version of osmc on my Rpi4 it works. If I perform an update after the reboot it looses the HDMI signal after the splash screen.
Visually, it looks similar to this issue.

sudo journalctl | paste-log

paste-log /home/osmc/.kodi/temp/kodi.log

Well that’s embarrassing, after a second attempt troubleshooting and reading the forum, I swapped my power supply and that appears to have fixed it.


Okay, might be more complicated than I thought. The same problem has returned.

While your case sounds a bit different as it originally was triggered by an update check out this thread that was solved by replacing the mini hdmi cable with an adapter.

Update time. I went a bought a new HDMI to micro HDMI cable and an official RPi power supply. No change…
So I took the Pi out of the Argon One case I had just put it in, and it started working.
Interestingly, using the power board only, lets the pi operate normally. Using the board, that relocates the HDMI and audio ports, causes the HDMI output to fail.
Has anyone else had similar issues with the Argon One case?

I bought a rp4 from canakit and had the same problem. I’ve ordered an adapter to see if it fixes the issue. It also has a case like @jmbmkn but it’s just a simple plastic one, it’s just holding the rp4 in place. I was able to boot using their included NOOBS memory card, when I formatted with the OSMC image, it loaded and installed, but now when it boots, I see the startup splash icon for OSMC and then it goes blank. My suspicion is that the cable is just not high quality. They include 2 of them for the 2 ports on the Pi. I’ll report back if the adapter works.

Replying for any poor souls who have the same issue. Confirmed that the HDMI cable provided by canakit is insufficient for Kodi, for whatever reason. An HDMI cable from Monoprice and small adapter for the mini HDMI (Pi connection) fixed the problem. Might want to update the docs/wiki on this

Another update. I really want to use the Argon One case, so I went to get the V2 that has full sized type A HDMI sockets. Having now fit my Pi4 in the case, I have the same issue no HDMI output. Can anyone make a guess at why the Argon One case might cause the HDMI output to fail?

Going to test with another OS

If you check this thread:

You can find a possible solution for the black screen problem if you have a 4K screen and also if you check the Github link in the thread you’ll see there’s a problem with the Argon One’s HDMI passthrough. If you avoid using the passthrough your picture might come back, if it doesn’t then you can try making the changes to configuration files and Kodi settings see if it comes back.

Thanks for pointing that out, looks like a fix is being worked on, so that’s good news

It might be just as simple as trying the other HDMI socket, it looks like the two sockets are swapped round on the Argon case.