New vero 4k cant see win10 network shares

I have bought a vero 4k and am trying use my win10 network shares but the vero cant see them.
On OSMC i go to videos/files/add videos/browse/ widnows network (SMB) but that doesnt return any video files.

Connected via Ethernet and I did a fresh win10 install so all my network settings are stock.

Really not sure what to do :frowning:

Are you updated to the last version of OSMC?
Well some people find browsing to be broken (I can’t confirm as it works for me).
But assuming you can not browse it you have two options:

  1. Add it manually via SMB menu option
  2. If you are going to use that as your main Media source you may want more performance than choosing mounting via fstab may make sense. There is an article in the wiki for that

I updated OSMC to latest version.
Im not sure how to manually add a shared folder via SMB menu option.

I totally dont know what im doing :frowning:

Check this out. Your screen might look a little different, depending on the skin you are using.

I think you also posted on Geekzone.


Thanks for the guide, it totally worked. :slight_smile:

Another question.
Is there a way to specify both movies and tv shows to scan for/collect data for? As i have folders that have both film and tv in them.
I can only select movies or tv. Some kind of “all” option??

No, you will need to separate your movies and TV shows. That’s just how Kodi works. (Plus it will make it easier in the future for you to maintain your files)

Ok now Im trying to setup fstab as I find the vero 4k struggles with most 4k content I have. Over 100Mb Ethernet.

Configuring fstab based Samba share mounts

I have been using this guide but cant get anything to work. I think i enter the details of the windows 10 share folder I’m trying to use correctly.

What is the error you get when you try to mount?
Share your fstab your giving URL of cat /etc/fstab | paste-log and the result of sudo mount -a | paste-log

Im just trying to share folder sw1 on my win10 pc.

# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root  /    ext4      defaults,noatime    0   0
// /mnt/Server_sw1 cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=AL,password=zzz,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

And the result of sude mount -a paste-log

{“message”:“Document not found.”}

sudo mount -a | paste-log

{“message”:“Document not found.”}

Is the result I get from sudo mount -a | paste-log


Just tried sudo mount -a | paste log and I’m getting the same result, so lets try something else:

sudo mount /mnt/Server_sw1

Please post any errors.

Please post the output of:

df -h

Also is if you issue:

ls /mnt/Server_sw1

Do you see your files?

Thanks Tom.

From sudo mount /mnt/server_sw1 I get

mount: can’t find /mnt/server_sw1 in /etc/fstab

Filesystem Size Used Avail Use% Mounted on
devtmpfs 785M 0 785M 0% /dev
tmpfs 895M 17M 879M 2% /run
/dev/vero-nand/root 14G 1.5G 12G 12% /
tmpfs 895M 0 895M 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 895M 0 895M 0% /sys/fs/cgroup
tmpfs 179M 0 179M 0% /run/user/1000

ls /mnt/Server_sw1

ls: cannot open directory ‘/mnt/Server_sw1’: Host is down

Linux is case sensitive. Try:

sudo mount /mnt/Server_sw1


still the same result
mount: can’t find /mnt/Server_sw1 in /etc/fstab

Is my line correct??
// /mnt/sw1 cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=AL,password=zzz,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

That’s not the line you originally posted. Looks like you changed the name to sw1 now. So first make sure your created /mnt/sw1 and then mount it.

to use folder sw1 on win10. It works fine when when added via SMB option but 4k not possible with buffering and stuttering :frowning:

// /mnt/sw1 cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=al,password=add,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

I shouldnt have to do anything in win10 right as it already shares properly.
Probably doing something simple and obvious wrong … I dunno :(:slightly_frowning_face:

So what happens if you try to mount now?

sudo mount /mnt/sw1

You have to

sudo mkdir /mnt/sw1

before trying to mount.