New Vero 4k plus cannot sync audio and video for certain videos

I just received my new Vero 4k+, and it plays 4k and other HD files perfectly, but the funny thing is that when I try to play 480p and other low quality video the audio and video does not sync. It seems like the video is playing slowly while the audio plays at normal speed. Anyone knows what would cause this issue? It was never a problem on my old Vero or for OSMC on the RPi4.

Please provide mediainfo of the file.

Also please upload logs via Settings - MyOSMC

Will upload logs. How do I retrieve mediainfo of files?

There are several ways to get the mediainfo information, perhaps this online method is the appropriate way to do it for you, MediaInfoOnline - MediaInfo in your browser and use “text” format. The result you can paste here as preformatted text.

Thank you, here is the mediainfo of one of the files that showed the above explained behaviour, but there are many more. Would more mediainfos help at all?

I am trying to enable logging according to How to submit a useful support request - General - OSMC, but going into Settings → System → Logging there is no option to select “Enable Logging”. I am in Expert mode and all I can see is “Enable component-specific logging” and “Enable event logging”. Is it either of these options I should be selecting?

Actually this can be closed. For some reason it wasn’t working for me last night, but trying it again now it is working. Not even a reboot was necessary :man_shrugging:

Hopefully the issues won’t resurface again.

1 Like

For the next time you should do:

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Since you didn’t post logs I can only guess, but make sure that the GUI is set to 1080p and Adjust Refresh Rate is On start/stop. Having the GUI set wrong causes odd problems.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

I did not know this was the case. Thank you!