New Vero 4K remote control dead

Hi there,
I just received my new Vero 4K last week, so I installed it this weekend.
Everything worked just fine, but after a normal shutdown/reboot via KODI-menu
the remote was dead.
I tried the re-pairing process, the blue led in the remote lights up etc.
but the remote does not work!
So what else could I do? Is this a driver problem?
Is there a possibility to test the remote donlgle on a PC?


Sure, plug it in and try it out.


Ok, I will try it in the evening.

Had the same problem 2 weeks after i received my new Vero 4k. The last thing i tried was to replace the battery and that was indeed the problem! So maybe try to measure or replace it. No further problems yet for me (this was around 2 months ago).

I tried the pairing on a normal Windows PC and on a MacBook.
Unfortunately both failed.
Changing the battery even has no effect on this.

Someone wrote in the forum that the led of thre remote will start blinking.
In my case i only lights up permanently for a minute or so and then switches off again.

It seems to be a broken dongle?!

Inser the dongle in the Vero 4K and post a debug log.

I’m sorry, but what do I have to do?

The log doesn’t show the dongle connected. If it is connected, it’s faulty. Send me a PM and we can arrange to have it replaced for you.