New Vero 4K / slow network performance

Hello, sorry for my bad english, i´m from germany.

My Vero 4K has arrived, i put it on my setup, but the network is very slow. Every movie is stuttering and the HD Audio is going on and off.

I tried Ethernet Port / Wlan 5Ghz and a Gigabit to Usb adapter. My Network is Gigiabit Lan.
The movies are on a Synology DS2014 per nfs.

With my Shield every movie (BD untouched) works fine.

I read about fstab mount nfs share, is there any tutorial? I´m a linux noob.

thx Tim

There’s a wiki about using fstab with Samba shares:

You might also want to look at changing the default video cache settings. That often helps. Here’s a post with a good starting point for video cache:

If it’s not clear, the settings go in file ~/.kodi/userdata/advancedsettings.xml

No tutorial but the steps should be clear

I personally prefer SMB as I want access from Windows machines as well and have setup proper credentials. Also I need some features that NFS does not provide and have as most probably do a heterogeneous environment (Windows, Linux and in my case even a Mac). Biggest no no is for me that NFS does not support user authentication and only IP based authentication. That’s a no go. Yes, I know you can setup NIS. Welcome back to the 80s. NFS is only enabled for me for OS network installations on that specific share.

Yes, NFS is a tad faster for streaming your files, but that is rarely a problem. For Kodi the point between SMB vs. NFS is rendered mute by the fact that we just fill a buffer and plays. The theoretical max performance difference because of less overhead plays absolute no role in the end. Any network throughput test do not reflect the actual usage case you have with Kodi.

If Kodi cannot fill its buffer fast enough for playback then you have a general network performance problem. For example 4K media with a very high bit rate that your network can barely handle to begin with.

But sure if you have no other requirements beside everyone can access a share from Linux then you can use NFS as well. And if you talking server to server transfer, well use ZFS. Hey, you can even use SSHFS or FTP. Really, doesn’t matter in the end.

Choose your poison. There is no right/wrong or better/worse. And for the Kodi usage case it does not matter at all, as long as your network, file server and configuration is proper; the filesystem you are using plays no real role.

Proper SMB setup with a Synology and a Vero 4K

On the Synology:

Control Panel -> File Services -> Enable SMB Service
Click on Advanced Settings

  • WINS Server: Leave Empty
  • Maximum Supported SMB Protocol: SMB3
  • Minimum Supported SMB Protocol: SMB2 (SMB1 if you have ancient clients that require a 30 year old version - if all clients support SMB3, wenn you can even turn off SMB2)
  • Transport Encryption Mode: Auto
  • Enable Opportunistic: Locking: Checked
  • Enable SMB2 Leave: Checked
  • Enable Local Master Browner. Not checked (unless you really want to, HDDs will not hibernate)
  • Enable DirtSort VFS module: Not Checked - no real benefit in server side sorting.
  • Veto Files: Not Checked
  • Allow Symbolic Links within Shared Folders: check if you use them
  • Allow Symbolic Links across Shared Folders: check if you use them and they go between shares

Then you have it setup nicely on your Synology. Check from your Windows client. It should be snappy even when you access folder with several 1000 files.

The Synology defaults are not very good as they kept it compatible with everything. Especially browsing shares is slow out of the box. Same for other NAS. There are a few more hacks you can do to the server side SMB configuration. But this is usually not needed unless you tempered with related stuff under the hood on your Synology or have some really huge file lists (e.g. 100,000+)

On the Vero 4K side:

As Kodi does not use libsmbclient properly (not going into details), it basically behaves like the 30 year old SMB1, we let the OS fulfill all our needs. At least libsmbclient allows you to configure stuff with a user config file. But why bother? It is still bad inside Kodi no matter what protocol version you are using - though for just streaming a file it is ok. But it makes stuff like scanning libraries/cleaning terrible slow. NFS is not much better inside Kodi, Better let the OS handle your network needs with Kodi whenever possible.

And SMB1 is not secure. Ransom Ware uses SMB1 security problems to propagate many times in the past. It was finally turned off in Win 10 per default in the Fall Creators Update if I remember correctly. About time. You can’t fix problems with a 30 year old protocol, especially when there is no reason to use it in the first place.

So we let the OS handle everything and it can even read ahead for a better caching experience.

To mount folders automatically we will edit /etc/fstab

Here is how you set it up nicely:

  1. Create a file for your SMB credentials in the OSMC user’s home dir. I named mine .smbcredentials The content looks like this:


Just fill in what user you want to use to access your diskstation and the appropiate password. Saves us typing it later and other users cannot see the credentials. Just good practice.

  1. Edit the /etc/fstab files and add one line for each share like this:

//Diskstation/Movies /mnt/Movies/ cifs noauto,x-systemd.automount,vers=3.0,sec=ntlmssp,credentials=/home/osmc/.smbcredentials,uid=1000,gid=1000,iocharset=utf8

That’s all one line.

Also make sure you created the directory for mounting sudo mkdir /mnt/Movies

Let me go over the parameters quickly, so you understand them.

  1. Name of the share. They are in the format //SERVER/SHARE. If you have spaces in your shares you need to write them as \040 (it’s the character code for space as the character space itself is used as a separation character). If you have no proper local DNS resolution you can use the IP instead of the server name. But well if you have a Synology you probably setup a Dynamic DNS with reverse lookup zones anyway, with your router as a secondary DNS.

  2. Where to mount. We mount everything under /mnt in their own directory per share. Need to be created of course.

  3. cifs - tells the system it is an SMB mount. CIFS was the initial name for SMB. It was basically SMB1. Though newer versions are supported by Samba the parameters was not changed even tough SMB has not much in common with CIFS anymore. Yeah, just adds to the confusion.

  4. noauto,x-system.automount - we will automount the shares at boot time. Don’t worry Synology HDDs will still hibernate properly when there is no file access (unless HDDs have crappy firmware and never hibernate properly to begin with when appropiate)

  5. vers=3.0 - the SMB version we are using. Let’s go for 3. You can also use 2.0 or 2.1 if prefer that. But we are not doing anything fancy where 2.1 or above are lacking features in Samba’s SMB implementation and neither we are missing kernel support. Same stuff as on the Diskstation.

  6. sec=ntlmssp - security mode to authenticate. We are using what modern Windows versions are using.

  7. credentials=FILE - we point to the user/password file we created eariler

  8. uid=1000, gid=1000 = mapping the user/group we are in when accessing the SMB share to our local OSMC user so we see the proper username and group and not some cryptic values from the command line as user/group ID as the ones the NAS do not match the local ones, which they usually never do.

  9. iocharset=utf8 - to deal with special chars in filenames. We do not live in a 7bit ASCII world anymore.

After a reboot (or restarting the service) your shares should be there. SSH into the box and look at the directories. If you did everything correctly they should be accessible like everything else. And file access is controlled by the permissions you set on the Synology. And you can even set Symlinks easily!

I use them a lot to create duplicate files like having a custom Movie Sets in Kodi but still have file as well the movie in the proper location (e.g. Terminator shows up under my Schwarzenegger Set but as well under a Terminator Collection). Also files are linked from various shares into a main share and even from another server. For my symlinking needs. I just fire off one script that updates/remove links when I add new files.

I like symlinking in my library a lot as how it appears to the network is not necessarily the same as on the file storage itself. I simulate a low footprint virtual file system with it for Kodi to access. Kodi only accesses one share per media type on my Synology that only consists of Symlinks to other shares (hidden from network browsing) that even might be on different machines (can even be over VPN connections if you have the bandwidth).

This is one reason why I need SMB beside user authentication, as for NFS I would need to mount all the shares with the same name as symlinking is resolved on the client and not on the server. NFS is just leightweight, hence a tad faster but lacking more options.

Now the paths might be different if you scanned files into your library from SMB, NFS or whatever url before. But no problem we can use path substitution for it instead of rescanning.

Here an example how to do it in the advancedconfig.xml


With that we basically tell Kodi everytime it access the network URL it should use the path we defined. We just redirect it.

Now Kodi does not use any SMB itself, the OS handles it. You might see Kodi using SMB shares of course if you access file sources as network URLs. Well you can use the above path now as your new source folders and that problem is also gone.

With multiple clients you might need different mappings. I personally leave the sources always as SMB so I can easily map them to other directories on clients as needed - I scan from a Windows box where I encode my DVDs/Bluray/Recordings anyway. Don’t use Kodi as a player there at all. But well multiple clients, central library is a different topic.

Also make sure you setup the caching in Kodi - as already explained by other… As the Vero 4K has more RAM you can use usually more than on older device. Helps when data cannot delivered as fast as required. But only up to a certain point naturally. Anything in the 200-500 range should be fine. Though I am not sure anymore that Kodi still uses 3 times what is defined here (can someone verify that this is still the case?. Anyway tweak the size as needed. But it’s no magic pill. I currently have 200MB setup.

You find a lot of posts how to customize the caching here, though for the Vero future updates will probably have higher defaults out of the box (guess with Dec '17 update?)


Nicely detailed.

Thanks all for the many suggestions.

I will give it a try at the weekend.

Hi there,

just tried to fowllo these instructions to mount via fstab.
I think I managed (the vero should reboot as I write).
But: I made 2 folders in /mnt to match my folders on the synology, “Filme” and “Serien”.
But in side the osmc directory are still the “Movies” etc folder which I can see in the skin.
Do I still have to configure the surces (and scrapers and so on) inside kodi? How do I make the connection to the folders I just (hopefully) mounted via fstab?

Yes you need to add them as sources. You will find them under Root Folder / mnt / Filme

Ah, ok. Because I just looked and I just see the Entries Movies Music etc in the OSMC skin.
Allright, then I’ll dig out the tutorial for configuring the sources, and report back.

Ok. All is up and running. Added my Picture Folder via fstab as well for the slideshow screensaver.
Thanks everyone so far.
I will test everything in the next few days.

Hello and thanks for the detailed instructions.
i set everything as described.

as i am using mysql for saving movie information and stats in a database and using several kodis i am wondering about the path substitution.
kodi is loading the media infos from the db with the information the file is located at
advancedsettings.xml tells with path substitution to replace that string with /mnt/Media

so acutally i dont have to add any sources on kodi, right? how can i check if kodi uses fstab instead of kodi based smb client?

p.s. i am trying this for performance problems, as 60mbit UHD hevc files had problems with smooth playback…



When kodi uses the fstab mount, the source is /mnt/Media, not smb://synologynas/Media

See post 2 by dilthedog, it links a wiki for setting up fstab.

As for substitutions:

Thanks Tom.

but when i change the source in kodi doesnt it change the location in the database from smb to /mnt?

i thought the sence of pathsubstitution is that the db is untouched (smb:// is used) and it replaces the string just on the client site?

my advancedsettings.xml looks like this:

<?xml version="1.0" encoding="utf-8"?>



my fstab looks like this:

// /mnt/Media/ cifs noauto,x-systemd.automount,vers=3.0,sec=ntlmssp,credentials=/home/osmc/.smbcredentials,uid=1000,gid=1000,iocharset=utf8
// /mnt/usbshare2/ cifs noauto,x-systemd.automount,vers=3.0,sec=ntlmssp,credentials=/home/osmc/.smbcredentials,uid=1000,gid=1000,iocharset=utf8

but in the logs it keeps telling me that the files played through smb://

VideoPlayer: Opening: smb://
i would expect this:
VideoPlayer: Opening: /mnt/Media/Filme/HD/movie.mkv


This should be in a single “pathsubstitution” section.

1 Like


like this?

Yes, while obviously closed by a </pathsubstitution>

ok, but in the logs it still shows playback from:

NOTICE: VideoPlayer: Opening: smb://

Enable debugging and provide full logs so that we can check what might be wrong.

the logs:

11:42:14.115 T:4080292432  NOTICE: special://profile/ is mapped to: special://masterprofile/
11:42:14.115 T:4080292432  NOTICE: -----------------------------------------------------------------------
11:42:14.115 T:4080292432  NOTICE: Starting Kodi (17.6). Platform: Linux ARM (Thumb) 32-bit
11:42:14.115 T:4080292432  NOTICE: Using Release Kodi x32 build (version for Vero)
11:42:14.115 T:4080292432  NOTICE: Kodi compiled Mar 12 2018 by GCC 6.3.0 for Linux ARM (Thumb) 32-bit version 4.9.30 (264478)
11:42:14.115 T:4080292432  NOTICE: Running on Open Source Media Center 2018.03-2, kernel: Linux ARM 32-bit version 3.14.29-69-osmc
11:42:14.115 T:4080292432  NOTICE: FFmpeg version/source: ffmpeg-3.1-kodi
11:42:14.115 T:4080292432  NOTICE: Host CPU: AArch64 Processor rev 4 (aarch64), 4 cores available
11:42:14.115 T:4080292432  NOTICE: ARM Features: Neon disabled
11:42:14.115 T:4080292432  NOTICE: special://xbmc/ is mapped to: /usr/share/kodi
11:42:14.115 T:4080292432  NOTICE: special://xbmcbin/ is mapped to: /usr/lib/kodi
11:42:14.115 T:4080292432  NOTICE: special://xbmcbinaddons/ is mapped to: /usr/lib/kodi/addons
11:42:14.115 T:4080292432  NOTICE: special://masterprofile/ is mapped to: /home/osmc/.kodi/userdata
11:42:14.115 T:4080292432  NOTICE: special://envhome/ is mapped to: /home/osmc
11:42:14.115 T:4080292432  NOTICE: special://home/ is mapped to: /home/osmc/.kodi
11:42:14.115 T:4080292432  NOTICE: special://temp/ is mapped to: /home/osmc/.kodi/temp
11:42:14.115 T:4080292432  NOTICE: special://logpath/ is mapped to: /home/osmc/.kodi/temp
11:42:14.115 T:4080292432  NOTICE: The executable running is: /usr/lib/kodi/kodi.bin
11:42:14.115 T:4080292432  NOTICE: Local hostname: VERO4K
11:42:14.115 T:4080292432  NOTICE: Log File is located: /home/osmc/.kodi/temp//kodi.log
11:42:14.116 T:4080292432  NOTICE: -----------------------------------------------------------------------
11:42:14.147 T:4080292432   ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
11:42:14.240 T:4080292432  NOTICE: load settings...
11:42:14.241 T:4080292432  NOTICE: AML device detected
11:42:14.306 T:4080292432  NOTICE: Found 1 Lists of Devices
11:42:14.306 T:4080292432  NOTICE: Enumerated ALSA devices:
11:42:14.306 T:4080292432  NOTICE:     Device 1
11:42:14.307 T:4080292432  NOTICE:         m_deviceName      : default
11:42:14.307 T:4080292432  NOTICE:         m_displayName     : Default (AML-M8AUDIO Analog)
11:42:14.307 T:4080292432  NOTICE:         m_displayNameExtra: PCM
11:42:14.307 T:4080292432  NOTICE:         m_deviceType      : AE_DEVTYPE_PCM
11:42:14.307 T:4080292432  NOTICE:         m_channels        : FL,FR,UNKNOWN1,LFE,FC,BC,BL,BR,BLOC,BROC
11:42:14.307 T:4080292432  NOTICE:         m_sampleRates     : 32000,44100,48000,88200,96000,176400,192000
11:42:14.307 T:4080292432  NOTICE:         m_dataFormats     : AE_FMT_S32NE,AE_FMT_S16NE,AE_FMT_S16LE
11:42:14.307 T:4080292432  NOTICE:         m_streamTypes     : No passthrough capabilities
11:42:14.307 T:4080292432  NOTICE:     Device 2
11:42:14.307 T:4080292432  NOTICE:         m_deviceName      : hdmi:CARD=AMLM8AUDIO,DEV=0
11:42:14.307 T:4080292432  NOTICE:         m_displayName     : AML-M8AUDIO
11:42:14.307 T:4080292432  NOTICE:         m_displayNameExtra: HDMI
11:42:14.307 T:4080292432  NOTICE:         m_deviceType      : AE_DEVTYPE_HDMI
11:42:14.307 T:4080292432  NOTICE:         m_channels        : FL,FR,BL,BR,FC,LFE,SL,SR
11:42:14.307 T:4080292432  NOTICE:         m_sampleRates     : 32000,44100,48000,88200,96000,176400,192000
11:42:14.307 T:4080292432  NOTICE:         m_dataFormats     : AE_FMT_S16NE,AE_FMT_S16LE,AE_FMT_RAW
11:42:14.315 T:4080292432  NOTICE: Loaded settings file from special://xbmc/system/advancedsettings.xml
11:42:14.316 T:4080292432  NOTICE: Contents of special://xbmc/system/advancedsettings.xml are...
                                            <?xml version="1.0" encoding="UTF-8" ?>
                                            <!-- Do not modify! These are OSMC Optimised Settings for your device  !-->
                                            <!-- If you wish to override any of these values, then create a file in /home/osmc/.kodi/userdata/advancedsettings.xml !-->
                                            <!-- It will override these settings, and your settings will be preserved across OSMC updates !-->
11:42:14.320 T:4080292432  NOTICE: Loaded settings file from special://profile/advancedsettings.xml
11:42:14.320 T:4080292432  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <?xml version="1.0" encoding="utf-8" ?>
11:42:14.320 T:4080292432 WARNING: VIDEO database configuration is experimental.
11:42:14.321 T:4080292432  NOTICE: Default Video Player: VideoPlayer
11:42:14.321 T:4080292432  NOTICE: Default Audio Player: paplayer
11:42:14.321 T:4080292432  NOTICE: Disabled debug logging due to GUI setting. Level 0.
11:42:14.321 T:4080292432  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"
11:42:14.321 T:4080292432  NOTICE: CMediaSourceSettings: loading media sources from special://masterprofile/sources.xml
11:42:14.322 T:4080292432  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
11:42:14.323 T:4080292432  NOTICE: Loaded playercorefactory configuration
11:42:14.323 T:4080292432  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
11:42:14.323 T:4080292432  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
11:42:14.451 T:4080292432  NOTICE: Running database version Addons27
11:42:14.737 T:4080292432  NOTICE: ADDONS: Using repository
11:42:15.012 T:4080292432  NOTICE: InitWindowSystem: Using EGL Implementation: amlogic
11:42:15.056 T:4080292432   ERROR: GetString: error reading /home/osmc/.kodi/userdata/disp_cap
11:42:15.057 T:4080292432  NOTICE: Found resolution 1280 x 720 for display 0 with 1280 x 720 @ 60.000000 Hz
11:42:15.057 T:4080292432  NOTICE: Found resolution 1280 x 720 for display 0 with 1280 x 720 @ 59.940060 Hz
11:42:15.057 T:4080292432  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080i @ 60.000000 Hz
11:42:15.057 T:4080292432  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080i @ 59.940060 Hz
11:42:15.057 T:4080292432  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080 @ 60.000000 Hz
11:42:15.057 T:4080292432  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080 @ 59.940060 Hz
11:42:15.057 T:4080292432  NOTICE: Found resolution 1280 x 720 for display 0 with 1280 x 720 @ 50.000000 Hz
11:42:15.057 T:4080292432  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080i @ 50.000000 Hz
11:42:15.057 T:4080292432  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080 @ 50.000000 Hz
11:42:15.057 T:4080292432  NOTICE: Found (1920x1080@60.000000) at 20, setting to RES_DESKTOP at 16
11:42:15.057 T:4080292432  NOTICE: Checking resolution 21
11:42:26.351 T:4080292432  NOTICE: GL_VENDOR = ARM
11:42:26.351 T:4080292432  NOTICE: GL_RENDERER = Mali-450 MP
11:42:26.351 T:4080292432  NOTICE: GL_VERSION = OpenGL ES 2.0
11:42:26.351 T:4080292432  NOTICE: GL_SHADING_LANGUAGE_VERSION = OpenGL ES GLSL ES 1.00
11:42:26.351 T:4080292432  NOTICE: GL_EXTENSIONS = GL_OES_texture_npot GL_OES_vertex_array_object GL_OES_compressed_ETC1_RGB8_texture GL_EXT_compressed_ETC1_RGB8_sub_texture GL_OES_standard_derivatives GL_OES_EGL_image GL_OES_depth24 GL_ARM_rgba8 GL_ARM_mali_shader_binary GL_OES_depth_texture GL_OES_packed_depth_stencil GL_EXT_texture_format_BGRA8888 GL_OES_vertex_half_float GL_EXT_blend_minmax GL_OES_EGL_image_external GL_OES_EGL_sync GL_OES_rgb8_rgba8 GL_EXT_multisampled_render_to_texture GL_EXT_discard_framebuffer GL_OES_get_program_binary GL_ARM_mali_program_binary GL_EXT_shader_texture_lod GL_EXT_robustness GL_OES_depth_texture_cube_map GL_KHR_debug GL_ARM_shader_framebuffer_fetch GL_ARM_shader_framebuffer_fetch_depth_stencil GL_OES_mapbuffer
11:42:26.985 T:4060082944  NOTICE: Running database version Addons27
11:42:26.987 T:4060082944  NOTICE: Running database version ViewModes6
11:42:26.990 T:4060082944  NOTICE: Running database version Textures13
11:42:27.036 T:4060082944  NOTICE: Running database version MyMusic60
11:42:27.099 T:3979117312  NOTICE: Register - new cec device registered on cec->AOCEC: CEC Adapter (0000:0000)
11:42:27.171 T:4060082944  NOTICE: Running database version MyVideos107
11:42:27.173 T:4060082944  NOTICE: Running database version TV29
11:42:27.176 T:4060082944  NOTICE: Running database version Epg11
11:42:27.178 T:4080292432  NOTICE: start dvd mediatype detection
11:42:27.747 T:4080292432 WARNING: JSONRPC: Could not parse type "Setting.Details.SettingList"
11:42:28.859 T:4080292432  NOTICE: UpdateLibraries: Starting video library startup scan
11:42:28.982 T:4080292432  NOTICE: initialize done
11:42:28.982 T:4080292432  NOTICE: Running the application...
11:42:28.997 T:4080292432  NOTICE: starting zeroconf publishing
11:42:28.998 T:4080292432  NOTICE: CWebServer[80]: Started
11:42:28.998 T:4080292432  NOTICE: starting upnp client
11:42:29.000 T:3768038144  NOTICE: ES: Starting UDP Event server on port 9777
11:42:29.000 T:3768038144  NOTICE: UDP: Listening on port 9777 (ipv6 : true)
11:42:33.859 T:3835147008  NOTICE: [] Startup: detected Krypton (Kodi-17.6), DASH_SUPPORT_ADDON = True
11:42:34.371 T:3873436416 WARNING: CSkinInfo: failed to load skin settings
11:42:36.770 T:3853513472  NOTICE: VideoInfoScanner: Starting scan ..
11:42:43.168 T:4060082944  NOTICE: Start - EPG thread started
11:44:29.068 T:3853513472  NOTICE: VideoInfoScanner: Finished scan. Scanning for video info took 01:52
11:44:48.590 T:4080292432  NOTICE: VideoPlayer: Opening: smb://
11:44:48.590 T:4080292432 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
11:44:48.592 T:3556766464  NOTICE: Creating InputStream
11:44:48.915 T:3556766464  NOTICE: Creating Demuxer
11:44:49.263 T:3556766464  NOTICE: Opening stream: 0 source: 256
11:44:49.263 T:3556766464  NOTICE: Creating video codec with codec id: 174
11:44:49.265 T:3556766464   ERROR: Unable to load, reason: cannot open shared object file: No such file or directory
11:44:49.265 T:3556766464 WARNING: CAMLCodec::CAMLCodec not found, trying instead
11:44:49.275 T:3556766464  NOTICE: Creating video thread
11:44:49.275 T:3571446528  NOTICE: running thread: video_thread
11:44:49.278 T:3556766464  NOTICE: Opening stream: 1 source: 256
11:44:49.278 T:3556766464  NOTICE: Finding audio codec for: 86020
11:44:49.278 T:3556766464  NOTICE: Creating audio thread
11:44:49.278 T:3526357760  NOTICE: running thread: CVideoPlayerAudio::Process()
11:44:49.278 T:3556766464  NOTICE: Opening stream: 3 source: 256
11:44:49.296 T:3526357760  NOTICE: Creating audio stream (codec id: 86020, channels: 6, sample rate: 48000, pass-through)
11:44:49.389 T:4080292432  NOTICE: Display resolution ADJUST : 1920x1080 @ 59.94 - Full Screen (21) (weight: 0.000)
11:44:49.467 T:3571446528  NOTICE: CAMLCodec::OpenDecoder - using V4L2 pts format: 64Bit
11:44:49.498 T:3526357760   ERROR: CAEStreamInfo::GetDuration - invalid stream type
11:44:49.879 T:4080292432   ERROR: Previous line repeats 1 times.
11:44:49.879 T:4080292432  NOTICE: Display resolution ADJUST : 1920x1080 @ 59.94 - Full Screen (21) (weight: 0.000)

That is not debug enabled log. Please enable debug logging and then upload grab-logs -A and share the URL.