New Vero 4K unable to see any WiFi Networks

When I enable the wireless adapter on my Vero 4K there is a pause for 10 seconds or so, and then nothing shows in the right hand panel. The same applies when I tried over at my friend’s house. Using my Android phone I can see several available networks but nothing shows on the Vero. I have re-installed OSMC and all settings are at default.


can you provide a set of logs? See How to submit a useful support request and paste the URL of the uploaded logs, here.

In addition what is the output if you connect to the Vero via SSH as user osmc/osmc and invoke the commands

osmc@osmc-vero4k:~$ sudo connmanctl
connmanctl> agent on
connmanctl> enable wifi
connmanctl> scan wifi

wait a minute

connmanctl> services
connmanctl> exit

Hi Jim
Thank you for the reply. I’ll see what I can do about logs, in the meantime this is what I get from SSH:
osmc@osmc-Cuthbert:~$ sudo connmanctl
Error getting VPN connections: The name net.connman.vpn was not provided by any connmanctl> agent on
Agent registered
connmanctl> enable wifi
Error wifi: Already enabled
connmanctl> scan wifi
Error /net/connman/technology/wifi: No carrier
connmanctl> services
*AO Wired ethernet_c44eac10b9fd_cable
connmanctl> exit

Does this look OK?

I think because you got your ethernet connected, when you pull out that cable wifi probably starts working.

Dunno if you can have both enabled, one of the mods can probably say more about that :slight_smile:

I only connected the ethernet because I couldn’t get wifi working. So ethernet disabled and cable disconnected makes no difference.

  1. Is the WiFi access point close by?

  2. Are you using a hidden SSID?

  3. What’s the output from running connmanctl technologies?

  4. When the ethernet cable is connected, connman will favour wired over wireless. That shouldn’t stop you trying to connect to wireless later.

  1. I have plenty of signal from my router. especially on 2.4G
  2. SSID are not hidden. I can;t see my neighbours networks which I can see on my phone.

osmc@osmc-Cuthbert:~$ connmanctl technologies
Name = WiFi
Type = wifi
Powered = True
Connected = False
Tethering = False
TetheringIdentifier = osmc_wifi
TetheringPassphrase = h0tsp0t0smc
Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False
Name = Bluetooth
Type = bluetooth
Powered = False
Connected = False
Tethering = False

I suggest you switch off tethering for now. It might be causing an issue, so let’s try to keep things simple.

Tethering is not enabled.

Could you run

connmanctl enable wifi

Then provide logs using grab-logs -J -K

will do now

Something is happening that’s causing the WiFi chip to crash:

Jan 06 18:31:01 osmc-Cuthbert kernel: wl_android_wifi_on: Failed
Jan 06 18:31:01 osmc-Cuthbert kernel: dhd_open : wl_android_wifi_on failed (-14)
Jan 06 18:31:01 osmc-Cuthbert kernel: dhd_stop: Enter ffffffc060818800
Jan 06 18:31:01 osmc-Cuthbert kernel: wl_android_wifi_off in 1
Jan 06 18:31:01 osmc-Cuthbert kernel: wl_android_wifi_off in 2: g_wifi_on=0
Jan 06 18:31:01 osmc-Cuthbert kernel: wl_android_wifi_off out
Jan 06 18:31:01 osmc-Cuthbert kernel: dhd_stop: Exit
Jan 06 18:31:01 osmc-Cuthbert kernel: dhd_open: Exit ret=-1
Jan 06 18:31:01 osmc-Cuthbert kernel: CFG80211-ERROR) wl_cfg80211_hang : In : chip crash eventing

The second log is a little different but wl_android_wifi_on still fails with a return code of -14.

Could you run the following:

sudo apt-get update
sudo apt-get install rfkill
rfkill list

and show the output from rfkill list.

osmc@osmc-Cuthbert:~$ rfkill list
0: bt-dev: Bluetooth
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
2: brcmfmac-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no

Do you have a WiFi dongle attached?

nope, only internal adapter

Did it ever work before?
Maybe it’s a faulty adapter, in which case this would need to be replaced under warranty.


Hi Sam
It worked for about a week. But then 5G disappeared from discovery then a day later 2.4G disappeared along with other neighbouring networks.

If you have a USB stick or micro SD handy, I’d recommend reinstalling OSMC from without Ethernet attached.

Try and go through the setup steps for WiFi.
If this still fails, send me a PM and we will organise a replacement unit for you.