New Vero 4K wont see my Windows 10 network shares

I’ve just received my new Vero 4K and am very impressed with the speedy service and device apart from one thing.
I’m serving my media throughout my home from a Windows 10 PC running the Fall Creators update and my new Vero will not see or connect to these shares.
All my other devices see the shares including 2 Fire TV 2nd gen boxes and 2 Windows 10 HTPC’s.
I’m unsure if this is caused by a setting within Windows or the Vero 4K that needs changing.
So far I’ve tried giving all permissions access to any device on the network and turning off password sharing but the Vero 4K still isn’t seeing any shares.
I know its connected to the network and internet because the HD Homerun addon works showing its getting connections from my network and the Iplayerwww addon also works showing it has an internet connection.

Any suggestions for things to try will be more than welcome.

Well I assume with “seeing” you mean you can not browse them. Browsing windows shares is a feature of smb1 which has been disabled for security reasons (WannaCry attack) in OSMC. Actually Windows 10 also disable it in the last update if you don’t use it for 10 days.

Anyhow you should be able to add your Windows 10 manually via network source or for more performance via fstab

I should elaborate, for years I’ve never been able to get Kodi to see any Windows network shares across various PC’s and OS’s using he browse function,
my workaround has been to enter the address manually,
I.E. “smb://my-pc/movies”
Kodi will then connect to the share and carry on with the rest of its functions, like entering the user and password, setting the content type etc.
With my new Vero 4K I first get the message “operation not permitted” then when I click on ok I get “Couldn’t retrieve directory information. This could be due to the network not being connected. Would you like to add it anyway?”

As I have already proved the network is connected and I now need some guidance for how to proceed, I don’t really want to set up fstab if I don’t need to as I assume that will effect the devices already using my network without any issues.

I have tried the same on another Windows 10 Fall Creators update PC connected to the network and get the same error,
I feel either my Vero 4K is faulty or there’s a setting within it that needs to be changed

To add I get the same non connection via Ethernet or wifi connections.
I really want to like and keep my Vero 4K but its certainly not an out of the box solution and if it can’t connect to my network shares correctly I’m afraid I shall be returning it

using fstab would not impact any of your other devices and would be much more performant than using Kodi build in smb client. If you use a shared MYSQL database between your clients the only thing you need to do is set path substitution

You Vero is definitely not faulty, just as mentioned after the Wannacry attack the minimal protocol support was changed in Kodi for security measures.
If you insists on using Kodi you tried to change the max protocol under Settings -> Services -> SMB Client -> Maximum Protocol version

Are you using a static IP or the hostname of your PC? The IP is a better option.

It isn’t a fault with Vero 4K. SMB browsing is deprecated for security reasons. As more and more devices get firmware updates, you will see browsing disabled on those devices too.

For now you can work around it by setting SMB level to v1 — but we do not recommend this

Ok I give up, sorry @sam_nazarko but I did ask the pertinent questions before I ordered this device.
I have now installed putty on my PC and apart from being able to login to my Vero 4K every command I enter from the guides comes up with a command not recognised error.
I thought the Vero 4K was the out of the box solution for me but it obviously isn’t as it will not work with my Windows shares when every other device I own does (I did try entering the IP rather than the PC name too).

I think I’ll be sending it back under the 30 day satisfaction guarantee, as well as the new 4K HDR TV I have back to Amazon.
Its no fault of yours but I have spent a week and a half trying to get 4K HDR working reliably , I thought the Vero 4K was the solution to my needs but it clearly isn’t.
I think I am going to go back to 1080P HD until the 4K market has matured.

You’re probably going to have some problems in a weeks / months with legacy devices. MS have stated they are completely removing SMBv1 support from Windows 10 (apart from Enterprise editions) in the future.

There’s not much we can do about that. But security is important. If other vendors are also dropping SMBv1 support, you can be sure that there is a very good reason.

SMB browsing being removed does not mean SMB support is gone however.

You don’t need to use the command line to access your shares however. It would have been good to see a photo of the error on screen and a photo of the share to see how you had tried to add it to Kodi.

We’re happy to help you with this. It shouldn’t take long to resolve this if you are happy to help us help you.


Sorry I missed the part about photos
here are the pertinent ones

Did you try this suggestion? But remember that it’s probably a temporary fix. As @sam_nazarko said, SMB browsing will be disabled in Windows 10 soon.

Really you should do as @fzinken suggested and use fstab mounts, and path substitution if needed.

You are using a hostname rather than an IP here.

Please enable debug logging, repeat the attempt to add sources and then upload a full set of logs via My OSMC -> Logs


I’ve uploaded the log its here

You have the IP of your server wrong: 192/168.2.128

My bad, here’s the log with the correct IP

It may not be much comfort to you but I can’t access Win10 shares from any device other than another Win10 machine. This is after ‘upgrading’ to the Fall Creators edition yesterday.

Any other device means Rpi, Vero, Android tablet, Android phone, Linux laptop.

And just to be sure, created a new share with all the right permissions (I’ve had issues with that before) and can’t see that either. Windows gurus required…

Ok I’ve sussed it for now,
I went to settings then services then SMB client and set the maximum protocol version to none and I can now access my Windows shares.
I’d like to know if this has any bearing on my network security though (my networking knowledge is almost non existent as you can see from this thread lol)

I’ve just managed to make it work by downgrading the Win10 server:


Something tells me my method will be a security issue, but perhaps only if you have other Windows machines on the LAN.

@grahamh try entering the IP rather than the name on your other devices, I’ve found on my Vero at least using the name results in getting as far as entering the share user name and password (which I entered correctly) then getting no connection, but with the IP it works.
From everything I’ve read these past two days downgrading to SMB V1 should only be done as a temporary measure

I always use IP addresses.

Actually, I still can’t connect through the Kodi gui, only by mounting the the shares with systemd.

I can’t browse for the shares from Kodi but I can from Linux Mint. Go figure.

Glad you solved it. Strange you can’t play 4k on a brand-new TV, though.

The only security issue would be if your LAN was compromised or if you were for some reason attempting to pass access to your windows shares outside your LAN. If you are confident that your firewall is secure then you should be fine.